1 (edited by ionutm80 17-05-2016 10:32:39)

Topic: How to ensure perfect or close to 59.94 with NVidia

Hi,

I have a question that might not be directly related to SVP usage so apologizes to the admins in advance / please delete the thread if the case.
So briefly my problem is the following:
- my chain: TV Philips 32PFL9632 with PC input frequency only 60Hz (nothing else possible), HTPC with GeForce GTX 960, Win 10
- madVR set to automatically change resolution for 1080p59 and 1080p60 (I've red somewhere that in Win 10 59 and 60 are practically the same thing...)
- madVR stats: display: 59.937xxx, composition rate: 59.940 which results in 1 frame repeat every xy seconds / 1 frame drop every 19.48 min after I go fullscreen

http://i.imgur.com/IGVLpJS.jpg

I have another set-up with a Sony KDL-26EX320 and Intel HD Graphics 4400 for which madVR stats reports display as 59.94005, composition rate 59.940 which practically results in 1 drop frame every 1.x hours.

And now the question: on my first system (Philips TV + GTX 960) the fact that I do not have a much close to 59.94 resolution for display is because of the TV or the NVidia not outputting correct resolution when set to 60Hz?
I've red also on NVidia forums that in order to get something like 59.94 for NVidia you need to create a custom resolution with the following settings:

Horizontal Pixels: 1919 Vertical Lines: 1080
Refresh Rate: 60Hz Color Depth: 32 Bit
Scan Type: Progressive
Timing
front porch horizontal: 88 vertical: 4
sync width horizontal: 44 vertical: 5
total pixels horizontal: 2200 vertical: 1124
refresh rate: 59.940

I'm still reluctant to check this because last time I broke the entire system and had to do a full Win 10 reset to fix things ...

Can you please advise on this? What would be the best settings to achieve the same results as with Sony TV and Intel GPU, meaning something almost identic to 59.9400xyz?
Or there is no chance due to TV or the way NVidia is outputting resolution?
I'm asking this because on Sony+Intel system letting madVR handle resolutions allowed me to switch to a x64 chain w/o ReClock while on Philips + NVidia I can only achieve 1 frame drop in 4.xyz hours on the x86 chain with ReClock.

Thanks a lot in advance and please excuse my ignorance.

Re: How to ensure perfect or close to 59.94 with NVidia

ionutm80

I do not have a much close to 59.94 resolution for display is because of the TV or the NVidia not outputting correct resolution when set to 60Hz?

You can add custom resolution wih exactly 59.94 Hz refreshrate.
NVIDIA control panel - Resolution change - Custom... - Add users resolution... - Accept - fill 1920x1080@60 - change Auto to Manual - Type refreshrate 59.94 - Test - OK

In my case it works without broke entire system. Use 15 seconds mode (no key press if no picture on the screen) to recover unproper settings.

Re: How to ensure perfect or close to 59.94 with NVidia

OK, thanks. Will test that and see what happens.

Re: How to ensure perfect or close to 59.94 with NVidia

ionutm80 wrote:

OK, thanks. Will test that and see what happens.

Check the attachment of my setting for exact 60fps smile

Post's attachments

exact60fps.png, 248.35 kb, 782 x 483
exact60fps.png 248.35 kb, 344 downloads since 2016-05-17 

5 (edited by ionutm80 17-05-2016 10:34:51)

Re: How to ensure perfect or close to 59.94 with NVidia

mashingan wrote:

Check the attachment of my setting for exact 60fps smile

Hi, Am I missing something here ... or in fact for you is the same because display is at 59.974... and composition rate at perfect 60 which also translates in dropped frames.
My problems is not with the composition rate but with the display rate enforced by NVidia driver being 59.937 instead of 59.9400x as I'm getting with Intel HD4400 for instance ...
Or I'm loosing something?

Re: How to ensure perfect or close to 59.94 with NVidia

ionutm80 wrote:

Hi, Am I missing something here ... or in fact for you is the same because display is at 59.974... and composition rate at perfect 60 which also translates in dropped frames.
My problems is not with the composition rate but with the display rate enforced by NVidia driver being 59.937 instead of 59.9400x as I'm getting with Intel HD4400 for instance ...
Or I'm loosing something?

Oh, sorry, I misunderstood your first post.

So, you want to make whether the SVP or display rate match exact each other, right?

If your concern about the different about ~0.01 which the cause of dropped frames, you can rest easy that it wasn't the case.
Dropped frames is purely because the system couldn't keep up with the calculation so in order to sync with the audio, the renderer starts dropping frames (CMIIW).

In my case, the current system I have has very low specs so it just couldn't play smoothly without closing other resource-intensive apps such as firefox and chrome.

As long the different doesn't differ too much, it's neglectable.

Re: How to ensure perfect or close to 59.94 with NVidia

mashingan wrote:

So, you want to make whether the SVP or display rate match exact each other, right?

Exactly my issue, what if I set SVP to interpolate to screen rate? Would this mean that it would try to reach 59.937, my display actual resolution, instead of 59.94?

Re: How to ensure perfect or close to 59.94 with NVidia

Setting are wrong in MadVr if you are getting dropped frames I have a GTX-770
and have used 59.94 but run 71.928 because of my crt projector. Needi3 was the cause
of my dropped frames  in the madvr settings.

Re: How to ensure perfect or close to 59.94 with NVidia

It's 1080p blu-ray rips on 1920x1080 TV, nothing fancy in madVR only Bicubic75 AR for Chroma upscaling / no need for Nnedi.

Re: How to ensure perfect or close to 59.94 with NVidia

Your general setting you using seperate presentation. I have the  last 5 boxes checked
but do not use fullscreen exclusive.

Re: How to ensure perfect or close to 59.94 with NVidia

One more question for SVP developers: what if I change target resolution from 59.94 to 59.937?
Is it possible (I have SVP 4 Pro)?
What do I lose? More jerks, less fluid? More resources needed?

Thanks in advance.

Re: How to ensure perfect or close to 59.94 with NVidia

if I change target resolution from 59.94 to 59.937?

Maybe target refresh rate? wink
Use 'fi_target' parameter. It must work in your case. See droped frames in madVR statistics (by Ctrl-J while playback and in the fullscreen mode).
Just try.

Re: How to ensure perfect or close to 59.94 with NVidia

MAG79 wrote:

if I change target resolution from 59.94 to 59.937?

Maybe target refresh rate? wink
Use 'fi_target' parameter. It must work in your case. See droped frames in madVR statistics (by Ctrl-J while playback and in the fullscreen mode).
Just try.

Ok, I'll try that and see what is happening.

Re: How to ensure perfect or close to 59.94 with NVidia

Hi, in order to achieve my desired fps of 59.937 I need a factor of 2.4999 to input in fi_target which is not accepted being rounded to 2.5, only 3 decimals works but that does not help.
Any ideas?

Re: How to ensure perfect or close to 59.94 with NVidia

ionutm80 wrote:

Hi, in order to achieve my desired fps of 59.937 I need a factor of 2.4999 to input in fi_target which is not accepted being rounded to 2.5, only 3 decimals works but that does not help.
Any ideas?

just use reclock / mpv (display mode here)

Re: How to ensure perfect or close to 59.94 with NVidia

ionutm80

2.4999 to input in fi_target which is not accepted being rounded to 2.5

Input framerate in the box 'fi_target'. It works too. In you case: 59.937

Re: How to ensure perfect or close to 59.94 with NVidia

MAG79 wrote:

ionutm80
Input framerate in the box 'fi_target'. It works too. In you case: 59.937

Hi, already tried that but no change, SVP is still showing playing at 59.94 ...
In the end I gave up on x64 chain and reverted to ReClock:
- set the resolution in Win 10 at 59Hz (59.938Hz as shown by ReClock and 59.9376 as shown by madVR)
- left display mode madVR can switch to empty
- set frequency of 59.94 in ReClock (manually for each movie for the moment ...)
==> now madVR does not drop anymore frames after ReClock turns green and even the estimated ones show 1 frame drop in either 3.xx hrs, 14.xx hours or even 1.2 days (I still do not understabd why it's not locked but nevertheless the estimated time interval for dropping a frame > movie length)
I decode audio with LAV Audio to PCM and then play through my Asus Xonar U7 analog output directly to Logitech z906 so ReClock can do "its magic".

Re: How to ensure perfect or close to 59.94 with NVidia

ionutm80

madVR does not drop anymore frames after ReClock

It is good!

Re: How to ensure perfect or close to 59.94 with NVidia

> Hi, already tried that but no change, SVP is still showing playing at 59.94 ...

For the record, there's an option called "frc.target.tolerance", which is equal to 0.02 by default.