1 (edited by Mystery 23-05-2015 03:20:30)

Topic: Deinterlacing Lag

I have some .TP and .TS videos that cause some problems. With madVR alone, it plays normally. With SVP, however, madVR displays weird deinterlacing times that cause the video to lag.

I currently have the latest Catalyst driver 15.4. There are some driver versions that don't cause this problem (at least one driver version that I kept reverting back to).

Here's a screenshot with madVR alone, then with madVR+SVP.

You can download the video here
https://mega.co.nz/#!KYpSlJYD!c4XNTi0jy … cLxWkOvsRA

Post's attachments

DiamondMadVR.png, 166.61 kb, 287 x 634
DiamondMadVR.png 166.61 kb, 493 downloads since 2015-05-22 

DiamondSVP.png, 394.18 kb, 716 x 631
DiamondSVP.png 394.18 kb, 469 downloads since 2015-05-22 

Re: Deinterlacing Lag

Mystery
If you want to watch interlaced video with SVP you need to deinterlace it first then use SVP to insert interpolated frames.
In your case (29.97i movie on 59.94 Hz display) you don't need SVP. Use vector adaptive deinterlace to get true source 59.94 fps from this movie.

Re: Deinterlacing Lag

How do I configure my computer to use vector adaptive deinterlace and deactivate SVP?

Re: Deinterlacing Lag

Mystery
How do I configure my computer to use vector adaptive deinterlace?
In general case MPC-HC, LAV filters, EVR custom and madVR are already use VA-deinterlacing.
You can just check it.

deactivate SVP?
Exit SVP, Disable SVP (Alt-Ctrl-Win-P) or just stay it open. It don't use CPU or GPU when interpolated frames are not added.

Re: Deinterlacing Lag

Ok now I understand what's going on. Shouldn't SVP automatically disable itself for interlaced video?

Re: Deinterlacing Lag

It doesn't turn interpolation on if input frame rate is close to desired output. The gap is setting up in config.

7 (edited by Mystery 27-05-2015 16:03:53)

Re: Deinterlacing Lag

With the Diamond video, when I play it without SVP, it does appear to already be playing at 60fps with 29.97 interpolated. It's a fluid 60fps with great quality. So although this driver version causes SVP+madVR to lag, it DOES appear to be doing the right thing.

Whereas before, with a different driver version, SVP+madVR would work properly but the video's quality would be lower. Maybe the interpolation mode was different for some reason to generate 29.97fps instead of 59.94fps.

So when I look at the video information, it says 29.97, and it appears to be playing 59.97 already. SVP is then trying to generate frames with a 2:1 ratio, which is where lags occur.

Here's the log

11:03:09.406; ===== Detected playback with ffdShow. AppName: mpc-hc.exe PID: 13112
11:03:09.407; GetDimensionAndFPS_fromOSD start. Duration: 44 ms
11:03:09.451; GetDimensionAndFPS_fromOSD result: 1920x1080 29.97 1/1
11:03:09.452; T1T: begin
11:03:09.453; T1T: GetAllMediaParams
11:03:09.454; ### CorrectStereoModeByAppAndFilename: Diamond.tp
11:03:09.455; T1T: SettingsPrepare
11:03:09.459; T1T: Preparing smooth playback...
11:03:09.460; T1T: WriteAllMediaParamsToIni
11:03:09.460; SVPMgr: main "C:\ProgramData\SVP 3.1\" 1366 768 29.97 1920 1080 2 1. Duration: 141 ms
11:03:09.601; ===== Playback
29.97 * (2 : 1) = 59.94 fps
11:03:09.601; SetPriorityPlayer: 2. Duration: 810 ms
11:03:10.411; frame #10 crop detected: 1 4 1 0
11:03:10.412; frame #11 crop detected: 1 4 1 0
11:03:10.412; frame #12 crop detected: 1 4 1 1
11:03:10.413; frame #13 crop detected: 1 4 1 11
11:03:10.413; frame #14 crop detected: 1 4 1 0
11:03:10.413; frame #15 crop detected: 1 4 1 0
11:03:10.493; frame #16 crop detected: 1 4 1 0
11:03:10.493; frame #17 crop detected: 1 4 1 0
11:03:10.587; frame #18 crop detected: 1 4 1 0
11:03:10.593; SVPMgr: main "C:\ProgramData\SVP 3.1\" 1366 768 29.97 1916 1076 2 1. Duration: 461 ms
11:03:11.054; ===== Playback
29.97 * (2 : 1) = 59.94 fps
Auto crop: [2:4:2:0]