Re: SVP 4 Linux

I built an SVP4 environment on "Ubuntu 22.04" based on "https://www.svp-team.com/wiki/SVP:Linux" but mpv does not work. mpv's video filter "Vapoursynth" does not seem to be properly investigated. So instead of "echo --enable-vapoursynth >> mpv_options" when building mpv, I used "echo --enable-vapoursynth >> ffmpeg_options" and it worked properly. I also added "echo --enable-nvenc >> ffmpeg_options" and "echo --enable-cuvid >> ffmpeg_options" and confirmed that NvEnc also works properly.

352 (edited by Nintendo Maniac 64 25-07-2022 17:29:53)

Re: SVP 4 Linux

opportunity027 wrote:

I used "echo --enable-vapoursynth >> ffmpeg_options" and it worked properly.

Could you quickly check if AV1 decode support works?  When I built mpv+vapoursynth on Mint 20.3 a few months ago, it was unable to decode AV1 video dsspite the very same AV1 video working in the "Celluloid" application that comes pre-bundled with Mint 20.3.

If you need an example AV1 video (note that it's a tiny 256x128 resolution in order to keep file size down):
- https://ttm.sh/wad.mkv

If you run into the same situation there I do where audio plays but there's no video nor even a video player, then you'll have to end the mpv process via the system monitor in order to get the audio to stop.

353 (edited by opportunity027 26-07-2022 12:52:53)

Re: SVP 4 Linux

echo --enable-libaom >> ffmpeg_options

When I used "libaom", it was able to decode normally.

Post's attachments

Screenshot.png, 414.99 kb, 900 x 509
Screenshot.png 414.99 kb, 15 downloads since 2022-07-26 

Re: SVP 4 Linux

opportunity027 wrote:
echo --enable-libaom >> ffmpeg_options

When I used "libaom", it was able to decode normally.

You're probably a more experienced Linux user than me, so could you elaborate more specifically on what you did?  I ran that in the terminal and it seemed to do nothing (I honestly didn't think it would) so clearly there's something more specific that one is supposed to do with that.

Re: SVP 4 Linux

I have only built an environment based on "https://www.svp-team.com/wiki/SVP:Linux". However, there are some differences. First, I built and installed cython for vapoursynth. Then I installed it according to the instructions.However, the options are different and more dependencies are required.It also includes options for nvidia.
ffmpeg_options

--enable-libx264
--enable-libx265
--enable-libmp3lame
--enable-nvdec
--enable-nvenc
--enable-cuvid
--enable-vapoursynth
--enable-openal
--enable-opencl
--enable-opengl
--enable-cuda-nvcc
--nvcc=/usr/local/cuda/bin/nvcc
--enable-vaapi
--enable-vdpau
--enable-libmfx
--enable-gpl
--enable-gnutls
--enable-libaom
--enable-libsvtav1
--enable-libass
--enable-libfdk-aac
--enable-libfreetype
--enable-libopus
--enable-libvorbis
--enable-libvpx
--enable-nonfree

mpv_options

--enable-vapoursynth
--enable-libmpv-shared
--enable-vdpau
--enable-xv
--enable-x11
--enable-gl

Re: SVP 4 Linux

I have problem. When i use svpcode. FAILED. I am newbie. vapoursynth installed.

06:31:11.230: ===== Starting mpv ======
06:31:11.230: Command line: /usr/bin/mpv /home/kali/Desktop/TT2/lv_0_20220804110039.mp4 --o=/home/kali/Desktop/TT2/lv_0_20220804110039.SVP.VO.mkv --no-audio --no-sub --no-sub-auto --input-ipc-server=/tmp/mpvencodesocket --input-media-keys=no --no-msg-color --vf=vapoursynth:/home/kali/.local/share/SVP4/scripts/ffff.py:4:2 --ovc=libx264 --ovcopts=preset=slow,crf=12,threads=2
06:31:11.402: Option vf: vapoursynth doesn't exist.
06:31:11.402: Error parsing option vf (option parameter could not be parsed)
06:31:11.402: Setting commandline option --vf=vapoursynth:/home/kali/.local/share/SVP4/scripts/ffff.py:4:2 failed.
06:31:11.402: Exiting... (Fatal error)
06:31:11.409: (!!!) Intermediate file may be broken: /home/kali/Desktop/TT2/lv_0_20220804110039.SVP.VO.mkv
06:31:11.409: ===== mpv exited with code 1 =====

357

Re: SVP 4 Linux

06:31:11.402: Option vf: vapoursynth doesn't exist.

You need vapoursynth:
https://www.svp-team.com/wiki/SVP:Linux#Vapoursynth

And You need mpv with vapoursynth support:
https://www.svp-team.com/wiki/SVP:Linux … th_support

Re: SVP 4 Linux

I don't suppose anyone know if something special needs to be done to make HDR videos look correct on an SDR display in the compiled mpv+vapoursynth?  They look overly blown-out compared to the same video played in Celluloid with the default configuration provided by Mint 20.3, and the result in Celluloid looks very similar to the SDR version of the very same video(s).

For reference I'm just using YouTube HDR videos for this; here's a very recent example video of such:
https://youtu.be/MuzwlZi7FP8

(the main reason I'm trying to do this is because I don't have the grunt to interpolate 1440p videos but I can do 1080p videos, and YouTube's HDR 1080p encode gets over double the bitrate of their equivalent SDR VP9 encode)

Re: SVP 4 Linux

https://mpv.io/manual/master/#options-tone-mapping

360 (edited by NM64 Yesterday 19:52:51)

Re: SVP 4 Linux

Sure enough, all I had to do was add:

tone-mapping=hable

...and HDR videos now "look good" to my eyes in the compiled mpv+vapoursynth on my SDR monitor.

Curiously, none of the 'tone-mapping' settings matched the result displayed by Celluloid; this isn't really a problem but it was interesting nevertheless.