326 (edited by GianniTee 10-09-2021 14:15:43)

Re: SVP 4 Linux

Chainik wrote:

try this (replace files in SVP 4/plugins)

The SVP works fine with these updated files on OpenSuse Tumbleweed. Thank you very much for this help and your amazing software.

A few notes on the OpenSuse Tubleweed multimedia support.

The user can enable the Packman software repository as described here.
https://en.opensuse.org/Additional_package_repositories

sudo zypper ar -cfp 90 https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/ packman
sudo zypper dup --from packman --allow-vendor-change

Alternatively, the user can visit the graphical Yast control center, open Software Repositories, and add a new community repository (Packman, the entire repository of all the software packages). However, the name of the repository is registered differently, so you need a different command to install the basic multimedia codecs.

sudo zypper dup --from "Packman Repository" --allow-vendor-change

Further, install mpv, mediainfo, and python3-vapoursynth

sudo zypper install mpv
sudo zypper install mediainfo
sudo zypper install python3-vapoursynth

The file type associations can be changed in the File Associations program.
https://www.ghacks.net/2018/03/28/how-t … e5-plasma/

Thanks again!

327

Re: SVP 4 Linux

Hello there,

Any idea of what should i do?

04:41:13.385 [i]: Playback [1392]: playing at 50 [25 *2/1] 
04:41:13.911 [E]: VLC: Python exception: module 'vapoursynth' has no attribute 'get_core'\n\nTraceback (most recent call last):\n  File \src/cython/vapoursynth.pyx\, line 2753, in vapoursynth._vpy_evaluate\n  File \src/cython/vapoursynth.pyx\, line 2754, in vapoursynth._vpy_evaluate\n  File \/home/guilherme/.local/share/SVP4/scripts/1392.py\, line 5, in <module>\n    core = vs.get_core(threads=7)\nAttributeError: module 'vapoursynth' has no attribute 'get_core'\n
04:41:13.911 [E]: VLC: script evaluation failed

Re: SVP 4 Linux

it is the recent Vapoursynth update

replace /script/generate.js

Post's attachments

generate.js 18.11 kb, 230 downloads since 2021-10-02 

329

Re: SVP 4 Linux

Chainik wrote:

it is the recent Vapoursynth update

replace /script/generate.js


Thank you, it worked.

Re: SVP 4 Linux

Hello there,

Am i missing something? Thanks.

04:57:06.679 [i]: Main: starting up SVP 4 Linux [4.5.0.210]... 
04:57:06.679 [i]: Main: args: none
04:57:06.679 [i]: Main: working dir is /home/guilherme/SVP 4/
04:57:06.679 [i]: Main: data dir set to /home/guilherme/.local/share/SVP4/
04:57:06.680 [i]: Settings: loading reg.cfg OK
04:57:06.680 [i]: Settings: loading main.cfg OK
04:57:06.680 [i]: Settings: loading ui.cfg OK
04:57:06.680 [i]: Settings: loading frc.cfg OK
04:57:06.681 [i]: Settings: loading profiles.cfg OK
04:57:06.681 [i]: Settings: loading custom.cfg OK
04:57:06.681 [i]: Settings: loading lights.cfg OK
04:57:06.681 [i]: Main: using Qt 5.15.2 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 11.1.0)
04:57:06.682 [i]: Main: device scale is 1.00132, user defined scale is 1
04:57:06.682 [i]: Main: system locale is [en]
04:57:06.682 [i]: Main: preferred language is [en-us]
04:57:06.684 [i]: Main: setting language file to en.qm...
04:57:06.686 [i]: Main: collecting system information...
04:57:06.688 [i]: Main: module 'plugins/libsvpflow1_vs64.so': 4.5.0.205
04:57:06.690 [i]: Main: module 'plugins/libsvpflow2_vs64.so': 4.5.0.212
04:57:06.691 [i]: Main: VLC filter (64 bit): 1.0.0.182
04:57:06.696 [i]: OS: Linux 5.14.14-zen1-1-zen #1 ZEN SMP PREEMPT Wed, 20 Oct 2021 21:35:17 +0000 x86_64
04:57:06.711 [i]: Desktop environment: /usr/bin/sddm / plasma / kde
04:57:06.725 [i]: CPU: AMD Ryzen 5 1600 Six-Core [base frequency 3018 MHz, 6 threads]
04:57:06.725 [i]: Video: reading OpenCL info...
04:57:06.869 [i]: Video: 1 GPU OpenCL device(s) on Clover [OpenCL 1.1 Mesa 21.2.4] (Mesa)
04:57:06.869 [i]: Video 1: Radeon RX 570 Series (POLARIS10, DRM 3.42.0, 5.14.14-zen1-1-zen, LLVM 12.0.1) (AMD, ver.21.2.4) [gpuID=11]: NOT SUPPORTED
04:57:06.870 [i]: Memory:  15946  MB total,  13731 MB free
04:57:06.870 [i]: System: finding network settings...
04:57:06.884 [i]: Screens: updating information, 1 screen(s) found
04:57:06.884 [i]: Screens: screen 0 (DisplayPort-2) - 1920x1080 @144.001 Hz, x1.0 [91 DPI]
04:57:06.884 [i]: Screens: primary screen is 0
04:57:06.911 [i]: Main: preparing video profiles...
04:57:06.958 [i]: Main: preparing performance graphs...
04:57:06.983 [i]: Icon theme gnome not found.
04:57:07.009 [i]: Main: preparing mpv...
04:57:07.068 [i]: Main: preparing remote control...
04:57:07.069 [i]: RemoteControl: started
04:57:07.069 [i]: Main: preparing main menu...
04:57:07.085 [i]: Main: loading extensions...
04:57:07.088 [i]: Extensions: found svpcode 1.1.0.210 ...
04:57:07.089 [i]: Settings: loading code.cfg OK
04:57:07.118 [i]: Main: initialization completed in 432 ms
04:57:07.286 [i]: Updates: checking now...
04:57:09.045 [i]: VideoPlayer: mpv [smplayer] connected, waiting for the video info...
04:57:09.580 [i]: VideoPlayer: mpv 0.33.1-dirty /via '/tmp/smplayer-mpv-1a25'
04:57:09.840 [i]: Performance: quick estimation = 626 (previous value was 642)
04:57:10.258 [i]: Media: video 1280x720 [PAR 1.000] at 29.970 fps
04:57:10.258 [i]: Media: codec type is AVC, YUV/4:2:0/8 bits
04:57:10.272 [i]: Playback: starting up...
04:57:10.280 [i]: Playback [274c6edf]: resulting video frame 1280x720
04:57:10.280 [i]: Playback [274c6edf]: 1 acceptible profiles, best is 'Automatic' [0]
04:57:10.285 [i]: Playback [274c6edf]: enabled while video is playing
04:57:10.285 [i]: Profile: using automatic profile #1 /animation
04:57:10.286 [i]: Playback [274c6edf]: playing at 143.856 [29.97 *24/5] 

Re: SVP 4 Linux

missing what?

Re: SVP 4 Linux

Chainik wrote:

missing what?


the movie stays in the same fps, i dont get that message SVP running on the screen, its like its not working.

Re: SVP 4 Linux

i followed the instructions to install svp on linux and i get this at near the end of the installation

sudo ./install
The project was not configured: run "waf configure" first!

can somebody help please?

Re: SVP 4 Linux

check previous step errors and fix them!

Re: SVP 4 Linux

Greetings!

Is there a way to get Plex Media Player 2.58.1 working in Linux with SVP? Following the directions for Plex for Windows worked like a charm so even though I've not seen any info on this in regard to Linux I figured it couldn't hurt to ask.

Thanks!

Re: SVP 4 Linux

PMP for Linux should work

Re: SVP 4 Linux

Quick sanity check - is the beta RIFE interpolation not available on SVP 4 Linux?

338 (edited by dlr5668 08-01-2022 15:21:38)

Re: SVP 4 Linux

Nintendo Maniac 64 wrote:

Quick sanity check - is the beta RIFE interpolation not available on SVP 4 Linux?

rife cuda actually works faster (that what flowframes discord guys tolds me) with linux

```I dont have a 3070ti, but a 3080.
On my Linux (Fedora 35) it performs with over 65fps on 1080p.```

339 (edited by Nintendo Maniac 64 09-01-2022 20:19:32)

Re: SVP 4 Linux

dlr5668 wrote:

cuda

The newest Nvidia GPU I own is a GTX 260 (not a typo) which, while it has CUDA, doesn't have a CUDA spec that's new enough to actually run the software in question.

So I'll ask again - is the beta RIFE interpolation not available on SVP 4 Linux?


The jist is that I just wanted to quickly test something with it, but the option for "[VPS_64] RIFE AI interpolation engine" isn't even appearing in the 'Additional programs and features...' update selection in SVP 4 Linux on a PC with Vulkan.

By contrast, it appears in the 'Additional programs and features...' update selection in SVP 4 Windows despite the according Windows PC not having Vulkan.


And yes, I know that you need to be using SVP v4.5.0.210, but the option still appears in the 'Additional programs and features...' update selection in the older v4.3.0.168 of SVP 4 Windows implying that the update option should at least still appear regardless of your currently-installed version.


EDIT: And no, I can't just run Windows on the PC with Vulkan as it's an older GPU architecture that has Vulkan on Linux but not on Windows.

Re: SVP 4 Linux

SVP is not working properly with mpv.  I have set the config properly, but when ever I open a file with mpv, svp shows that there is no video playback. When I check the events log, everything is working fine even showing that mpv is connected to svp and that the correct profile ahs been applied. When I check mpv, svp is applied. I am running arch linux.

14:41:17.918 [i]: Main: starting up SVP 4 Linux [4.5.0.210]... 
14:41:17.918 [i]: Main: args: none
14:41:17.919 [i]: Main: working dir is /home/tanzious/SVP 4/
14:41:17.919 [i]: Main: data dir set to /home/tanzious/.local/share/SVP4/
14:41:17.919 [i]: Settings: loading reg.cfg OK
14:41:17.919 [i]: Settings: loading main.cfg OK
14:41:17.919 [i]: Settings: loading ui.cfg OK
14:41:17.919 [i]: Settings: loading frc.cfg OK
14:41:17.920 [i]: Settings: loading profiles.cfg OK
14:41:17.920 [i]: Settings: loading custom.cfg OK
14:41:17.920 [i]: Settings: loading lights.cfg OK
14:41:17.920 [i]: Main: using Qt 5.15.2 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 11.1.0)
14:41:17.920 [i]: Main: device scale is 1.11959, user defined scale is 1
14:41:17.921 [i]: Main: system locale is [en]
14:41:17.921 [i]: Main: preferred language is [en-us]
14:41:17.922 [i]: Main: setting language file to en.qm...
14:41:17.925 [i]: Main: collecting system information...
14:41:17.926 [i]: Main: module 'plugins/libsvpflow1_vs64.so': 4.5.0.205
14:41:17.926 [i]: Main: module 'plugins/libsvpflow2_vs64.so': 4.5.0.212
14:41:17.929 [i]: OS: Linux 5.15.8-227-tkg-pds #1 TKG SMP PREEMPT Thu, 16 Dec 2021 00:34:47 +0000 x86_64
14:41:17.941 [i]: Desktop environment: /usr/bin/sddm / openbox / 
14:41:17.959 [i]: CPU: AMD Ryzen 7 3700X 8-Core [base frequency 3600 MHz, 16 threads]
14:41:17.959 [i]: Video: reading OpenCL info...
14:41:17.973 [i]: Video: 1 GPU OpenCL device(s) on NVIDIA CUDA [OpenCL 3.0 CUDA 11.4.136] (NVIDIA Corporation)
14:41:17.973 [i]: Video 1: NVIDIA GeForce GTX 1080 Ti (NVIDIA Corporation, ver.470.62.16) [gpuID=11]: OK
14:41:17.974 [i]: Memory:  32099  MB total,  29904 MB free
14:41:17.974 [i]: System: finding network settings...
14:41:17.986 [i]: Screens: updating information, 1 screen(s) found
14:41:17.986 [i]: Screens: screen 0 (DP-2) - 2560x1440 @143.973 Hz, x1.1 [108 DPI]
14:41:17.986 [i]: Screens: primary screen is 0
14:41:17.992 [i]: Main: preparing video profiles...
14:41:18.034 [i]: Main: preparing performance graphs...
14:41:18.091 [i]: Main: preparing mpv...
14:41:18.108 [i]: Main: preparing remote control...
14:41:18.108 [i]: RemoteControl: started
14:41:18.108 [i]: Main: preparing main menu...
14:41:18.120 [i]: Main: loading extensions...
14:41:18.123 [i]: Extensions: found svpcast 1.1.0.208 ...
14:41:18.124 [i]: Settings: loading cast.cfg OK
14:41:18.142 [i]: Extensions: found svpcode 1.1.0.210 ...
14:41:18.143 [i]: Settings: loading code.cfg OK
14:41:18.166 [i]: Extensions: found svplight 2.0.0.190 ...
14:41:18.166 [i]: Settings: loading leds.cfg OK
14:41:18.189 [W]: :/res/images/fullscreen-off.svg:23:32: Could not parse node: radialGradient
14:41:18.189 [W]: :/res/images/lights-off.svg:23:32: Could not parse node: radialGradient
14:41:18.219 [i]: Main: initialization completed in 294 ms
14:41:18.351 [i]: Updates: checking now...
14:41:21.041 [i]: Performance: quick estimation = 826 (previous value was 829)
14:41:29.427 [i]: VideoPlayer: mpv [mpv] connected, waiting for the video info...
14:41:43.732 [i]: VideoPlayer: mpv 0.33.1-dirty /via '/tmp/mpvsocket'
14:41:44.259 [i]: Media: video 1920x1080 [PAR 1.000] at 29.970 fps
14:41:44.259 [i]: Media: codec type is AVC, YUV/4:2:0/8 bits/BT.709 BT.709
14:41:44.264 [i]: Playback: starting up...
14:41:44.270 [i]: Playback [f4b8c953]: resulting video frame 1920x1080
14:41:44.270 [i]: Playback [f4b8c953]: 2 acceptible profiles, best is 'JOe' [0]
14:41:44.273 [i]: Playback [f4b8c953]: enabled while video is playing
14:41:44.274 [i]: Profile: using automatic profile #1 /animation
14:41:44.275 [i]: Playback [f4b8c953]: playing at 144  

341 (edited by Nintendo Maniac 64 10-01-2022 21:56:33)

Re: SVP 4 Linux

tanzious wrote:

SVP is not working properly with mpv.

Does it work if you instead open the video file with SVP rather than mpv?

If it does work, then it simply means that something with the mpv arguments aren't set up correctly (which opening the file with SVP works-around by automatically appending the necessary arguments).

If it doesn't work, then something is broken with either SVP of mpv on a more program-level... but what that is I could not tell you as I am at best an intermediate Linux user (and even that is pushing it).


EDIT: One thing I personally had a bit of trouble with was actually putting the "mpv.conf" file in the correct location - it might be a good idea to include a test argument that would make it really obvious whether the argument is even being found by mpv, such as "speed=1/4" (without quotes) which will default the playback speed to 1/4th.

(and psst, you should have a better end result for 30fps videos if you run your monitor at 120Hz rather than 144Hz)

342

Re: SVP 4 Linux

Nintendo Maniac 64 wrote:

Quick sanity check - is the beta RIFE interpolation not available on SVP 4 Linux?

It's not. We don't get the beta features sadly sad

Re: SVP 4 Linux

I'd like to try and get pmp in arch linux to work with svp. Could someone please point me in the right direction on getting the 2 to work together, thank you!

Re: SVP 4 Linux

InnKeepNY wrote:

I'd like to try and get pmp in arch linux to work with svp. Could someone please point me in the right direction on getting the 2 to work together, thank you!

The process is identical to how you make it work on windows, you just need to know the linux paths.  I think mpv.conf goes in something like ~/.config/plexmediaplayer

345 (edited by bartus 31-03-2022 09:01:31)

Re: SVP 4 Linux

Could we ditch the GUI installed and just provide a binary archive, searching through the .run file in order to extract the 7z archive is somewhat retarded ¯\_(ツ)_/¯

mkdir "installer"
LANG=C grep --only-matching --byte-offset --binary --text  $'7z\xBC\xAF\x27\x1C' "svp4-linux-64.run" |\
cut -f1 -d: |\
while read ofs; do
    dd if="svp4-linux-64.run" bs=1M iflag=skip_bytes status=none skip=$ofs of="installer/bin-$ofs.7z"
done

for f in "installer/"*.7z; do
    7z -bd -bb0 -y x -o"extracted/" "$f" || true
done
rm -rf "installer"

Re: SVP 4 Linux

Using SMPlayer and SVP on Linux Mint 20.3. When I load a video, the video plays for a second or two, then stutters when SVP takes over. Any idea on how I can stop that?

347 (edited by Nintendo Maniac 64 06-05-2022 00:07:23)

Re: SVP 4 Linux

I just found out that Rusticl supports OpenCL image support in mesa; if it's to be merged into mainline mesa then it'll be in 22.2 at the very earliest.

This would make GPU-accelerated SVP on AMD GPU hardware become way easier to setup (I say this typing from a Ryzen 4800U right now which apparently is straight-up not even supported by ROCm), and could similarly become the go-to solution for Intel hardware as well since the existing Intel OpenCL ICD Loader is no longer maintained and therefore has a questionable future.

UPDATE: Rusticl is now able to run Darktable's OpenCL which also relies on image support.


bartus wrote:

Could we ditch the GUI installed and just provide a binary archive

I've kind of wondered why it couldn't just be offered as a flatpak when even highly-proprietary software like Discord is even offered as a flatpak directly on flathub.

On the subject of the ".run", am I crazy or does it not even launch at all on both Mint 20.3 and LMDE5 (Linux Mint Debian Edition 5) and presumably also Debian 11 which LMDE5 is based off of?


----------------------------------------------------------------


BaconCatBug wrote:

Using SMPlayer and SVP on Linux Mint 20.3. When I load a video, the video plays for a second or two, then stutters when SVP takes over. Any idea on how I can stop that?

Does the stutter persist for the entire time that SVP is running?  If so then you might want to try updating mesa - there was a similar sort of stutter issue I ran into with video playback on Intel GPUs that I believe updating mesa fixed but I can't say for sure (basically the issue only occurred on test OS installations where I just happened to never update mesa and, similarly, OS installations where I had already updated mesa just simply never exhibited the issue).  For reference I simply followed the usual "linux gaming" recommendation of installing the "kisak-mesa" PPA for updated mesa.

If the stutter only occurs right at the moment when SVP "kicks in" but then goes away after a second or so, then this might not be something that can be solved as it's something even I've noticed for many many years (going back to SVP 3.1) even on Windows with MPC-HC.

BTW while you're here, do you have the same issue that I do that I described above where double-clicking SVP's ".run" installation file on Mint 20.3 simply does nothing?  How did you work around that outside of using the old version of the installer from archive.org that I linked to on the previous page?

348 (edited by BaconCatBug 17-05-2022 12:48:35)

Re: SVP 4 Linux

Nintendo Maniac 64 wrote:
BaconCatBug wrote:

Using SMPlayer and SVP on Linux Mint 20.3. When I load a video, the video plays for a second or two, then stutters when SVP takes over. Any idea on how I can stop that?

Does the stutter persist for the entire time that SVP is running?  If so then you might want to try updating mesa - there was a similar sort of stutter issue I ran into with video playback on Intel GPUs that I believe updating mesa fixed but I can't say for sure (basically the issue only occurred on test OS installations where I just happened to never update mesa and, similarly, OS installations where I had already updated mesa just simply never exhibited the issue).  For reference I simply followed the usual "linux gaming" recommendation of installing the "kisak-mesa" PPA for updated mesa.

If the stutter only occurs right at the moment when SVP "kicks in" but then goes away after a second or so, then this might not be something that can be solved as it's something even I've noticed for many many years (going back to SVP 3.1) even on Windows with MPC-HC.

BTW while you're here, do you have the same issue that I do that I described above where double-clicking SVP's ".run" installation file on Mint 20.3 simply does nothing?  How did you work around that outside of using the old version of the installer from archive.org that I linked to on the previous page?

It's just the initial stutter about 2 seconds after the video loads, at which point the SVP kicks in.

Did you remember to set the .run to be executable? I just ran it from terminal (./svp-4-linux-64.run) and it worked fine for me.

Re: SVP 4 Linux

BaconCatBug wrote:

Did you remember to set the .run to be executable? I just ran it from terminal (./svp-4-linux-64.run) and it worked fine for me.

Strangely running it from the terminal does indeed work despite double-clicking via the GUI not working and it being set to be executable.

Nevertheless, this issue doesn't occur on (x)ubuntu 22.04 so I figure it's an OS bug or something that's since been solved and will subsequently be solved with Mint 21.

350

Re: SVP 4 Linux

I currently have the problem (again [1]), that RocM with Radeonsi and LLVM causes a LLVM CommandLine plugin error like the following, if mpv is started with SVP using OpenCL. The GPU based performance test runs just fine and SVP also works without OpenCL usage.

mesa: CommandLine Error: Option 'dwarf-extended-loc' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options
Aborted

This started to happen after an update of mpv to 0.34.1, but downgrading did not fix it. I also backtracked (downgraded) updates of all other linked libraries (LLVM, Clang, Mesa) to see, if that helps, but the only change was made by mesa downgrade from 22 to 21, which changed the message to the one, I reported originally here in [1] 2 years ago. I can’t recall any working fix attempts for that original issue. It just went away some day, maybe by a SVP update.

mesa: CommandLine Error: Option 'help-list' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options
Aborted

This error is a result of LLVM plugins being loaded multiple times and caused by bad linking (and the crappy CommandLine plugin (and glibc, mesa, LLVM) implementation(s) [2]). Nowadays this usually happens, if multiple LLVM versions are installed and linked against [3], however I just have LLVM/Clang 13 installed, so this can’t be the case. Usually the linkage in the binary itself has to be fixed, for instance SVP could (indirectly) link against LLVM 12. Other programs using OpenCL Image support like darktable-cltest work just fine.

So my question for the community is: Has anyone with the following library major versions and a RocM supported AMD card has the same issue with mpv, if OpenCL is activated (and OpenCL does work everywhere else)?

Mesa: 22.0.3
RocM: 5.0.2
LLVM/Clang: 13.0.1
mpv: 0.34.1

I’d also kindly ask the SVP developers, if they could check their build with these versions and if they could provide a working build for them in case of problem reproduction. I’m aware, that this build might not work for LLVM 12 systems, but for the transition phase it would be nice to have a working one. Note, that this is not really an urgent issue for me, because I have the necessary CPU power for max settings.

[1]: https://www.svp-team.com/forum/viewtopi … 773#p75773
[2]: https://bugs.gentoo.org/617154#c8
[3]: https://bugs.gentoo.org/651658

Post's attachments

clinfo.log 9.34 kb, 74 downloads since 2022-06-02 

SVP.log 3.76 kb, 72 downloads since 2022-06-02