1 (edited by dzid_ 13-04-2011 23:15:02)

Topic: Waiting for ffdshow video... issue

I think I tried everything. 
I unintalled codecs and then installed SVM package. 
In ffdsow (raw)  I have ffdhow_remote_message enabled and the grab tab is visible (don't know what for).
Tried different players, filters, renderers.

I have applied avisynth script and it does interpolation but with extreme CPU usage because doesn't use GPU.
SVP manager say all the time - Waiting for ffdshow video...  but nothing happens.

Any solution?

Re: Waiting for ffdshow video... issue

We done some work on the bugs.
I think it is good idea to try new SVP 3.0.1.
This version is comming soon.

3 (edited by BipBip 01-05-2011 16:30:56)

Re: Waiting for ffdshow video... issue

In XP I did not have this problem but I switched to Windows 7 and could not having SVP working with ffdshow raw using a different decoder (Cyberlink with HAM in my case).

Seems that in Windows 7 you have to add the ffdshow raw decoder in external filters in MPC-HC too aside from the decoder otherwise it doesn't work. Strange that in XP no need to do that, I just added Cyberlink 10 but didn't added ffdshow raw and it was working fine smile  but no HAM of course  big_smile


P.S. off-topic

Is there a chance of adding HD 4xxx support in the future? Even partial?  tongue  Probably not since no full OCL support but doesn't harm to ask  big_smile

Thank you for great work,

Cheers

Re: Waiting for ffdshow video... issue

BipBip wrote:

Is there a chance of adding HD 4xxx support in the future?

No if AMD will not do anything to add OpenCL 1.0 features to the OpenCL 1.0-compatible videocards like they said the 48xx series is.

Re: Waiting for ffdshow video... issue

BipBip
SVP was working at my Windows 7 without any customization. But after PotPlayer installation something changed.
And now I have to add the ffdshow raw decoder in external filters in MPC-HC to make SVP working.

I have not tried to fix it before. May be later.

Re: Waiting for ffdshow video... issue

first of all, thank you for making this software free to download!

i currently have the issue where the icon in my system tray displays the message, "wating for ffdshow video..." and i am running windows 7 64 bit.
i have made the appropriate changes to ffdshow based on what i saw in the FAQ, but i'm still getting an error message.
i see that there is a fix to add dd the ffdshow raw decoder in external filters in MPC-HC, but i don't know what this means or how to do it. could anyone explain this further to me or offer a different suggestion? thank you!!

Re: Waiting for ffdshow video... issue

tman wrote:

to add dd the ffdshow raw decoder in external filters in MPC-HC

http://www.svp-team.com/forum/misc.php?item=339&download=1

Post's attachments

mpc-ffdraw.jpg, 156.58 kb, 818 x 555
mpc-ffdraw.jpg 156.58 kb, 15300 downloads since 2011-06-24 

Re: Waiting for ffdshow video... issue

Hi developers:
Catching occasion I'd like to add sth to topic. New SVP came up and I make recently another trial with no success.   

When video is playing and SVP says it waits for ffdshow, it also is frozen and when I right click on it nothing happen. Earlier I thought it is supposed to be frozen to ensure no changes during playback but now I know it is a bad sign. Moreover when I play video with some very old Widezu's scripts and SVP is launched it seems like SVP override avisynth script but doesn't apply its own script, only freeze and waits for ffdshow.
To summarize it knows that ffdshow is running but it stuck in some moment when talking with ffdshow.
Any hints what could be wrong (for me and few other people I found with this problem)?

Re: Waiting for ffdshow video... issue

Hmm. I'm still receiving a "Waiting for ffdshow video" message.
Here are some screenshots that show the settings I'm using.
If anyone has any suggestions for me, I'd love to hear them! Thank You!

Post's attachments

1.JPG, 64.26 kb, 473 x 566
1.JPG 64.26 kb, 558 downloads since 2011-06-24 

2.png, 28.52 kb, 354 x 194
2.png 28.52 kb, 518 downloads since 2011-06-24 

Re: Waiting for ffdshow video... issue

2 more screenshots.
Note: I'm using SVP to get the "Soap Opera Effect" on the videos I watch so the settings I pick were to try and get that.

Post's attachments

3.JPG, 54.04 kb, 563 x 476
3.JPG 54.04 kb, 523 downloads since 2011-06-24 

4.JPG, 67.97 kb, 661 x 500
4.JPG 67.97 kb, 594 downloads since 2011-06-24 

Re: Waiting for ffdshow video... issue

Why you using deinterlacing  tab? Disable it. And make sure ffdshow is really running - check if there is ffdshow icon in tray or right click on video and check what filters are used.

12 (edited by tman 25-06-2011 02:18:50)

Re: Waiting for ffdshow video... issue

dzid_
Thank you for responding! I uncheked deinterlacing.
Now everything is responding, but the Media Player Classic Home crashes when the SVP smooth playback starts.

Post's attachments

new.png, 128.24 kb, 471 x 637
new.png 128.24 kb, 482 downloads since 2011-06-24 

Re: Waiting for ffdshow video... issue

tman
Can you show details of this error?

dzid_
I need more information about frozen bug. It is first bug report about it. Try to reinstall SVP and install ffdShow from SVP distributive.

Re: Waiting for ffdshow video... issue

@MAG79
I've just been writing to you bug details when I come up with some idea.  It strange because I though I've already checked this idea....  - anyway, I've made two another windows accounts to be sure: one with my real name and one with some stupid short name. It occurs that the problem was with my real name because in %Userprofile% path was polish letter "ł" from Unicode shit or something.

Details for Bug elimination (account with ł):
- SVP is saving and loading its setting successfully
- SVP icon is getting freeze when video is playing and unfreeze when video stops (freeze - I mean I right click on it and nothing happens)
- although icon is frozen SVP does something to active avisynth scripts in ffdshow (for example degrain), because when SVP runs those scripts don't work as they were cleaned


@tman
It is important what filters are you actually using (right click on video -> filters) . You can also try another player (I like KMplayer). But you have to be careful because all those modern players has internal filters which have to be disabled in order to make ffdshow and SVP working.

Re: Waiting for ffdshow video... issue

@MAG79 the error message  is:
Problem signature:
  Problem Event Name:    BEX64
  Application Name:    mpc-hc64.exe
  Application Version:    1.5.1.2903
  Application Timestamp:    4d6bfe92
  Fault Module Name:    StackHash_1dc2
  Fault Module Version:    0.0.0.0
  Fault Module Timestamp:    00000000
  Exception Offset:    0000000000000000
  Exception Code:    c0000005
  Exception Data:    0000000000000008
  OS Version:    6.1.7601.2.1.0.768.3
  Locale ID:    1033
  Additional Information 1:    1dc2
  Additional Information 2:    1dc22fb1de37d348f27e54dbb5278e7d
  Additional Information 3:    cbc5
  Additional Information 4:    cbc5ec6970b2af35927ad67117ca57e2

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid= … cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt


thank you for your help!

16 (edited by Chainik 25-06-2011 22:24:45)

Re: Waiting for ffdshow video... issue

tman
Application Name:    mpc-hc64.exe

Is it a x64 build of MPC-HC?  hmm
SVP is working with x32 players only (and with x32 builds of ffdshow).

dzid_
Thanks.
So the problem is in i18n only. It's not the first time smile and I think it'll fixed in the next bug-fix release.

Re: Waiting for ffdshow video... issue

Chainik
i just downloaded the x32 version and it works perfectly! thank you for all your help. your program is great!

Re: Waiting for ffdshow video... issue

I can't wait for 3.0.4 bug-fix release!!  I can test it if any betas.

Re: Waiting for ffdshow video... issue

dzid_
Thanks. We will contact you when the issue will be fixed.

Re: Waiting for ffdshow video... issue

It's the same problem when windows user name contains "ё" char.  sad

Re: Waiting for ffdshow video... issue

Fedr
Thank you for bug report. We will fix it next release.

Re: Waiting for ffdshow video... issue

Same problem with DVBViewer. FFdshow Video renderer selected and no video image (DVBViewer freezes). SVP shows Waiting for ffdshow video.

Configured FFdshow with 2 tips in FAQ (Grab and remote API).

With MPC-HC no problem.

Win7 x64
AMD Athlon II X4 640
ATI 5670

Re: Waiting for ffdshow video... issue

tecram
Try this:

fooladi wrote:

I found that if we disable fast channel switching in DVBViewer then no error occurred and there is no need to resize video by ffdshow.   
(Settings -> TV+Radio -> Fast Channel Switching).

advise from this post.

Re: Waiting for ffdshow video... issue

Same issue.

Re: Waiting for ffdshow video... issue

Unfortunately, I'm not a DVBViewer user. hmm
What happen when run DVBViewer with ffdShow but without SVP launched?