Topic: Need help for AMD A10 7300 with R6 Mobile Radeon

As the title mentioned, I've had unfortunate circumstance that I couldn't access my PC and have to stick with said system.

With so much pain at setting, I finally could do the setting that play with SVPFlow.
I'm using madvr because I somehow noticed the quality different between madvr and evr-cp.
OS is Windows 10.

There are several question about this:
1. The video performance was dropped very much when battery was charging. I changed the setting to "optimize battery life" instead of "max performance" in power plan in order to mitigate the issue. Why is it work that way?
2. I played 8 bit video, it was constantly dropping a frame every ~5 seconds (the stat was 1 frame repeat in 5 seconds). But played ok when playing 10 bit videos. Why is it happened that way?
3. I played without SVP using 32 bit video player (I'm using SVPFlow without SVP manager) and the GPU already utilize 100% but no dropped frames. Why is it worked that way?

My madvr setting:
Chroma upscaling: Bicubic sharpness 100 with anti-ringing filter
Image downscaling: Bicubic sharpness 100 with anti-ringing filter to relaxed and scaled in linear light
Image upscaling: Lanczos 3 taps with anti-ringing filter
CPU queue size: 20
GPU queue size: 16
All in general setting of rendering are ticked the exception "delay playback start until render queue is full" and "disable desktop composition".
16 video frames shall be presented in advance.
All other option should be (almost) in default setting.

Those are questions that somehow I can think for now. There are many others but I'm just at lost of how confusing the system. This is the first time I'm using AMD APU so this is really confusing for me.
So if someone who somehow familiars with AMD APU and GPU, please explain to me and give some suggestions on how to utilize this to its full.
(Below I attached my radeon system and SVPAnalyse parameter options).

Thanks in advance.

Post's attachments

analyse_options.PNG, 13.66 kb, 497 x 478
analyse_options.PNG 13.66 kb, 279 downloads since 2016-05-04 

radeon_crimson.png, 160.76 kb, 1000 x 489
radeon_crimson.png 160.76 kb, 308 downloads since 2016-05-04 

2 (edited by Nintendo Maniac 64 04-05-2016 19:02:14)

Re: Need help for AMD A10 7300 with R6 Mobile Radeon

Just to clarify, does this system have a stand-alone discrete GPU and an APU, or does it only have the integrated graphics built into the APU?


mashingan wrote:

I'm using madvr because I somehow noticed the quality different between madvr and evr-cp.

You did change the resizer for evr-cp to one of the three "Bicubic" settings, right? (A=-0.60 is smoothest, A=-1.00 is sharpest).


mashingan wrote:

1. The video performance was dropped very much when battery was charging. I changed the setting to "optimize battery life" instead of "max performance" in power plan in order to mitigate the issue. Why is it work that way?

Perhaps due to poor/cheap design on the laptop manufacturers part, it cannot pull enough power to charge the battery and run the system at full-tilt which then may force the APU to underclock.  Setting it to optimize for battery life may cause the APU to not run at absolute full-tilt, but still run at a faster than than when it's underclocked.

Alternatively, because SVP + MadVR is extremely demanding on both the GPU and CPU, maybe it's throttling the CPU or GPU portion in order to boost performance and thermal headroom of the other, in which case you should follow the steps here to try to mitigate that:
http://forums.toshiba.com/t5/Video-Disp … d-p/351374
(the only thing is that you're using the new GPU drivers interface while that guide is written for the old Catalyst drivers)


mashingan wrote:

2. I played 8 bit video, it was constantly dropping a frame every ~5 seconds (the stat was 1 frame repeat in 5 seconds). But played ok when playing 10 bit videos. Why is it happened that way?

10bit doesn't have GPU hardware decode while 8 bit does, so it's likely because your GPU has too much utilization, either from being maxed-out or from being underclocked.


mashingan wrote:

3. I played without SVP using 32 bit video player (I'm using SVPFlow without SVP manager) and the GPU already utilize 100% but no dropped frames. Why is it worked that way?

I've never used SVPFlow without the SVP manager, so I've no idea.  However, I can't help but see a pattern with your issues relating  to the GPU not having enough headroom whether due to being maxed out or due to underclocking.

Re: Need help for AMD A10 7300 with R6 Mobile Radeon

Nintendo Maniac 64 wrote:

Just to clarify, does this system have a stand-alone discrete GPU and an APU, or does it only have the integrated graphics built into the APU?

It has stand-alone GPU which linked with APU. From the pic of system, the discrete is R6 Radeon (primary) while in APU is R5 M200 (linked).
But the memory is shared with GPU (I don't know with which GPU), so is it standalone or integrated?



Nintendo Maniac 64 wrote:

You did change the resizer for evr-cp to one of the three "Bicubic" settings, right? (A=-0.60 is smoothest, A=-1.00 is sharpest).

Yes, I changed to Bicubic (A=-0.60) with D3D fullscreen was ticked.



Nintendo Maniac 64 wrote:

Perhaps due to poor/cheap design on the laptop manufacturers part, it cannot pull enough power to charge the battery and run the system at full-tilt which then may force the APU to underclock.  Setting it to optimize for battery life may cause the APU to not run at absolute full-tilt, but still run at a faster than than when it's underclocked.

Alternatively, because SVP + MadVR is extremely demanding on both the GPU and CPU, maybe it's throttling the CPU or GPU portion in order to boost performance and thermal headroom of the other, in which case you should follow the steps here to try to mitigate that:
http://forums.toshiba.com/t5/Video-Disp … d-p/351374
(the only thing is that you're using the new GPU drivers interface while that guide is written for the old Catalyst drivers)

I think you're correct about cheap design, originally laptop I used was available for premium/high spec laptop, but my current work can only afford the cheaper version of it sad

I inferred that when the setting to max performance, somehow the Windows (e.g. ShellExperienceHost.exe, explorer.exe, SearchUI.exe) actually used the "portion of perfomance" too. I just couldn't selectively choose which performance I need to maxed and which I don't need. sad

I'll check that link after this.



Nintendo Maniac 64 wrote:

10bit doesn't have GPU hardware decode while 8 bit does, so it's likely because your GPU has too much utilization, either from being maxed-out or from being underclocked.

Any idea on how to make 8 bit videos don't use GPU decoder? I tested the hardware decoder in LAV to none but it was the same.




Nintendo Maniac 64 wrote:

I've never used SVPFlow without the SVP manager, so I've no idea.  However, I can't help but see a pattern with your issues relating  to the GPU not having enough headroom whether due to being maxed out or due to underclocking.

Could you tell me how to check if it was underclocking?

4 (edited by Nintendo Maniac 64 05-05-2016 03:45:58)

Re: Need help for AMD A10 7300 with R6 Mobile Radeon

mashingan wrote:

Any idea on how to make 8 bit videos don't use GPU decoder? I tested the hardware decoder in LAV to none but it was the same.

That's weird, it should work...

Maybe try using LAVfilters 0.68 since that lets you select which GPU to use; that might give you some more control over it.

The easiest way to do this is to download the x86 zip (or 64bit if you're using 64bit MPC-HC; SVP comes bundled with 32bit MPC-HC though) from here:
https://github.com/Nevcairiel/LAVFilters/releases

Navigate to your MPC-HC program folder and go into the folder named "LAVFilters"; take the contents of the downloaded ZIP and extract them to said LAVFilters folder; this should replace most of not all the files with newer versions.


mashingan wrote:

Could you tell me how to check if it was underclocking?

Use CPU-Z for your CPU clockrate and GPU-Z for your GPU clockrate.

Also, one thing to try is to change which GPU SVP and MadVR uses.  Normally I'd recommend setting SVP to the integrated GPU and MadVR to the discrete GPU, but in this case you should probably try any and all combinations and see what works best (if at all).

Re: Need help for AMD A10 7300 with R6 Mobile Radeon

Thanks for the help NM64, but I gave up to investigate it anymore (and because I didn't have much time to tweak it).

Based on my finding, AMD APU is weaker for single thread computation than Intel. If it's about "only" rendering, I think AMD is better because AMD has better performance with multiple threads. Not to mention it's actually using physical threads instead of Intel which using Hyper-Thread.

Unfortunately, SVP is still computation-wise heavy. It still has to do the iteration/calculation which can only thrive in single thread/process. (This is only my thought, though). So considering how weak the system I has in single thread, I just gave up to investigate more sad

Re: Need help for AMD A10 7300 with R6 Mobile Radeon

But SVP loves "moar cores", so AMD's currently lower IPC shouldn't hamper it's performance much at all.