1 (edited by berryracer 24-02-2013 19:57:41)

Topic: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

I am getting the following error when trying to run a video with SVP

Please help

I am running on a freshly installed Windows 8 Pro with all windows updates and no Antivirus yet

I installed the latest SVP FULL version 3.1.4

http://img28.imageshack.us/img28/3193/captureyib.png

Post's attachments

Capture.PNG, 250.86 kb, 654 x 591
Capture.PNG 250.86 kb, 494 downloads since 2013-02-24 

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

Error Log:

19:34:39.710; Start: SVPMgr 3.1.4 (901) starts...
19:34:39.710; AppDataPath: C:\Users\berry\AppData\Roaming (ANSI)
19:34:39.710; Start: read settings file settings.ini
19:34:39.710; Start: load language file - English. Duration: 16 ms
19:34:39.726; Start: check launched instance of SVP-manager
19:34:39.726; Start: check Avisynth installed
19:34:39.726; Start: clear Logs folder. Duration: 16 ms
19:34:39.742; Start: performance graphs prepare
19:34:39.742; Start: SVPMgr folders prepare
19:34:40.319; Start: CPU performance level estimation. Duration: 1638 ms
19:34:41.957; Start: auto-detected profiles set: 4g (1660)
19:34:41.957; Start: copying files of profiles set
19:34:41.957; Start: read settings file SVPMgr.ini
19:34:41.957; Start: GPUs settings detection
19:34:44.937; Start: detected graphics (OpenCL) adapter: 11. GeForce GTX 670M (800)
19:34:44.937; Start: monitors settings detection. Duration: 982 ms
19:34:45.919; Start: detected monitor: 1920 x 1080 @ 59.861
19:34:45.919; Start: disable LNG-file write when UAC enabled
19:34:45.919; Start: change SVP-manager priority
19:34:45.919; Start: register hotkeys
19:34:45.919; Start: get versions of modules used
ffdshow.ax/avisynth.dll: 1.3.4500.0/2.5.8.6
svpflow1/2.dll: 1.3.3.0/1.4.1.0
svpflow_cpu/gpu.dll: 1.7.2.0/1.7.7.0
19:34:45.919; Start: refresh autostart state in registry
19:34:45.919; Start: some more work with registry
19:34:45.919; Start: create menu
19:34:45.919; Start: update settings file settings.ini. Duration: 16 ms
19:34:45.935; Start: update monitor settings
19:34:45.935; Start: prepare "About the program" window
19:34:45.935; Updates: check for updates. Request sended
19:34:46.091; Start: enable ffdShow waiting mode
19:34:46.091; RefreshSVP
19:34:46.091; ===== Waiting for ffdshow video
19:34:46.091; Start: prepare to work is complete
19:34:46.231; Updates: connection opened
19:34:46.949; Updates: server answer:
HTTP/1.1 400 Bad Request
Date: Sun, 24 Feb 2013 15:34:47 GMT
Server: Apache
Content-Type: text/html; charset=iso-8859-1
Content-Length: 299
Connection: Keep-Alive

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
</p>
<hr>
<address>Apache Server at http://www.svp-team.com Port 80</address>
</body></html>

19:35:16.746; Updates: connection closed
19:49:18.941; ===== Detected playback with ffdShow
19:49:18.942; GetDimensionAndFPS_fromOSD start. Duration: 22 ms
19:49:18.964; GetDimensionAndFPS_fromOSD result: 640x272 23.976 1/1
19:49:19.169; T1T: begin
19:49:19.171; T1T: GetAllMediaParams
19:49:19.171; T1T: SettingsPrepare
19:49:19.175; T1T: Preparing smooth playback...
19:49:19.176; T1T: WriteAllMediaParamsToIni
19:49:19.176; SVPMgr: main "C:\Users\berry\AppData\Roaming\SVP 3.1\" 640 272 23.976 640 272 5 2. Duration: 124 ms
19:49:19.300; ===== Playback
23.976 * (5 : 2) = 59.94 fps
19:49:19.300; SetPriorityPlayer: 2. Duration: 390 ms
19:49:19.690; Error: Error preparing smooth playback! Script error:
SVSmoothFps: unable to init FlowLib [code 0x3FFFB]
(C:\Users\berry\AppData\Roaming\SVP 3.1\AVS\ffdshow.avs, line 38)
(C:\Users\berry\AppData\Roaming\SVP 3.1\AVS\ffdshow.avs, line 53)
(ffdshow_filter_avisynth_script, line 4)
. Duration: 842 ms
19:49:20.532; this is changing FalseVFR_Dwn. ffdShow-framerate: 18.262 SVP Index:0.00/0.00
19:49:21.467; this is changing FalseVFR_Dwn. ffdShow-framerate: 16.672 SVP Index:0.00/0.00
19:49:22.405; this is changing FalseVFR_Up. ffdShow-framerate: 22.538 SVP Index:0.00/0.00
19:49:23.340; this is changing FalseVFR_Up. ffdShow-framerate: 23.807 SVP Index:0.00/0.00
19:49:24.275; this is changing FalseVFR_Up. ffdShow-framerate: 23.976 SVP Index:0.00/0.00
19:49:24.275; express clear interval
19:49:24.276; stabilized framerate: 23.976 fps
19:49:50.951; RefreshSVP
19:49:50.952; ===== Waiting for ffdshow video

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer
Thank you for bug report.

This error [0x3FFFB] was on SVP with NVIDIA cards in early versions. It was fixed.
Error tells about video memory leaks.

1. Can you compare used video memory values via GPU-Z on both last SVP versions: 3.1.3 and 3.1.4?
2. What NVIDIA drivers do you use?
3. SVPmark works fine or with errors too?

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

Strange thing man, this time SVP worked fine. This error happens randomly I guess but happens too often that SVP is unusable when I need it most

I use the GeForce Driver 314.07 (x64)

I am really not in the mood of uninstalling SVP 3.1.4 and reinstalling 3.1.3 to compare the difference in memory consumption usage

any thing else I should try to fix this bro?

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

Test summary
-----------------------
  Date: 2013-02-25T10:23:54
  CPU:  Intel Core i7-3610QM @2294 MHz [8 threads]
  GPU:  NVIDIA GeForce GTX 670M [ver.314.07]
  Mode: FHD + GPU [17 threads]

Overall scores
-----------------------
  Synthetic CPU:                  MC1879
  Synthetic GPU:                  MG3338
  Real-life:                      FG2506

Details: synthetic
-----------------------
  CPU: compose (single-threaded): 506
  CPU: compose (multi-threaded):  2150
  CPU: search (single-threaded):  385
  CPU: search (multi-threaded):   1669
  GPU: system -> GPU transfer:    1170
  GPU: GPU -> system transfer:    1403
  GPU: calculations:              788
  GPU: total score:               4303

Details: real-life /FHD
-----------------------
  decode video:                   15.40x (369.5 fps)
  48 fps - vectors search:        1.21x (58.0 fps)
  60 fps - frame composition:     3.49x (209.4 fps)
  48 fps - [SVP] fastest:         6.21x (297.9 fps)
  48 fps - [SVP] simple 1:        4.13x (198.1 fps)
  60 fps - [SVP] good:            2.09x (125.4 fps)
  60 fps - [SVP] high:            1.66x (99.5 fps)
  60 fps - [SVP] highest:         0.75x (44.7 fps)
  72 fps - [SVP] simple 2:        3.74x (269.6 fps)

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer
The driver is official and must be compatible. It is first message about 0x3FFFB error.
Good SVPmark results. Nothing strange.

If the error appears again please do not press OK button, run GPU-Z and take screenshot of Sensors tab.

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

Alright thanks man. I will let you know if it happens again

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

It happened again, here's the GPU-Z Sensors tab:

http://img51.imageshack.us/img51/6153/gpuzb.png

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

All i can say now - rollback to the last working nv driver version

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

so you think it's a problem with the nVIDIA driver and not SVP?

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer
Probably NVIDIA changed something in drivers 314.* and NVIDIA drivers became incompatible to SVP commands.
You can check it. It is simple. Just install older driver with advanced option and clean install option enabled.

If older driver will work fine then return to newest one. Check again. Else go back to more older driver. What driver version works fine at your system?

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

I went back to GeForce Driver 310.90 (x64) but same error

I think SVP is not compatible with Windows 8 something is not allowing the ffdshow to run properly

same with ReClock it's not running when i run a video even though i ensured to let it run automatically with MPC-HC sad

please help

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer
Error not in ffdShow. Error occurs in SVP library. It can not init OpenCL hardware acceleration.

Now you only one with error 0x3FFFB.
It give me think something wrong with your system, with your OpenCL-driver or with your video driver. NOT with SVP.

I went back to GeForce Driver 310.90 (x64) but same error
Go down to next WHQL-driver: 310.70, 306.97, 306.23.
Or you don't want to fix the error? hmm

please help
Can you attach here your CLInfo output?
Start menu - Programs - SVP - Utilities - CLInfo

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

MAG79

but bro, I've been using SVP with the 2 drivers I mentioned just fine on Windows 7, this just started happening with Windows 8

How do I attach the CLInfo you're talking about?

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer
How do I attach the CLInfo you're talking about?

Start menu - Programs - SVP - Utilities - CLInfo

copy text from appeared notepad and paste it here in the post

16 (edited by %username% 26-02-2013 11:40:50)

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer


something is not allowing the ffdshow to run properly

Does ffdshow video configuration opened from start menu?
Does player (MPC-HC) used FFDShow and it work without SVP?


ReClock it's not running when i run a video even though i ensured to let it run automatically with MPC-HC

Have you admin rights on the windows 8?
Try to run all stuf as administrator
Or try to disable UAC and reboot. Probably UAC blocks something  hmm

please help install windows 7
wink

17 (edited by berryracer 26-02-2013 11:45:59)

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

UAC is disabled always and I am the admin

ffdshow video settings open just fine

Here is the CLInfo:


Number of platforms:                 1
  Platform Profile:                 FULL_PROFILE
  Platform Version:                 OpenCL 1.1 CUDA 4.2.1
  Platform Name:                 NVIDIA CUDA
  Platform Vendor:                 NVIDIA Corporation
  Platform Extensions:                 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_d3d9_sharing cl_nv_d3d10_sharing cl_khr_d3d10_sharing cl_nv_d3d11_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll


  Platform Name:                 NVIDIA CUDA
Number of devices:                 1
  Device Type:                     CL_DEVICE_TYPE_GPU
  Device ID:                     4318
  Max compute units:                 7
  Max work items dimensions:             3
    Max work items[0]:                 1024
    Max work items[1]:                 1024
    Max work items[2]:                 64
  Max work group size:                 1024
  Preferred vector width char:             1
  Preferred vector width short:             1
  Preferred vector width int:             1
  Preferred vector width long:             1
  Preferred vector width float:             1
  Preferred vector width double:         1
  Native vector width char:             1
  Native vector width short:             1
  Native vector width int:             1
  Native vector width long:             1
  Native vector width float:             1
  Native vector width double:             1
  Max clock frequency:                 1240Mhz
  Address bits:                     18397247599280160
  Max memory allocation:             805224448
  Image support:                 Yes
  Max number of images read arguments:         128
  Max number of images write arguments:         8
  Max image 2D width:                 32768
  Max image 2D height:                 32768
  Max image 3D width:                 2048
  Max image 3D height:                 2048
  Max image 3D depth:                 2048
  Max samplers within kernel:             16
  Max size of kernel argument:             4352
  Alignment (bits) of base address:         4096
  Minimum alignment (bytes) for any datatype:     128
  Single precision floating point capability
    Denorms:                     Yes
    Quiet NaNs:                     Yes
    Round to nearest even:             Yes
    Round to zero:                 Yes
    Round to +ve and infinity:             Yes
    IEEE754-2008 fused multiply-add:         Yes
  Cache type:                     Read/Write
  Cache line size:                 128
  Cache size:                     114688
  Global memory size:                 3220897792
  Constant buffer size:                 65536
  Max number of constant args:             9
  Local memory type:                 Scratchpad
  Local memory size:                 49152
  Kernel Preferred work group size multiple:     32
  Error correction support:             0
  Unified memory for Host and Device:         0
  Profiling timer resolution:             1000
  Device endianess:                 Little
  Available:                     Yes
  Compiler available:                 Yes
  Execution capabilities:                
    Execute OpenCL kernels:             Yes
    Execute native function:             No
  Queue properties:                
    Out-of-Order:                 Yes
    Profiling :                     Yes
  Platform ID:                     033E0E70
  Name:                         GeForce GTX 670M
  Vendor:                     NVIDIA Corporation
  Driver version:                 314.07
  Profile:                     FULL_PROFILE
  Version:                     OpenCL 1.1 CUDA
  Extensions:                     cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_d3d9_sharing cl_nv_d3d10_sharing cl_khr_d3d10_sharing cl_nv_d3d11_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll  cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer
It's an OpenCL initialization error which means (as it defined in specs) - "there is a failure to allocate resources required by the OpenCL implementation on the device".

"Device" is 670M in your case.

Last tme it was SVP's issue but it was fixed like an year ago.

This error happens randomly I guess but happens too often that SVP is unusable when I need it most

Define "randomly".
Is it happens really randomly, or just after some (or many) video file openings / SVP settings changes / seeking in video?

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

Randomly means 90% of the time, 10% of the time it works...

when I go home, I will try enabling pagefile to a 1 GB min / max as I currently have Pagefile disabled...just to see if it makes any difference...

Also, I was reading on another forum about people having trouble installing codecs on Windows 8 as in they are not working...could that be a reason you think there should be some kind of trick to get codecs working?

Read this if u have time: http://forums.mydigitallife.info/thread … ptop/page2

I am thinking, even though I disabled UAC, Windows still asks me twice before copying, deleting, etc. a file to C:

I read online that there is a registry tweak that totally disables UAC I will also try that when I get home:

http://www.eightforums.com/system-secur … etely.html

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer
90% of the time
what action usually you do what leads to the error?
- open video
- seeking video
- nothing (error at the middle of the movie) roll
- another

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

MAG79 wrote:

berryracer
90% of the time
what action usually you do what leads to the error?
- open video
- seeking video
- nothing (error at the middle of the movie) roll
- another

As soon as the video starts, you know how there is usually a 2 second delay until SVP displays the message on the screen that it is playing the video @ 60 FPS? Well with me, the movie starts fine for 1 second then by the time SVP is preparing for smooth playback it gives me the error with that ffdshow cannot access bla bla bla message

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

do you want to logon to my computer within 2 hours on TeamViewer to try a few things on my computer?

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

berryracer
do you want to logon to my computer within 2 hours on TeamViewer
Yeah! It will be great but I don't know how to find the problem. I'm not master of OpenCL smile
Chainik can do more than I can. He has another time zone. He will contact you.

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

alright.... it is 7:28 am as I am typing, I will be home @ 9 am Dubai Time which is GMT +4

Please bear in mind that I work night shifts so I will be awake for 5 more hours smile

I hope we can work together to resolve this issue SVP is my favorite PC app of all time

Re: Error: unable to init FlowLib [code 0x3FFFB] in Windows 8 Pro x64

I fixed the problem!!!!!!!!!! What I did was:


- Uninstall LAV
- Uninstall madVR
- Uninstall ffdshow
- Install Win 8 Codecs by Sharky (he's a jerk but his codecs are good)
- Tried to run SVP, said ffdshow was not registerd
- Installed ffdshow_rev4499_20130104_clsid
- Ran a movie and SVP works

smile

I hope the error doesn't come back again but if you need any info from my system which will help others please let me know and I will be happy to help