Topic: MPV having troubles with Crunchyroll?

I've used svptube with Crunchyroll successfully over the past few months. Recently though, autoplay from clipboard has stopped working in regards to mpv; other players seem to launch fine... Weirdly it seems that choosing the uncrossed out "1080p" or normal resolutions will cause mpv to launch incorrectly. I can see the process in my process list but no window pops up. Logs just say mpv connected, waiting for video info.

However, going into the list and specifically choosing one of the crossed out names, i.e American English will launch mpv successfully. Also weirdly enough, if I manually launch mpv from the svp folder first, then autoplay will work successfully.

I've had my main computer and test computer both experience this problem. Anyone else having this?

Thanks

Post's attachments

svp.png, 15.9 kb, 645 x 187
svp.png 15.9 kb, 15 downloads since 2019-08-06 

Re: MPV having troubles with Crunchyroll?

I'm having problems with mpv and Crunchyroll on a few specific URLs.  Other Crunchyroll URLs will launch and play mpv without problems.

But these few specific URLs will launch mpv into the background while using LAN bandwidth, but no window shows up.  Trying to play other URLs immediately afterwards will not work, unless I first kill mpv in the background in task manager.

If I try to launch SVPtube2 into MPC-HC or VLC, the same problematic URL starts to play successfully.  So the problem seems to be with mpv.  But MPC-HC and VLC always doesn't play smoothly for me. mpv plays very smooth, so I prefer to use mpv.

I also tried to launch a working URL into mpv, and while the video is playing in mpv, then I try to play the URL that is causing the problem.  The current video will freeze a frame, then no new video shows up, but the LAN bandwidth is still consuming data.  I can press pause and play button, but nothing happens and the window still shows the frozen frame from the old video.  There is a backward/forward button, when I press the buttons then a queue list shows up, but moving around the queue doesn't do anything.

This is one of the problematic URLs:
https://www.crunchyroll.com/the-island- … vie-792591

And a part of the log file.  It shows me first playing a good URL.  Then I try to play a bad URL. mpv is frozen.  Then I kill mpv.  Then I try to play the bad URL again. mpv launches in the background and consumes LAN bandwidth, but there is no window.  The log just keeps showing " connected, waiting for the video info..".

23:27:39.901 : Tube: video format id adaptive_hls-audio-jaJP-8314-0 selected
23:27:40.187 : Playback [2db12551]: disabled while video is playing
23:27:40.197 : Playback [2db12551]: deleted
23:27:41.367 : VideoPlayer: mpv [mpv.exe] connected, waiting for the video info...
23:27:41.871 : VideoPlayer: mpv 0.31.0
23:33:52.249 : Tube: video format id adaptive_hls-audio-jaJP-8314-0 selected
23:33:52.601 : VideoPlayer: mpv [mpv.exe] connected, waiting for the video info...
23:33:53.107 : VideoPlayer: mpv 0.31.0

Re: MPV having troubles with Crunchyroll?

I looked at the log again.  Could it be a problem here?

23:04:09.093 [i]: Main: setting language file to en.qm...
23:04:09.101 [W]: Main: module 'plugins/svpflow1.dll': NOT FOUND
23:04:09.102 [W]: Main: module 'plugins/svpflow2.dll': NOT FOUND
23:04:09.102 [i]: Main: module 'plugins64/svpflow1.dll': 4.3.0.156
23:04:09.103 [i]: Main: module 'plugins64/svpflow2.dll': 4.3.0.168
23:04:09.104 [i]: Main: module 'plugins64/svpflow1_vs.dll': 4.3.0.156
23:04:09.104 [i]: Main: module 'plugins64/svpflow2_vs.dll': 4.3.0.168
23:04:09.104 [W]: Main: PATH doesn't contain mpv64 folder, VLC and libmpv players may not work
23:04:09.104 [W]: Main: PYTHONPATH doesn't contain mpv64 folder, VLC and libmpv players may not work
23:04:09.105 [i]: Main: VLC filter (64 bit): 1.0.0.182
23:04:09.105 [W]: Main: PYTHONPATH is EMPTY
23:04:09.108 [i]: Main: running OpenCL info...

Do I need to install SVPflow 4.3.0.168 ?

Re: MPV having troubles with Crunchyroll?

Video by your link is working to me:
https://www.crunchyroll.com/the-island- … vie-792591

SVPtube2 opens mpv window just after press Play button with delay about 5 seconds.
---

What format are you open (720p or 1080p)?