76 (edited by dlr5668 12-04-2016 10:10:28)

Re: Recent crashes

mashingan wrote:

Overall, mpv seemed more stable, but when there's scene with heavy type-setting (I usually watch animes and those sometimes have heavy karaoke effects or fancy subtitle), the frames will be dropped. Also, MPC variants seemed more lighter, but maybe it's just me.

check this config (copy 2 files to %appdata%\mpv )

test both too :
hwdec=no / hwdec=dxva2-copy ( 1st works for me better. I use 71 Hz lcd overclock and Reclock like slow down )
backend=angle / backend=dxinterop ( angle gives 0 drops on amd ).

Dont use smplayer. Run mpv directly.

Post's attachments

input.conf 7.25 kb, 327 downloads since 2016-04-12 

mpv.conf 5.16 kb, 411 downloads since 2016-04-12 

Re: Recent crashes

ionutm80

could you post a report via the Manager just after the crash will occur next time?

Re: Recent crashes

Chainik wrote:

ionutm80

could you post a report via the Manager just after the crash will occur next time?

Ok, I will try tonight.

Re: Recent crashes

With the new version 4.0.0.74 it got even worse and now even 1080p video crashes instantly even without GPU acceleration.

kernelbase!RaiseException+0x39
msvcr120!__ExceptionPtr::_RethrowException+0x181
avisynth!DllGetClassObject+0x7c53
avisynth!avs_get_frame+0x33
ffdshow!DllUnregisterServer+0x7cfd5
ffdshow!DllUnregisterServer+0x807ea
ffdshow!DllUnregisterServer+0x814c3
ffdshow!DllUnregisterServer+0xada6e
ffdshow!DllUnregisterServer+0xad4a3
ffdshow!DllUnregisterServer+0xada6e
ffdshow!DllUnregisterServer+0x93822
ffdshow!DllUnregisterServer+0xada6e
ffdshow!DllUnregisterServer+0xadd85
ffdshow!DllUnregisterServer+0x173f4
ffdshow!configureEnc+0x535ff
ffdshow!DllUnregisterServer+0x1e5cb
ffdshow!DllUnregisterServer+0x16fb9
ffdshow!DllGetClassObject+0x363f
ffdshow!ffacm2creator+0x204f
ffdshow!DllUnregisterServer+0x1e513
ffdshow!DllUnregisterServer+0x17ae7
ffdshow!configureEnc+0x4dbe0
ffdshow!DllUnregisterServer+0x1e5cb
ffdshow!DllUnregisterServer+0x16fb9
ffdshow!DllGetClassObject+0x363f
ffdshow!ffacm2creator+0x204f
ffdshow!DllUnregisterServer+0x1e513
lavsplitter!OpenConfiguration+0x6235
lavsplitter!OpenConfiguration+0x5cf1
lavsplitter!DllGetClassObject+0x426c
lavsplitter!DllGetClassObject+0x1482d
kernel32!BaseThreadInitThunk+0xd
ntdll!RtlUserThreadStart+0x1d

80 (edited by ionutm80 12-04-2016 20:28:06)

Re: Recent crashes

Chainik wrote:

ionutm80

could you post a report via the Manager just after the crash will occur next time?

Hi Chainik,

I have sent the report via the Manager (e-mail signed ionutm80) and also inserted the crash log:

ntdll!RtlpAllocateHeap+0x1b1b
ntdll!RtlpAllocateHeapInternal+0x27b
ntdll!RtlAllocateHeap+0x2e
WARNING: Following frames may be wrong.
svpflow2!AvisynthPluginInit3+0xaa73
svpflow2!AvisynthPluginInit3+0x88d1
svpflow2!svpGetVersion+0x23d4e
svpflow2!svpGetVersion+0x1af49
svpflow2!svpGetVersion+0x182b9
svpflow2!svpGetVersion+0x18261

However I think that I have narrowed down the problem. I have deactivated GPU acceleration with the trade-off of being forced to lower the quality / moved the slider one step backward ... but no more crashes anymore and tested twice with 3 resolutions: 1080p, 720p and 576p movies all on my 768p 60Hz TV.
Maybe madVR and SVP were fighting on resources?

Re: Recent crashes

ionutm80 wrote:

Chainik wrote:

ionutm80

could you post a report via the Manager just after the crash will occur next time?

Hi Chainik,

I have sent the report via the Manager (e-mail signed ionutm80) and also inserted the crash log:

ntdll!RtlpAllocateHeap+0x1b1b
ntdll!RtlpAllocateHeapInternal+0x27b
ntdll!RtlAllocateHeap+0x2e
WARNING: Following frames may be wrong.
svpflow2!AvisynthPluginInit3+0xaa73
svpflow2!AvisynthPluginInit3+0x88d1
svpflow2!svpGetVersion+0x23d4e
svpflow2!svpGetVersion+0x1af49
svpflow2!svpGetVersion+0x182b9
svpflow2!svpGetVersion+0x18261

However I think that I have narrowed down the problem. I have deactivated GPU acceleration with the trade-off of being forced to lower the quality / moved the slider one step backward ... but no more crashes anymore and tested twice with 3 resolutions: 1080p, 720p and 576p movies all on my 768p 60Hz TV.
Maybe madVR and SVP were fighting on resources?


https://drdump.com/UploadedReport.aspx? … ondVisit=1

This type of crash with GPU Acceleration started happening between version 4.0.0.60 and version 4.0.0.73 (I don't know when or where, but it happened in that time frame, and it's also related to processing threads). Changing some settings around I can make it start hanging instead of crashing, but the problem is there. It never happens with 4.0.0.60 (not for me, and not yet anyway, for almost a week now I've been using 4.0.0.60 Pro, with my custom settings).

Re: Recent crashes

Blackfyre wrote:

This type of crash with GPU Acceleration started happening between version 4.0.0.60 and version 4.0.0.73 (I don't know when or where, but it happened in that time frame, and it's also related to processing threads). Changing some settings around I can make it start hanging instead of crashing, but the problem is there. It never happens with 4.0.0.60 (not for me, and not yet anyway, for almost a week now I've been using 4.0.0.60 Pro, with my custom settings).

Ok, I will give a try to 4.0.0.60.

Since I disabled GPU acceleration I've also noticed some "strange things": instead of helping madVR by releasing more resources it was exactly the opposite, I've noticed a lot of glitches / "shaking frames" with 1080p material until I've made some aggressive changes in madVR settings like:
- no dithering,
- check all boxes to the bottom in trade quality for performance,
- use old path D3D9 and backbuffers
- and even dropping Bicubic 75 AR for chroma scalling / every scalling is now forced to DXVA
(anyway even with all the above is a night and day difference between madVR and EVR-CP quality / my best guess being that by using DXVA scalling on Intel iGPU which is very similar to Lanczos 3 Taps the image gets more crisp which I kinda like it ...)

The thing gets more weird since GPU-Z only shows 24% GPU usage in windowed mode so I assume that in fullscreen mode it cannot go too much higher which mean there are still plenty of resources left for madVR but I cannot use them ... is like  SVP magic done only on my poor CPU (dual core Core I3 1.7 GHz) do not get along very well with madVR.

Anyway with all the above now everything is working smooth with 1 frame repeat / drop every 2.4 hrs in madVR stats.

Other strange stuff noticed is that during my mumbling with the settings in SVP I have noticed that it was sometimes interpolating 1080p23 movies at 64,1.. instead of 54,940. Only a PC restart is fixing the problem.

Re: Recent crashes

ionutm80 wrote:

is like  SVP magic done only on my poor CPU (dual core Core I3 1.7 GHz) do not get along very well with madVR.

SVP's work is done ALL on your CPU if you have GPU Acceleration OFF, even with it on, most of the work is still done by the CPU, the GPU is only there to assist it and decrease the CPU usage if you wish to enable it with GPU Acceleration.

84 (edited by ionutm80 13-04-2016 08:29:46)

Re: Recent crashes

My point also, w/o GPU acceleration I'm quite borderline considering the very weak CPU. However what I struggle to understand is why lowering madVR settings helped also here since that is pure GPU bound ... Could it be that w/o the help of GPU SVP needs more time to interpolate frames to 59,940 and thus madVR which comes after is more squeezed with rendering times? I've noticed higher render times and even spikes above the 16ms threshold now while when GPU was used for SVP the render times in madVR were significantly lower ?! All in all I only see 2 options here for me: either downgrade to a working SVP with GPU acceleration or put everything to bare minimum in madVR.

Re: Recent crashes

ionutm80
The best way is to use GPU Acceleration in SVP of course. But we need to find and fix the error first.
Thank you for the bug report. Maybe we will find the answer there...

Re: Recent crashes

Hi again,

Just a small update: I've used the 4.0.0.60 version provided by Chainik and everything is butter smooth now, GPU acceleration is ON in SVP, I can use more aggressive madVR options and ... no more crashes at all. It still show however "No active playback" for MPC-HC x64 although ffdshow raw is active but anyway I'm using it with the x86 version and everything seems ok now.

@MAG79 Looking forward also for an updated version with the bug fixed. Thanks for all your efforts!

Re: Recent crashes

I'm glad 4.0.0.60 worked for you too. Hopefully this helps narrow down the problem. Anyway, can you use the latest SVP 4.0.0.74 with MPC and MadVR please (this goes for anyone having crashes).

Go to the MadVR Folder, and run madHcCtrl.exe. Right click the system-tray-icon of Madvr at the bottom-right corner of the screen, and choose Edit madVR Settings.

Edit the following settings:

Open the "Rendering" side menu, open "General Settings", make sure CPU Queue Size is set to 20, and GPU Queue Size is set to 10. Also above that, make sure only the first two options are ticked (delay playback, and delay playback after seek). Everything else in general settings should be UN-ticked (OFF).

Go to Windowed Mode side menu, make sure present several frames in advance is ticked (enabled), and in the drop down below that, choose 6.

Go to Trade Quality for Performance side menu and UN-Tick everything (make sure all are OFF).

I have not done enough testing yet, but this has eliminated the crash problem (I need to check if it stopped the hanging problem too). And I haven't checked yet if it's related to Full-Screen Exclusive mode, or Render Queue sizes for CPU & GPU, I changed both at the same time.

Re: Recent crashes

@blackfyre

I can try all this tonight. However I'm afraid that increasing the queues size (for this one I'm not sure), using frames presented in advance and un-ticking everything in TQP might be too much for my Haswell based iGPU HD 4400. The best config. for me, with 1 drop frame every 2-3 hours, was with backbuffers and old path D3D9, everything ticked up to "scale chroma separately" in TQP, exactly the opposite for the first 2 options in general settings meaning to be un-ticked and automatic fullscreen exclusive mode to be ticked.

Re: Recent crashes

ionutm80 wrote:

@blackfyre

I can try all this tonight. However I'm afraid that increasing the queues size (for this one I'm not sure), using frames presented in advance and un-ticking everything in TQP might be too much for my Haswell based iGPU HD 4400.

For me, I was decreasing. Because I had them both set at maximum. So try decreasing them from the defaults you have the set to now.

Re: Recent crashes

Oh well, nope, still problems with the latest version of SVP. Even after doing what I mentioned above:

https://drdump.com/UploadedReport.aspx? … ondVisit=1

4.0.0.60 is still working great though.

Re: Recent crashes

One dumb question though: x64 is supposed to work also for 4.0.0.60? I'm asking this because the version supplied by Chainik only works with x86 for me ... when I try to launch in MPC-HC x64 I see that ffdshow raw is used but SVP is saying "No active playback" !?

Re: Recent crashes

ionutm80 wrote:

One dumb question though: x64 is supposed to work also for 4.0.0.60? I'm asking this because the version supplied by Chainik only works with x86 for me ... when I try to launch in MPC-HC x64 I see that ffdshow raw is used but SVP is saying "No active playback" !?


Well considering 4.0.0.60 doesn't work with SMPlayer + MPV + VapourSynth, I'm going to go ahead and guess that x64 support wasn't around back when it was released. It came after.

Re: Recent crashes

Hi, any news on this front?

Re: Recent crashes

Ok, I think I was finally able to make it crash on one of my PCs not randomly but in just a few minutes, which is good news big_smile

The bad news I still have no idea why it crashes, BUT lets test it (I mean ver.4.0.0.74) with "Animation" mode turned on - which forces 24 grid size plus 2nd SVP shader.

95 (edited by Blackfyre 22-04-2016 13:45:03)

Re: Recent crashes

Chainik wrote:

Ok, I think I was finally able to make it crash on one of my PCs not randomly but in just a few minutes, which is good news big_smile

Haha! YES! That's good bad news. big_smile

The bad news I still have no idea why it crashes, BUT lets test it (I mean ver.4.0.0.74) with "Animation" mode turned on - which forces 24 grid size plus 2nd SVP shader.

Just use my custom settings, crashes it even faster. Or causes hanging if you set processing threads to auto.

EDIT:

If you don't mind me asking, what's the hardware you're testing with? And under what hardware before did you have no problems? (watching 1080P content).

Re: Recent crashes

Interestingly I haven't had a single crash with 4.0.0.74 so far. Although I'm not sure if that's due to the version or I finally found a combination of settings/components that work for me.
I have sent you a bug report through SVP, maybe that helps.

Re: Recent crashes

blabb wrote:

Interestingly I haven't had a single crash with 4.0.0.74 so far. Although I'm not sure if that's due to the version or I finally found a combination of settings/components that work for me.
I have sent you a bug report through SVP, maybe that helps.

Post your versions here so ppl can test them.

Re: Recent crashes

Info from blabb's logs:

SVP 4 Pro [4.0.0.74]
OS: Windows 10 [10.0.10586]
CPU: Intel Core i7-5820K
Video: registry info - AMD/ATI Radeon R9 200
MPC-HC 1.7.10 32-bit with Avisynth (32-bit) 2.6.0.5

Re: Recent crashes

blabb wrote:

Interestingly I haven't had a single crash with 4.0.0.74 so far. Although I'm not sure if that's due to the version or I finally found a combination of settings/components that work for me.
I have sent you a bug report through SVP, maybe that helps.

You mean that after forcing "Animation" on as Chainik proposed you did not experience crashes anymore?
I would also check this tonight but I was a little bit afraid since launching 4.0.0.60 (the one provided by Chainik) instead of installed 4.0.0.74 at windows start-up and make it persistent was a real pain for me

100

Re: Recent crashes

MAG79 wrote:

Info from blabb's logs:

SVP 4 Pro [4.0.0.74]
OS: Windows 10 [10.0.10586]
CPU: Intel Core i7-5820K
Video: registry info - AMD/ATI Radeon R9 200
MPC-HC 1.7.10 32-bit with Avisynth (32-bit) 2.6.0.5

And most recent 32bit ffdshow.
13 Processing Threads on my 12 thread CPU and GPU acceleration on.

ionutm80 wrote:

You mean that after forcing "Animation" on as Chainik proposed you did not experience crashes anymore?

No, I never used 'Animation'.
Those are the settings I use right now:
http://i.imgur.com/V6lOfDh.png