Topic: Recent crashes

ntdll!RtlpFreeHeap+0xa0a
ntdll!RtlFreeHeap+0x142
kernel32!HeapFree+0x14
WARNING: Following frames may be wrong.
svpflow2!AvisynthPluginInit2+0x8972
svpflow2!svpGetVersion+0x16629
svpflow2!svpGetVersion+0x1adba
svpflow2!svpGetVersion+0x18191

while watching [HorribleSubs] Kono Subarashii Sekai ni Shukufuku wo! - 09 [720p].mkv

Post's attachments

active.log 19.13 kb, 352 downloads since 2016-03-09 

opencl.log 20.05 kb, 362 downloads since 2016-03-09 

settings.zip 3 kb, 270 downloads since 2016-03-09 

Re: Recent crashes

Yes for about 2 weeks I think I have also experienced frequent crashes. Everytime it crashes it uploads bug reports automatically.
As you can see, quite a few bug reports with that problem have accumulated. https://drdump.com/Problem.aspx?Problem … ogin=guest

I guess this is a SVP problem, since MPC-HC hasn't been updated for a while and those crashes didn't happen a few weeks ago.

Re: Recent crashes

I collect information about crashes with svpflow2!AvisynthPluginInit2+0xNNNN and with svpflow2!svpGetVersion+0xNNNN.
The error occurs mainly on Intel HD Graphics when GPU-acceleration is used. For now quick solution is to disable GPU-acceleration in SVP.
SVP manager - Application settings - GPU acceleration - No acceleration

In case with AMD Radeon R9 2xx You can change renderer in MPC-HC. madVR causes the errors. I recommend to use EVR Custom with D3D Fullscreen option enabled.
MPC-HC - menu View - Options - Output

Post's attachments

EVR_with_D3D.png, 33.62 kb, 660 x 500
EVR_with_D3D.png 33.62 kb, 394 downloads since 2016-03-10 

Re: Recent crashes

Yeah I have an AMD 290X. But it doesn't seem to be madVR since I already use Enhanced Video Renderer and the crashes still occur.
I didn't have D3D Fullscreen enabled though, so I'm trying that now.

Re: Recent crashes

After one of the updates to SVP I had a few crashes too (I don't remember which update). It was something new that hadn't happened before, but I remember the error log looking similar to the one posted in the original post. I reset ALL of SVP's setting's to default, and then re-done my custom profiles and everything worked fine with no crashes whatsoever.

So try this... Right-Click SVP Tray Icon to bring up the MENU... Expand "Application Settings" menu... Then expand "Additional Options" menu... Then click on "Reset settings to defaults".

I assumed that maybe in one of the previous updates one or two values needed to be edited which the update missed, and it resulted in crashed. I fixed this issue quickly and haven't had any crashes since. Didn't see anyone complaining about it earlier so I assumed it was a unique issue to me.

Anyway, I hope that helps.

Re: Recent crashes

Thanks for the tip Blackfyre. Sadly it didn't work for me. I reset the settings yesterday and today I got that crash:

WARNING: Following frames may be wrong.
ntdll!RtlReleaseSRWLockShared+0x1cdb
ntdll!RtlAllocateHeap+0x2cb
ntdll!RtlAllocateHeap+0x2e
svpflow2!AvisynthPluginInit2+0xaa63
svpflow2!AvisynthPluginInit2+0x88c1
svpflow2!svpGetVersion+0x23aba
svpflow2!svpGetVersion+0x1adba
svpflow2!svpGetVersion+0x18191

@MAG79 any more ideas?

Re: Recent crashes

blabb
I checked the error on Radeon R9 285. I used Crimson 16.2.1. I can't reproduce the error on it.
Now Crimson 16.3 is available. Try it. Maybe this is the cause and it will help you.

Re: Recent crashes

It still crashes with Crimson 16.3.

But I had an idea how to look up when the first crash happened. It was February 23rd.
So the change probably was made in that version:

Manager - 4.0.0.66 - 2016-02-22
+ SVP logo in the Control panel now shows main menu
+ "Reset to defaults" option
= "1.5m" mode now works the same way as in SVP 3
+ MT mode = 1 for SVPflow functions
SVPflow - 4.0.0.128 - 2016-02-22
+ improved multi-threaded performance and stability

Re: Recent crashes

Try to disable black bar detection.

Right click SVP Tray Icon, open video-frame menu, and tick OFF the first option "Detect and Cut Off Black Bars". Also disable "Outer Lighting" if you have it enabled. Report back if that helps with the crashes.

Re: Recent crashes

I've never had black bar detection or outer lighting enabled.

11 (edited by Blackfyre 15-03-2016 14:37:35)

Re: Recent crashes

blabb wrote:

I've never had black bar detection or outer lighting enabled.

Okay. My last question will be. Is your CPU overclocked? and if yes, can you tone it down to its original speed and test?

Maybe your overclock is not stable?

Other recommendations:

Update your LAV Filters to the latest version:

Link: http://forum.doom9.org/showthread.php?t=156191
Click on: Version 0.68: Installer (both x86/x64)

And update your Media Player Classic to the latest nightly:
Link: https://nightly.mpc-hc.org/
Click on: MPC-HC.1.7.10.130.x86.VS2015.exe

Re: Recent crashes

ntdll!RtlpFreeHeap+0xa0a
ntdll!RtlFreeHeap+0x142
kernel32!HeapFree+0x14
WARNING: Following frames may be wrong.
svpflow2!AvisynthPluginInit2+0x8972
svpflow2!svpGetVersion+0x16629
svpflow2!svpGetVersion+0x1adba
svpflow2!svpGetVersion+0x18191

again.
Is there any way to disable drdump? So I could make process dump next time it crush

Re: Recent crashes

Next crash. This time a little different. I have updated LAV filters to latest version and MPC-HC to latest nightly.

kernelbase!RaiseException+0x48
msvcr120!__ExceptionPtr::_RethrowException+0xd5
WARNING: Following frames may be wrong.
avisynth!DllGetClassObject+0x7868
avisynth!avs_get_frame+0x44
ffdshow!DllUnregisterServer+0x6c88c
ffdshow!DllUnregisterServer+0x70c9d
ffdshow!DllUnregisterServer+0x93cd2

Re: Recent crashes

tachiorz
blabb
Ok. Try pack 'plugins122&MTmode2.zip'. It is SVPFlow libraries ver.122 and MT mode back to 2.
To restore original SVP4 files use 'plugins130&MTmode1.zip'

Unpack to SPV4 folder with files replacing.

Post's attachments

plugins122&MTmode2.zip 593.4 kb, 278 downloads since 2016-03-16 

plugins130&MTmode1.zip 4.52 kb, 274 downloads since 2016-03-16 

15 (edited by Blackfyre 16-03-2016 16:15:08)

Re: Recent crashes

MAG79 wrote:

tachiorz
blabb
Ok. Try pack 'plugins122&MTmode2.zip'. It is SVPFlow libraries ver.122 and MT mode back to 2.
To restore original SVP4 files use 'plugins130&MTmode1.zip'

Unpack to SPV4 folder with files replacing.

He doesn't need to extract the content in plugins122 into the plugins folder correct?

Because the script should point to that directory yes?

So all he has to do is extract plugins122&MTmode2.zip into the SVP 4 folder? (which will now have plugins122 and plugins folders - two of them).

I'm asking because I want to test SVPFlow libraries ver 122, I think they show even less artifacts than plugins130.

Re: Recent crashes

Blackfyre
yes
yes
yes

I share them for testing purposes. Just what you want smile
If it helps then we can find the cause of errors from ths topic.

Re: Recent crashes

I don't think I can give a definitive answer yet, but I wanted to give an interim result: So far I have not experienced any crashes with 'plugins122&MTmode2.zip' so it's looking good smile

Do I have to replace those files again if I update to 4.0.0.72?

Re: Recent crashes

blabb
No. I belive this bug is fixed in 4.0.0.72 version. Try it.

Re: Recent crashes

MAG79 wrote:

blabb
No. I belive this bug is fixed in 4.0.0.72 version. Try it.

I've updated to the latest version and it just crashed on me. Similar to OP, I've been experiencing crashes the past 2 weeks.

Crashes doesn't seem to happen if I disable GPU acceleration. Can't confirm but will be testing it out the next 2 hours.

Re: Recent crashes

I just ran an hour of the same video that crashed earlier but this time without GPU acceleration. Video played perfectly.

I'm running an AMD Radeon 6870. It seems to be a problem with AMD GPUs.

Re: Recent crashes

Seems fine to me. No crashes after v72. amd 7850

Re: Recent crashes

Xanthon
Did you try MPC-HC x64 with avisynth+?
It gives me more stability with my ultrabook (i3-3217U + HD4000). Try it.

Re: Recent crashes

MAG79 wrote:

Xanthon
Did you try MPC-HC x64 with avisynth+?
It gives me more stability with my ultrabook (i3-3217U + HD4000). Try it.

Weird to hear this about x64 avs+. It leaks for me and my brother PC like crazy.

Re: Recent crashes

dlr5668
I have no memory leaks with x64 and AVS+. Maybe it depends on system or profile settiings. I use very fast settings for my very slow i3-3217U wink

Re: Recent crashes

For anyone still having crashes... Use SVP Maintenance tool to do a complete uninstall, go uninstall LAV Filter, Madvr, MPC-HC, ffdShow, everything. Clean the folders. Run CCleaner, do registry fixes to delete left over residue (do this a few times until it doesn't pick anything up anymore).

Then download SVP Pro from your activation email if you have SVP Pro, or download SVP 4 Free from the website, go through the installation process and tick EVERYTHING from there, use the default setups that come up and don't add or tick anything extra from ffdShow setups. Once everything is complete use MPC and test and see if you have any crashes. Tell LAV Filters to reset to default settings too in the process of installing. If you're still getting crashes, I really don't know what more to do. Haha we've went through all the steps I can think of already in this thread.

I had one type of crash that was happening, and that's gone now too after I done these steps.