1 (edited by Blackfyre 04-03-2016 19:27:21)

Topic: SVP 64-Bit for Windows Released - Feedback

Hi Everyone;

SVP 64-Bit Support has just been released with the latest update, I would like to get some feedback on everyone's experiences. I'm looking forward to testing it myself now.

Regards, Blackfyre.

Re: SVP 64-Bit for Windows Released - Feedback

It works, just be prepared for the memory leaks on every seek big_smile

I think there's no hope left for a stable Avisynth 64 bit, so lets use what we have... and wait for any Vapoursynth-enabled Windows video players (or something else wink)

Re: SVP 64-Bit for Windows Released - Feedback

i use svp4 pro with potplayer, after updating(64 bit engine and other things) i ran into couple of problems with potplayer.In MPC both 32 and 64bit works fine but its completely broken with pot player now. SVP not even detecting the video playback in potplayer 32 and 64 bit but if i run pot player with admin previlege it detects but poor performance(is not going above 40fps checked with fraps)   

I tried in both my home desktop pc and in my laptop.both have same problem.I tried reinstalling in both,so i removed them completely and then tried installing only 32bit components ,still not detecting in pot player(detects with admin previleges but poor performance), 

i never had this problem with previous versions of svp4 pro and run at 60fps

anyone facing the same issue? this problem is related to update or i am going wrong somewhere?
and anyone test with pot player and post results?
thanks.

Re: SVP 64-Bit for Windows Released - Feedback

What exactly do i need (to install or configure) to test SVP in 64-bit mode with MPC?

Re: SVP 64-Bit for Windows Released - Feedback

xarunx

the only thing you could possibly do to break something in the 32-bit chain with the latest update is to (occasionally) install Avisynth+ 32-bit

Slayer Moon

1. install
2. configure
big_smile

6 (edited by Nintendo Maniac 64 04-03-2016 20:52:52)

Re: SVP 64-Bit for Windows Released - Feedback

Go figure - I've been wanting to try out the 64bit version, but I've been planning on somewhat redoing my MPC-HC configuration once LAVfilters 0.68 (and hypothetically MPC-HC 1.7.11) comes out in preparation for a future 64bit SVP.

I never figured the 64bit SVP would be released first...

Re: SVP 64-Bit for Windows Released - Feedback

Just to be clear:

64-bit video chain is NOT recommended.
Use it at your own risk (c)

8 (edited by Blackfyre 04-03-2016 22:52:17)

Re: SVP 64-Bit for Windows Released - Feedback

Chainik wrote:

So lets use what we have... and wait for any Vapoursynth-enabled Windows video players (or something else wink)

Yeah I believe you're right. We enter the waiting game now.

wink

Re: SVP 64-Bit for Windows Released - Feedback

Will it be possible to use dxva + vapoursynth on windows ?

10 (edited by cookieboyeli 05-03-2016 01:50:31)

Re: SVP 64-Bit for Windows Released - Feedback

An alternative to Reclock is also needed now since the reclock devs choose to support bloatware rather than create a 64 bit build.

It seems there's up to 1ms higher render times using 64-bit, system memory usage went from around 3100mb to 3600mb, vram usage is pretty much unchanged.

Re: SVP 64-Bit for Windows Released - Feedback

cookieboyeli wrote:

An alternative to Reclock is also needed now since the reclock devs choose to support bloatware rather than create a 64 bit build.

It seems there's up to 1ms higher render times using 64-bit, system memory usage went from around 3100mb to 3600mb, vram usage is pretty much unchanged.

Now use seek few times big_smile

12 (edited by MistahBonzai 05-03-2016 04:08:23)

Re: SVP 64-Bit for Windows Released - Feedback

SVP 4 (x64) is working fine with MPC-BE x64 smile However with MPC-HC x64 it continues to throw the same error concerning not being able to init the GPU sad (see attached screen clip). Just to recap..I had the same issue when running a manual config utilizing AviSynth scripts (MPC-BE x64 is fine while MPC-HC is a no-go with gpu:1 - fine with gpu:0). It's starting to look like a MPC-HC issue but no one else is complaining. Anyone using ffdshow 64bit with SVPflow Avisynth+ scripting like the ones posted by yan04000985 http://www.svp-team.com/forum/viewtopic … 410#p57410 with MPC-HC? (he uses MPC-BE x64)

Question(s):

  • Anyone using the new SVP 4 x64 variant with MPB-HC x64 with success?

  • If so did you use the complete manifest of SVP 4 optional software?

Post's attachments

error.png 41.35 kb, 223 downloads since 2016-03-04 

Re: SVP 64-Bit for Windows Released - Feedback

I  enjoy svp as quite some time, but i think never like that until now, I generally use high quality mkv or m2ts movies, with this update and exactly same settings i notice i have much less artifacts, a better and fluid experience, and better overall quality
I use Svp Pro+MPC-HC x64 1.7.10+ madvr 0.90.13 with these settings
-Uniform/13.Standard/Weakest/half pixel/12px. Average 2/Disabled/Average/Strongest/Large/Repeat frame
And it take the recomendation of  Nintendo Maniac 64 and  select my numbers of threads manually.

Re: SVP 64-Bit for Windows Released - Feedback

MistahBonzai wrote:

Anyone using ffdshow 64bit with SVPflow Avisynth+ scripting like the ones posted by yan04000985 http://www.svp-team.com/forum/viewtopic … 410#p57410 with MPC-HC? (he uses MPC-BE x64)

Wasn't your problem already over?
http://www.svp-team.com/forum/viewtopic … 265#p56265

15 (edited by EzioAs 05-03-2016 08:08:26)

Re: SVP 64-Bit for Windows Released - Feedback

Hi,

I've just tried the 64-bit version. It seems like I'm getting some lower framerates and stutters when I set conversion to monitor refresh rate (60Hz) or Fixed 60 FPS when using either 32-bit player or 64-bit player. 48FPS works fine though. Anyone has any solution how I can get good 60FPS like before I installed the new component?

Thanks.

EDIT: Turns out it's the SVP Shader. I can't use 23.Complicated, but 13.Standard works fine. Weird as it seems like there's no high usage on CPU or GPU though.

Re: SVP 64-Bit for Windows Released - Feedback

dlr5668 wrote:

Will it be possible to use dxva + vapoursynth on windows ?

only if someone will build mpv for Windows with vapoursynth support PLUS will add a TCP socket-based IPC channel to mpv itself (currently it doesn't support JSON IPC on Windows!)

Re: SVP 64-Bit for Windows Released - Feedback

Hi: I'm getting the following error using MPC-HCx64 and SVP 64bit for Windows:

SVSmoothFps: unable to init GPU-based renderer-code 255(C:\Users\kbumm\AppData\Roaming\SVP4\scripts\d0990.avs, line 43)(C:\Users\kbumm\AppData\Roaming\SVP4\scripts\d0990.avs, line 60)(ffdshow_filter_avisynth_script, line 3)

Re: SVP 64-Bit for Windows Released - Feedback

> unable to init GPU-based renderer-code 255

this error is about not loaded OpenCL.dll (i.e. - the library is not found)
64-bit version in this case

Re: SVP 64-Bit for Windows Released - Feedback

biff wrote:

Hi: I'm getting the following error using MPC-HCx64 and SVP 64bit for Windows:

SVSmoothFps: unable to init GPU-based renderer-code 255(C:\Users\kbumm\AppData\Roaming\SVP4\scripts\d0990.avs, line 43)(C:\Users\kbumm\AppData\Roaming\SVP4\scripts\d0990.avs, line 60)(ffdshow_filter_avisynth_script, line 3)

I don't feel so alone now wink Same here. You don't happen to be using AMD 'Crimson' drivers?

Post's attachments

SVP active.log 3.38 kb, 624 downloads since 2016-03-05 

20 (edited by biff 05-03-2016 19:20:11)

Re: SVP 64-Bit for Windows Released - Feedback

Nah, I'm using NVIDIA 362.00 on a GTX970

So, Chainik, is this a Windows 10 issue, maybe? (I'm using the latest build 14279)

Re: SVP 64-Bit for Windows Released - Feedback

> I don't feel so alone now

completely different errors
yours is about some unknown failure in the video driver, while "code 255" is just "opencl.dll is not found or can't be loaded"

Re: SVP 64-Bit for Windows Released - Feedback

mashingan wrote:
MistahBonzai wrote:

Anyone using ffdshow 64bit with SVPflow Avisynth+ scripting like the ones posted by yan04000985 http://www.svp-team.com/forum/viewtopic … 410#p57410 with MPC-HC? (he uses MPC-BE x64)

Wasn't your problem already over?
http://www.svp-team.com/forum/viewtopic … 265#p56265

Yes, but but even cleaning ffdshow 64-bit completely out and letting SVP 4 'upgrade' to ffdshow x64 it isn't helping this time. I think the issue reappeared when I re-upgraded from old Radeon to Crimson - now @16.2 hotfix. I'm gonna revert to 15.71 again and see how it plays out. I'm collecting all pertinent logs along the way. I wasn't gonna comment until done until I saw the post from Biff but I see he has NVIDIA/Windows 10. I'm AMD/Windows 7. Back to running more diagnostics...

Re: SVP 64-Bit for Windows Released - Feedback

Fixed! Rolled back my NVIDIA driver to version 361.43  Thanks for the input guys.

24 (edited by MistahBonzai 05-03-2016 21:14:15)

Re: SVP 64-Bit for Windows Released - Feedback

Fixed! Rolled back my AMD Crimson driver pack to pre-Crimson 15.7.1.

Looks like AMD still hasn't fixed the Open CL library issue even in the latest Crimson 16.2 hotfix driver pack sad . From my experience GPU acceleration doesn't buy me all that much - GPU load goes up ~5% and CPU load drops slightly. That's not a bad thing cuz I can use the extra GPU capacity for more madVR headroom and I do have extra CPU (i7-3770) capacity. So in the end it helps balance it all out in my case. Back to Crimson 16.2.1 hotfix.

FYI: Weird side effect of latest Crimson pack (not seen in 16.1.1) is that it somehow blocks my 'Weather Underground gadget' from internet access in the 'Sidebar' - yeah, I still use that functionality for GPU, CPU and Weather gadgets even though it's no longer supported.

Post's attachments

SVP 4 with win7-Radeon 15-5-1 drivers active.log 3.57 kb, 620 downloads since 2016-03-05 

Re: SVP 64-Bit for Windows Released - Feedback

> From my experience GPU acceleration doesn't buy me all that much - GPU load goes up ~5% and CPU load drops slightly.

if you're talking about "auto options selection" this's exactly how it should work - choose the highest options possible for the given hardware performance level