Topic: SVP 4 Pro — видео выглядит менее плавным, чем оригинал

Добрый день.

TL;DR: с включённым svp видео выглядит менее плавным, чем с выключенным

Длинная версия. Был у меня установлен SVP3 (да и сейчас установлен) и обновился я до SVP4TP, и обрадовался тому, что работает оно лучше, в особенности на перемотке. Потом обновился я до SVP4Free и возникла у меня проблема, видео с включённым svp становилось дёрганее, чем с выключенным. Отослал я тогда багрепорт через программу и получил ответ, что у меня «одновременно используются И ffdshow video decoder, и ffdshow raw filter». Ответил я на то письмо, но переписка в одностороннем порядке прекратилась и ответа я так и не получил, а проблема разрешилась сама собой после перезагрузки пк (к слову перезагружаю пк я редко, на ночь я его просто в сон погружаю). Так вот пользовался я SVP4Free и бед не знал, вплоть до выхода SVP4Pro. Памятуя о прошлых проблемах я решил не рисковать и удалил SVP4Free, перезагрузился, установил SVP4Pro и ещё раз перезагрузился, но не тут то было. В SVP4Pro появилась та-же самая проблема — с включённым svp видео становилось менее плавным, чем с выключенным. Об этом я сразу настрочил багрепорт, но вот прошло несколько обновлений, но проблема так и остаётся нерешённой, а на багрепорт письма с ответом я так и не получил (неделя прошла, спам проверял, там пусто). Сегодня накатал багрепорт ещё раз, но уже на английском, думал что там мне может быть ответят, а потом вспомнил, что ведь есть ещё и форум, где потерять мой багрепорт уже не получится и вот я здесь.

Лог того, как я минуту смотрю заедающее видео есть во вложении. Прошу всяческой помощи в разрешении проблемы, смотреть с использованием SVP3 уже надоело, уж больно там большая задержка при перемотке, а перематываю я часто.

Post's attachments

active.log 3.1 kb, 916 downloads since 2015-11-15 

Re: SVP 4 Pro — видео выглядит менее плавным, чем оригинал

Reflex
SVP3 использует Avisynth 2.5.8, а SVP4 - avisynth 2.6. Кроме того, было сообщение от пользователя, что SVP4 может некорректно определять число потоков при установке Auto.
И то и другое может пагубно сказаться на плавности.
Поэтому попробовать 2 вещи:
1. Заменить avisynth на 2.5, для чего поместить avisynth.dll из папки SVP3\Resources\Avisynth\ в папку к плееру (если там уже есть, то с заменой).
2. Указать число потоков в SVP4 вручную. Для core i5 указать 7 потоков, для i7 - 15 потоков.

Re: SVP 4 Pro — видео выглядит менее плавным, чем оригинал

Заработало! Установил 15 потоков и сразу заработало. Спасибо.

Насчёт Avisynth, у меня был установлен 2.6 MT ещё до перехода на SVP 4, и никаких проблем у SVP 3 с ним не возникало (собственно он и сейчас с ним работает). Потом с установкой и переустановкой различных редакций SVP 4 версия Avisynth была заменена установщиком, в котором я выбирал 2.6 MT.

Re: SVP 4 Pro — видео выглядит менее плавным, чем оригинал

Аналогичная проблема, решил зарегистрироваться, чтобы рассказать, как вылечить.

Суть проблемы в том, что SVP4TP работал нормально, а как вышла финальная версия -- при использовании SVP4Free/Pro (пробовал обе) видео начинает играть примерно с половинным фреймрейтом вместо того, чтобы играть с удвоенным.

Вылечил ручным сносом всего, что использует SVP3 (сам SVP3, AviSynth 2.5, ffdshow, MPC-HC) и установкой обратно вручную всех компонентов SVP4Pro (сам SVP4Pro, AviSynth 2.6 MT, ffdshow, MPC-HC). За исключением ffdshow всё ставил именно вручную, а не через инсталлятор SVP4.

Сама проблема вызывается, насколько я смог разобраться, тем, что текущий инсталлятор SVP4 почему-то не устанавливает необходимый SVP AviSynth. Сам эффект половинного фреймрейта, наблюдаемый мной и, возможно, автором топика, судя по всему, вызван тем, что SVP4 пытается работать с ранее установленным для SVP3 AviSynth 2.5 -- потому как установки AviSynth 2.6 MT не происходит. Во всяком случае, SVP4 после установки начисто с принудительно помеченной галочкой установки AviSynth 2.6 написал мне, что AS не найден. После того, как я вручную установил 2.6 и MT -- всё начало работать нормально.

Изменение вручную числа потоков мне не помогало вообще никак.

Re: SVP 4 Pro — видео выглядит менее плавным, чем оригинал

dgrdsv
У меня похожая проблема была:
Запускалось обновление SVP4
Скачивались новые компоненты
Начинался этап Удаление старых компонентов
И все, поолоса загрузки в одном месте, в логе ничего не написано, процесс обещает быть бесконечным.
Проблема решилась после переустановки винды.

Re: SVP 4 Pro — видео выглядит менее плавным, чем оригинал

dgrdsv wrote:

Аналогичная проблема, решил зарегистрироваться, чтобы рассказать, как вылечить.

Суть проблемы в том, что SVP4TP работал нормально, а как вышла финальная версия -- при использовании SVP4Free/Pro (пробовал обе) видео начинает играть примерно с половинным фреймрейтом вместо того, чтобы играть с удвоенным.

Вылечил ручным сносом всего, что использует SVP3 (сам SVP3, AviSynth 2.5, ffdshow, MPC-HC) и установкой обратно вручную всех компонентов SVP4Pro (сам SVP4Pro, AviSynth 2.6 MT, ffdshow, MPC-HC). За исключением ffdshow всё ставил именно вручную, а не через инсталлятор SVP4.

Сама проблема вызывается, насколько я смог разобраться, тем, что текущий инсталлятор SVP4 почему-то не устанавливает необходимый SVP AviSynth. Сам эффект половинного фреймрейта, наблюдаемый мной и, возможно, автором топика, судя по всему, вызван тем, что SVP4 пытается работать с ранее установленным для SVP3 AviSynth 2.5 -- потому как установки AviSynth 2.6 MT не происходит. Во всяком случае, SVP4 после установки начисто с принудительно помеченной галочкой установки AviSynth 2.6 написал мне, что AS не найден. После того, как я вручную установил 2.6 и MT -- всё начало работать нормально.

Изменение вручную числа потоков мне не помогало вообще никак.

Проще скопировать 1-2 (зависит от версии) dll avs  в папку с плеером и не знать проблем.

Re: SVP 4 Pro — видео выглядит менее плавным, чем оригинал

Ставил на 2 компа, решения не нашёл, но вроде как на эту тему натыкался.
SVP4 онлайн инсталятор, других и нет.

Ставил всё с madVR, на моём i5 3570K (7 64, svp 32) это даёт большую плавность при меньшей нагрузке. На тот момент была карта ATI HD4850, потом встроенная i HD4000 , теперь 1050ti . Возможно для мощной карты и другие методы будут лучше.

Но чтоб madVR стал, нужно удалить всё через SVP меню и через удаление программ и ставить с нуля.
Ещё косяк SVP 4 Free Manager не становится в автозагрузку, надо кидать ярлык.

Первый ПК: свежая 7 x64(старая версия) , FM2 X2 340, GT730, 4гб ОЗУ. Свежий аваст антивирус.
После установки, запустил видео и выдало "не установлен avisynth" . Переставлял версии 32 и 64 и обе сразу, одинаково.
avisynth в установке программ есть, но в меню Пуск нет, на моём компе со старой версией SVP, AviSynth в меню Пуск есть, на него и подумал.
В итоге залез в паку avisynth  куда он и становится, нашёл какойто файлик, в нем ссылку на гитхаб, скачал оттуда инсталятор свежего avisynth , установил выбрав сразу 32 и 64, и проблема решилась.
Видео пошло, но avisynth в меню Пуск так и не появился, видимо особенность новой версии.

Через меню утилит поставил патч 4гб на mpc x64, даже не знаю даёт ли что.

Второй ПК: древняя 7 32 забитая играми, E7200, GT9500 , 2гб ОЗУ. Антивируса ещё не было.
Всё стало и заработало сразу, avisynth  в меню всё также нет.

Патч 4гб тут както не логично упоминать, при том что их всего 2гб, потому решил не рисковать, приемлемо работает на 720 клипах, дальше не тестировал. Но комп будет как плеер, врятли чтото  кроме DVD будут смотреть. Хотя не знаю.

Даже не знаю кто виновник, кривая сборка svp 64 конфигурации или антивирус.
Есть ли различия инсталятора под 32 и 64 ? Возможно защитник системы чтото не дал поставить, он там включен.

Re: SVP 4 Pro — видео выглядит менее плавным, чем оригинал

> залез в паку avisynth  куда он и становится, нашёл какойто файлик, в нем ссылку на гитхаб, скачал оттуда инсталятор свежего avisynth , установил выбрав сразу 32 и 64, и проблема решилась.

конечно, зачем искать простые пути, когда есть сложные

и это еще повезло, что там наконец появился инсталлятор (2017-12-19), потому что раньше его просто не было