1 (edited by Feeed 15-10-2014 08:28:47)

Topic: SVP hides parts of the video

Hey, i started using SVP recently, and I noticed parts of the video im watching was missing when im using it. I took pictures as that should explain easier.

Without SVP: http://i.imgur.com/eydoYVv.png

With SVP: http://i.imgur.com/MRwdtbM.png

SVP settings: http://i.imgur.com/0rXrS8U.png?1

As you can see there is a lot of missing content when im using SVP, and the subtitles are also in the wrong place. Any idea whats causing this? Im using MPC version 1.7.3.

Re: SVP hides parts of the video

Do you disable frame crop setting?

Re: SVP hides parts of the video

Feeed
See details about video processing by SVP in debuginfo.txt: SVP tray menu - Information - Additional information.
You can find all answers there. Post here that content of debuginfo.txt if you can't understand it.

mashingan may be right. It can be enabled frame cropping option. And you will see it in debuginfo.

4 (edited by Feeed 15-10-2014 21:41:04)

Re: SVP hides parts of the video

Where can I find the frame crop setting? Im not sure if I did it correctly but is it: Information > Hidden Settings > ;Multiply factor for cropping (pixels) and changing the value from 2 to 0?

When I tried opening Additional information it was an empty .txt file.

5 (edited by mashingan 15-10-2014 22:28:22)

Re: SVP hides parts of the video

You must change your setting interface to expert (2nd from top).
http://www.svp-team.com/forum/misc.php?item=3271

Disable frame crop in that setting interface.

Post's attachments

spvsetting.jpg, 43.68 kb, 244 x 578
spvsetting.jpg 43.68 kb, 384 downloads since 2014-10-15 

Re: SVP hides parts of the video

Checked and it was disabled already, not sure exactly what happened but the video got fixed too without me doing anything.

Re: SVP hides parts of the video

Maybe it's automatically disabled after you change your interface to expert?  big_smile

8 (edited by Feeed 16-10-2014 00:09:31)

Re: SVP hides parts of the video

mashingan wrote:

Maybe it's automatically disabled after you change your interface to expert?  big_smile

I had my interface on expert since I used the program so that shouldn't be the reason.

I figured out what the problem is, and its seems to depend on which program is running first. http://imgur.com/a/MrK2n#0

If MPC is running before SVP it looks similar to the original video but with different subtitle placements.
If MPC is running before SVP without auto crop black bars its similar to the original video.
If MPC is running after SVP the video cuts some content from the top and bottom.

Im not sure why this happens but at least I know to run SVP after MPC is running.

Re: SVP hides parts of the video

Feeed
debuginfo.txt cleared every time you start SVP-manager and filled every time you play video with smoothness. So to watch debuginfo you need to play video first.

Re: SVP hides parts of the video

MAG79 wrote:

Feeed
debuginfo.txt cleared every time you start SVP-manager and filled every time you play video with smoothness. So to watch debuginfo you need to play video first.

Ah yes of course, I feel slightly stupid now, here is it.

Last processed file parameters:
Filename: [Coalgirls]_Nekomonogatari_Shiro_01_(1920x1080_Blu-ray_FLAC)_[20D629CC].mkv
Frame size and frame rate: 1920x1080 pixels, 23.976 fps
After auto crop: 1920x652 pixels

Detected screen parameters
Screen size and refresh rate: 1920x1080 pixels, 60 Hz

Video smoothing info
Smooth factor: 5:2
Resulting video frame rate: 59.94 fps
Repeat 1 frame every 17 sec

Selected profile: 1920x800@24

Profile settings of video processing
[ExMethod=MSmoothFps_3]        Frames interpolation mode: Adaptive (default)
[ExAlgo=13]            SVP shader: 13. Standard (default)
[ExMulti=MON]            Target frame rate: To screen refresh rate (default)
[ExBlockSize=32x32:2]        Motion vectors grid: 24 px. Large 2
[ExRecalc=0:0]            Decrease grid step: Disabled (default)
[TypeDist=Hex:-6:SAD]        Search radius: Small and fast
[ExPel=0]            Motion vectors precision: Two pixels
[Badsad=1000:-24]        Wide search: Average (default)
[ExSadml=0]            Artifacts masking: Disabled (default)
[ExBlend=false]            Processing of scene changes: Repeat frame (default)
[ExDwnResize=0]            Decrease frame size: Disabled (default)

Settings by menu
[svp_libflowgpu=1]        GPU-acceleration (OpenCL): true
[ExThreads=0]            Processing threads: Auto
[StereoMode=0]            Stereo mode (3D): Plain 2D
[AutoCrop=1]            Auto crop black bars: true [0:214:0:214]
[HandCrop=None]            Frame crop: Disabled
[Borderlight=None]        Outer lighting: Disabled
[VDelay=0]            Video delay: 0 ms
[ExDemo=0]            Demonstration mode: false
[ExTearingTest=0]        Tearing test: false
[StopSmoothDelayOnRewind=1]    Turn off on seek: Turn off by 1 sec

Re: SVP hides parts of the video

Have you tried playing with auto crop disabled and running SPV before MPC-HC?

From your picture you only tried setting without auto crop black bars by running MPC before SPV,
so what will happen if you reverse it?

Re: SVP hides parts of the video

mashingan wrote:

Have you tried playing with auto crop disabled and running SPV before MPC-HC?

From your picture you only tried setting without auto crop black bars by running MPC before SPV,
so what will happen if you reverse it?

Same thing, video is similar to running MPC without SVP.

Re: SVP hides parts of the video

Feeed wrote:

Same thing, video is similar to running MPC without SVP.

Hmm, all I think the cause is auto crop black bars.

I think you should disable it.

Re: SVP hides parts of the video

mashingan wrote:
Feeed wrote:

Same thing, video is similar to running MPC without SVP.

Hmm, all I think the cause is auto crop black bars.

I think you should disable it.

Yep I figured that out now. smile

Re: SVP hides parts of the video

Feeed

[AutoCrop=1]            Auto crop black bars: true [0:214:0:214]

Are detected black bars have true values? 214px from the top and from the bottom of the frame. hmm
If it true then it looks like double-cropping. SVP crop once and some application crop again. Maybe it is custom user settings of ffdShow crop option. See ffdShow properties.

Re: SVP hides parts of the video

MAG79 wrote:

Feeed

[AutoCrop=1]            Auto crop black bars: true [0:214:0:214]

Are detected black bars have true values? 214px from the top and from the bottom of the frame. hmm
If it true then it looks like double-cropping. SVP crop once and some application crop again. Maybe it is custom user settings of ffdShow crop option. See ffdShow properties.

I checked ffdShow and the crop option is turned off, so it shouldn't interfere with the SVP crop. Not sure how I can check the crop true value tho.

Re: SVP hides parts of the video

Feeed
You can turn on/off the SVP AutoCrop function. Use HotKeys Ctrl-Shift-C while watch the movie.
It gives you black bars detection just in place in video you watching. It works once and applies detected cropping to whole video.
Maybe in you case title of your video has another black bars than other part of video. In this case you need to detect black bars again using these HotKeys.