Topic: SVPTube No Longer Works

I don't know when this issue cropped up as I haven't used it in a while but today I attempt to play a youtube video by copying it's URL SVPTube would initially open and recognize the video but then refuse to play the content if I asked it to in the pop-up menu, the default video player MPV not even opening. So I tried changing the default player to MPC-BE and now SVPTube doesn't open automatically when copying a video's URL and when I manually open the dialog window it will now open MPC-BE when I ask it to play the video, which it still recognizes, and MPC-BE opens but no content is shown, it's just an empty player. I have no idea how to resolve this. Thanks for any help.

Re: SVPTube No Longer Works

It works when I check. Try this link: … UGc3BhY2V4
SVTtube shows popup window when I copy the link to clipboard.
mpv playback video without any issues. MPC-BE too.
Video interpolation works in both cases.

3 (edited by kapqa 23-11-2023 17:15:06)

Re: SVPTube No Longer Works

yesterday and today tried to build mpv with svp4 /tube instructions, but it would no longer allow me to play video via svp4 tube,

maybe i did something wrong during compile of mpv?

this is error getting after passing url to svptube and clicking play

[ffmpeg] https: HTTP error 403 Forbidden
18:02:52.083 [i]: Settings: loading leds.cfg OK
18:02:52.172 [i]: Extensions: found svptube ...
18:02:52.176 [W]: Settings: creating tube.cfg with default values
18:02:52.176 [i]: Settings: loading tube.cfg OK
18:02:52.238 [i]: Tube: initializing youtube_dl...
18:02:52.619 [i]: Main: initialization completed in 1261 ms
18:02:52.748 [i]: Updates: checking now...
18:02:56.400 [i]: Tube: youtube_dl ready
18:02:56.433 [i]: Performance: quick estimation = 374 (previous value was 0)
18:03:15.041 [i]: Performance: motion vectors estimation = 1017
18:03:25.556 [i]: Performance: CPU-based frame rendering = 1932
18:03:43.299 [i]: Tube: video format id 247 selected
[ffmpeg] https: HTTP error 403 Forbidden
Failed to open

Exiting... (Errors when loading file)
18:03:43.824 [i]: VideoPlayer: mpv [mpv] connected, waiting for the video info...

this on ubuntu 20.04 or 22.04<
also instructions for macos seem to require now bigsur.

Re: SVPTube No Longer Works

the problem solved on Ubuntu by removing "mpv" that got installed somehow via repository, and afterwards changing the svp4 tube settings linking to mpv from




now it would again function, so if on Linux, pay attention if you have already mpv installed via repository as this might/will inhibit the playback most probably.

Re: SVPTube No Longer Works

Same problem here ( The link is detected, I can choose a profile from the list but the download itself doesn't work.

Re: SVPTube No Longer Works

any specific link?

7 (edited by kapqa 18-12-2023 11:12:16)

Re: SVPTube No Longer Works

hello ,
on a fresh devuan install i have also problem with svptube since it does not seem to pickup the videolink correctly or parse it through<
maybe there is also a problem with the mpv installation.

problem is, the same link would play fine via mpv directly,
but not play when loaded through svptube


(plays fine in 60frames per second)

 (+) Video --vid=1 (*) (vp9 2560x1440 60.000fps)
 (+) Audio --aid=1 --alang=eng (*) (opus 2ch 48000Hz)
File tags:
 Uploader: TechLabUK
[ffmpeg] AVHWDeviceContext: Cannot load
[ffmpeg] AVHWDeviceContext: Could not dynamically load CUDA
Using hardware decoding (vaapi-copy).
AO: [pulse] 48000Hz stereo 2ch float
VO: [gpu] 2560x1440 nv12
[autoconvert] Converting nv12 -> yuv420p
VO: [gpu] 1440x808 yuv420p
Option vf-del: 0 doesn't exist.
Exiting... (Quit)


(fails to play through SVPmanager via Svptube)

12:07:14.304 [i]: Tube: video format id 302 selected
[ffmpeg] https: HTTP error 403 Forbidden
Failed to open
Exiting... (Errors when loading file)
12:07:14.613 [E]: VideoPlayer: unable to find mpv's PID

svpmanager complains there is 0 OpenCL device,
but mpv functions nontheless (AMD APU has no official drivers from AMD yet)

please see log here