Topic: python issue /linux/

hello ,

i would like to install on ubuntu20.04

the issue is with


# make Python find the Vapoursynth module
# there MUST be a better way to do this!
sudo ln -s /usr/local/lib/python3.7/site-packages/ /usr/lib/python3.7/lib-dynload/

the error is

sudo ln -s /usr/local/lib/python3.7/site-packages/ /usr/lib/python3.7/lib-dynload/
ln: failed to create symbolic link '/usr/lib/python3.7/lib-dynload/': No such file or directory

python3.8 is installed.

Re: python issue /linux/

adapting to

sudo ln -s /usr/local/lib/python3.8/site-packages/ /usr/lib/python3.8/lib-dynload/

seems to have fixed it.

Re: python issue /linux/

the next issue is that build would fail

make: Leaving directory '/home/rich/Programme/mpv-build/ffmpeg_build'
Using mpv options: --enable-vapoursynth --enable-libmpv-shared
/usr/bin/env: 'python': No such file or directory


is not available in ubuntu20.04 , instead there is

python2-minimal, pyhton2.7-minimal

Re: python issue /linux/

sudo apt-get install python-minimal
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-minimal is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  python2-minimal:i386 python2-minimal

E: Package 'python-minimal' has no installation candidate

Re: python issue /linux/

lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu Focal Fossa (development branch)
Release:    20.04
Codename:    focal

6 (edited by kapqa 30-03-2020 22:41:24)

Re: python issue /linux/

on possible solution was given here … -directory

cd /usr/bin
sudo mv python python.bak
sudo ln -s /usr/bin/python2.7 /usr/bin/python

this helped me to install the mpv with vaporsynth and svp4linux accordingly.

however, for some reason, svptube won't start.

Re: python issue /linux/

updating svp4linux to latest version .183
solved also the issue with svptube 2.

now it picks up the links as desired.