Topic: .ass subtitle problems with SVP+PotPlayer

When I'm using PotPlayer with SVP to watch my anime, I have two problem that occur with .ass subtitle tracks. This doesn't happen with MPC-HC neither VLC. I've tried without SVP and the problems doesn't happen.
- The first problem is when a certain line has the fade effect (fad(x,y) on the subtitle), the phrase become almost invisible a couple of seconds before it should, it's really hard to read it.
- The second problem is in the karaoke lines, the progress effect (don't know if it's the correct name) is to fast and it reaches the end of the phrase before it should.
I have Windows 10 Pro 1803 64 bits, SVP 4.2.0.136 Free and PotPlayer 1.7.13622 64 bits.
Does anyone has the same problems? Could it be a bug of SVP with PotPlayer? Or could it be a problem on my end?

Re: .ass subtitle problems with SVP+PotPlayer

Do you have short video sample + .ass?
We need it to reproduce and to fix the problem.

3 (edited by webtax 15-08-2018 22:56:01)

Re: .ass subtitle problems with SVP+PotPlayer

i've had the fade effect problem happen a few times as well, i'm 3.16 tough, but this is what i noticed if it helps:

see the problem on the sub first disabled, then svp enabled https://files.catbox.moe/obeecb.mp4 
ass https://files.catbox.moe/494w35.ass
video https://files.catbox.moe/sgwtdy.mkv (starts moving at 8s, sub at about 12s)

another example, see the white rectange on top right, first is with SVP disabled https://files.catbox.moe/vqjbcn.mp4

what i've also noticed is that it only happens if using "Display on Overlay/.." on in subtitle settings https://i.imgur.com/emimzYB.jpg
but it works fine on "Display on video (tv-out)"

Re: .ass subtitle problems with SVP+PotPlayer

Sorry for the late answer, I was on vacations in a place with no internet.
I tried to record a video sample but my laptop is not very good, the recording was very bad because the CPU is always near 95% when using SVP. But the problem is shown too on webtax's mp4's videos.
As for .ass subtitle, I have the same problem with the webtax's subtitle, so you can use his files to try.
I also tried playing with "Display on video (tv-out)" instead of "Display on Overlay/.." and it's like webtax said, the problems doesn't happen but the quality gets worse.

Re: .ass subtitle problems with SVP+PotPlayer

webtax
I see the result but I cant to reproduce because of the video look like is corrupted.
Your video MKV is not played to me (black screen). Can you give a link to source file?

OfficialBispo
Maybe you can give a link to source video too?

BTW can I use 494w35.ass with any another video to reproduce the issue?

Re: .ass subtitle problems with SVP+PotPlayer

With another video your ASS file working well: fadein and fadeout are visible.
Look to attached video. See subtitle "Gimnasio Nakajima" at the bottom of the viedo.
My MPC-HC settings attached below.

Post's attachments

EVR_D3DFullscreen2.png 48.29 kb, 104 downloads since 2018-08-27 

video_with_ass.flv 1.4 mb, 586 downloads since 2018-08-27 

Re: .ass subtitle problems with SVP+PotPlayer

Yes, I can reproduce the issue with any other video. If you want the source file, I saw with Aegisub that the source video name is "[ron] Vivid Strike! - 04 (720p BD x264 AAC) [58F9BF59]", you can find it on nyaa.
I can play the mkv webtax posted with PotPlayer but not with MPC-HC.
It seems to me that you are trying to reproduce the issue with MPC-HC instead of PotPlayer. With MPC-HC I don't have problems, only with PotPlayer. But I prefer using PotPlayer because I stream a lot of anime through MEGA and torrent, and I use Taiga to identify, add and sync with AniList. It can identify correctly the anime with PotPlayer but can't with MPC-HC.

Re: .ass subtitle problems with SVP+PotPlayer

> PotPlayer 1.7.13622 64 bits

I've just dowloaded it. Without SVP subtitles fading works well.
PotPlayer and SVP via ffdShow: subtitles fading works well.

PotPlayer and SVP via Vapoursynth native = can't setup it for now. Need more time to get what is wrong
PotPlayer and SVP via Avisynth native = can't setup it for now. Need more time to get what is wrong

Re: .ass subtitle problems with SVP+PotPlayer

One of the things I thought was the issue could be happening because was too overloaded by the frame rate conversion and could be affecting the subtitles, but I tried with a 144p video and the issue remains.
In last case, I can unninstall and reinstall SVP and PotPlayer.
For me in this moment it's not urgent because thanks to webtax I know that I can change to "Display on video (tv-out)" on karaoke.

10 (edited by webtax 30-08-2018 23:46:25)

Re: .ass subtitle problems with SVP+PotPlayer

yeah looks like which video doesn't matter,
another thing, it happens if using Potplayer+Madvr 0.92.14+SVP https://i.imgur.com/AxGbqzo.jpg
but with EVR Custom presenter renderer+SVP it plays fine https://i.imgur.com/293mcrn.jpg
Madvr+ SVP disabled https://i.imgur.com/EaRlzWq.jpg

Re: .ass subtitle problems with SVP+PotPlayer

I end up reinstalling SVP and PotPlayer, and I bought the pro version. Now I don't have issues, the subtitles play fine. Maybe the problem was on my player.
Thank you for your help.

12 (edited by OfficialBispo 01-09-2018 00:27:42)

Re: .ass subtitle problems with SVP+PotPlayer

I finally discovered what was causing this issue!
So I reinstalled everything from zero, with no settings saved. Then I configured the player to work with SVP and changed the settings to my needs. I played some animes and it was ok.
But the last thing that I installed was a skin that I really love, https://www.deviantart.com/flydonkey/ar … -444035536. To have the transparent effect that you can see in the image, it's needed to "Choose the 'Direct3D 9' in 'On Screen Control'". But the player had another option, Direct3D 11, that I thought was better than 9 so I choosed 11. After all Direct3D 11 was causing all the issues because with 9 it was ok.
webtax, can you check if you're using Direct3D 11 on your theme?

Edit: Can anyone say why Direct3D 11 affect .ass subtitles, while 9 don't?

Re: .ass subtitle problems with SVP+PotPlayer

> Can anyone say why Direct3D 11 affect .ass subtitles, while 9 don't?

https://potplayer.daum.net/forum/ big_smile

Re: .ass subtitle problems with SVP+PotPlayer

Oh yes you're right, I should ask on their forum.