1 (edited by Tsubajashi 24-07-2017 17:51:22)

Topic: MPV uses a lot of CPU somehow.

MPV uses way more CPU usage than MPC-HC, but i want to switch to it due to the stop of development of MPC-HC.
My Config will be attached, i would love to get some test configs i could try.
Also, the SVP Index seems to be unstable. sometimes its 0.97, sometimes its 1,22. in MPC-HC, i have a constant 0.99-1,01.
My PC:
Fx 8350 @ 4,1GHZ (8-core)
16gb DDR3-1600 RAM
R9 380 4G
Win10-Creators Update x64

Post's attachments

mpv.conf 511 b, 640 downloads since 2017-07-24 

Re: MPV uses a lot of CPU somehow.

vaapi? it's for Linux only

basically you now have hw decoder turned off

Re: MPV uses a lot of CPU somehow.

Was just a test. tested a few more

Re: MPV uses a lot of CPU somehow.

Check mine

input-ipc-server=mpvpipe
vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither
hwdec=d3d11va-copy
slang=enUS,en,eng,ptBR,pt
alang=jp,jpn,enUS,en,eng,ptBR,pt
save-position-on-quit=yes
script-opts=autospeed-nircmd=true,autospeed-speed=false,autospeed-nircmdc="C:\Users\vadas\AppData\Roaming\mpv\nircmdc.exe1",autospeed-rates="50,60,71,72",autospeed-osd=true
log-file="C:\tmp\mpv.log"
video-sync=display-resample
video-sync-max-video-change=10
hr-seek-framedrop=no

Re: MPV uses a lot of CPU somehow.

dlr5668 wrote:

Check mine

input-ipc-server=mpvpipe
vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither
hwdec=d3d11va-copy
slang=enUS,en,eng,ptBR,pt
alang=jp,jpn,enUS,en,eng,ptBR,pt
save-position-on-quit=yes
script-opts=autospeed-nircmd=true,autospeed-speed=false,autospeed-nircmdc="C:\Users\vadas\AppData\Roaming\mpv\nircmdc.exe1",autospeed-rates="50,60,71,72",autospeed-osd=true
log-file="C:\tmp\mpv.log"
video-sync=display-resample
video-sync-max-video-change=10
hr-seek-framedrop=no

These are working ALOT better i must say. still, the SVP index now permanently stays at 1.10-1.15 somehow.
http://imgur.com/a/La0BQ

Re: MPV uses a lot of CPU somehow.

dlr5668 wrote:

Check mine

input-ipc-server=mpvpipe
vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither
hwdec=d3d11va-copy
slang=enUS,en,eng,ptBR,pt
alang=jp,jpn,enUS,en,eng,ptBR,pt
save-position-on-quit=yes
script-opts=autospeed-nircmd=true,autospeed-speed=false,autospeed-nircmdc="C:\Users\vadas\AppData\Roaming\mpv\nircmdc.exe1",autospeed-rates="50,60,71,72",autospeed-osd=true
log-file="C:\tmp\mpv.log"
video-sync=display-resample
video-sync-max-video-change=10
hr-seek-framedrop=no

This will run smooth because the entire vo= line will be ignored, as for almost a year now the vo= settings are not separated by colons anymore.

Basically: vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither
none of these are actually on.

Re: MPV uses a lot of CPU somehow.

dejavecue wrote:
dlr5668 wrote:

Check mine

input-ipc-server=mpvpipe
vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither
hwdec=d3d11va-copy
slang=enUS,en,eng,ptBR,pt
alang=jp,jpn,enUS,en,eng,ptBR,pt
save-position-on-quit=yes
script-opts=autospeed-nircmd=true,autospeed-speed=false,autospeed-nircmdc="C:\Users\vadas\AppData\Roaming\mpv\nircmdc.exe1",autospeed-rates="50,60,71,72",autospeed-osd=true
log-file="C:\tmp\mpv.log"
video-sync=display-resample
video-sync-max-video-change=10
hr-seek-framedrop=no

This will run smooth because the entire vo= line will be ignored, as for almost a year now the vo= settings are not separated by colons anymore.

Basically: vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither
none of these are actually on.

So that line only says that it will run in opengl? FWIW these are my settings. Did I mess up? https://pastebin.com/gRQbTVLr

Re: MPV uses a lot of CPU somehow.

adamkex wrote:
dejavecue wrote:
dlr5668 wrote:

Check mine

input-ipc-server=mpvpipe
vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither
hwdec=d3d11va-copy
slang=enUS,en,eng,ptBR,pt
alang=jp,jpn,enUS,en,eng,ptBR,pt
save-position-on-quit=yes
script-opts=autospeed-nircmd=true,autospeed-speed=false,autospeed-nircmdc="C:\Users\vadas\AppData\Roaming\mpv\nircmdc.exe1",autospeed-rates="50,60,71,72",autospeed-osd=true
log-file="C:\tmp\mpv.log"
video-sync=display-resample
video-sync-max-video-change=10
hr-seek-framedrop=no

This will run smooth because the entire vo= line will be ignored, as for almost a year now the vo= settings are not separated by colons anymore.

Basically: vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither
none of these are actually on.

So that line only says that it will run in opengl? FWIW these are my settings. Did I mess up? https://pastebin.com/gRQbTVLr

Your config seems fine.

The other one with this line : vo=opengl-hq:backend=dxinterop:scale=ewa_lanczossharp:cscale=ewa_lanczossoft:interpolation:tscale=mitchell:tscale-clamp:temporal-dither

does not work.

The way it would work goes like this:

vo=opengl-hq
backend=dxinterop
scale=ewa_lanczossharp
cscale=ewa_lanczossoft
interpolation
tscale=mitchell
tscale-clamp
temporal-dither

Re: MPV uses a lot of CPU somehow.

Ty, I was using really old mpv

input-ipc-server=mpvpipe
profile=opengl-hq
vo=opengl-hq
backend=dxinterop
opengl-backend=dxinterop
scale=ewa_lanczossharp
cscale=ewa_lanczos
interpolation
tscale=mitchell
tscale-clamp
video-sync=display-resample
video-sync-max-video-change=10
hwdec=d3d11va-copy
slang=enUS,en,eng,ptBR,pt
alang=jp,jpn,enUS,en,eng,ptBR,pt
save-position-on-quit=yes
script-opts=autospeed-nircmd=true,autospeed-speed=false,autospeed-nircmdc="C:\Users\vadas\AppData\Roaming\mpv\nircmdc.exe1",autospeed-rates="50,60,71,72",autospeed-osd=true
log-file="C:\tmp\mpv.log"
video-sync=display-resample
video-sync-max-video-change=10
hr-seek-framedrop=no

[extension.hs]
fps=23.976
no-correct-pts
sub-delay=0.166

Not sure about --vo and --profile so I duplicated it

Re: MPV uses a lot of CPU somehow.

This looks solid. Did this fix your problem?