101 (edited by Nintendo Maniac 64 10-02-2017 08:06:26)

Re: SVP 4 Linux

Chainik wrote:

if it's supported in the latest youtube-dl then yes

Well it didn't seem to work...SVPtube2 didn't even bring up the little window showing that it identified a Twitch.tv video from your clipboard (YouTube worked perfectly fine though).


Chainik wrote:

it sounds like you just don't have vapoursynth libraries installed

I thought I did, but I'll check again.  I mean, I thought I had Qt and stuff installed as well but manually downloading and installing the newest versions and then re-installing SVP made that stuff work, so who knows?


Chainik wrote:

nope

Well, as shown in my previous screenshot, there's no close button in the title bar.  I mean, I can close it via SVP Menu -> Exit and by right-clicking on the taskbar -> Close, but if there's supposed to be a close button then something clearly ain't right.

Direct link to the aforementioned screenshot for your convenience (notice how there is a close button on the terminal window):
http://www.svp-team.com/forum/misc.php? … mp;preview

Re: SVP 4 Linux

> Well it didn't seem to work

apt-get install youtube-dl
youtube-dl -v <url>

> I thought I did, but I'll check again

SVP 4# ldd plugins/libvapoursynth_plugin.so.22

103 (edited by Nintendo Maniac 64 11-02-2017 05:40:45)

Re: SVP 4 Linux

Chainik wrote:
apt-get install youtube-dl
youtube-dl -v <url>

No it doesn't work, but from what I can tell, it's supposed to work:
https://github.com/rg3/youtube-dl/relea … 17.02.04.1

However, it may require the user to do something first:
https://github.com/rg3/youtube-dl/issues/10654
https://github.com/rg3/youtube-dl/blob/ … figuration

Chainik wrote:
SVP 4# ldd plugins/libvapoursynth_plugin.so.22

Well, it's there.

I tried the "install newest versions and re-install SVP", but nothing changed; I even installed python 3.6 in the process.

Post's attachments

screenshot.png, 68.93 kb, 808 x 347
screenshot.png 68.93 kb, 670 downloads since 2017-02-10 

Re: SVP 4 Linux

when I talk about some console command I mean you need to examine it's output wink

"youtube-dl -v " will give a verbose log
"ldd" will show missing dependencies

105 (edited by Nintendo Maniac 64 11-02-2017 10:06:32)

Re: SVP 4 Linux

Chainik wrote:

when I talk about some console command I mean you need to examine it's output wink

"youtube-dl -v " will give a verbose log

It wasn't clear that you wanted me to copy and paste the (failed) result; I will be sure to do that next time I'm on that PC.


Chainik wrote:

"ldd" will show missing dependencies

Could you "explain like I'm 5 [years old]"?  Notice how I'm using Linux Mint rather than Arch - I'm not savvy at all with the terminal.

Re: SVP 4 Linux

> I'm not savvy at all with the terminal.
> Could you "explain like I'm 5 [years old]"?

well, I don't think so big_smile

btw, there is an example of missing dependency

107 (edited by Nintendo Maniac 64 12-02-2017 01:16:00)

Re: SVP 4 Linux

Chainik wrote:

when I talk about some console command I mean you need to examine it's output wink

"youtube-dl -v " will give a verbose log


Here you go, does this help?

berr@Toshiba-terminal ~ $ youtube-dl -v https://www.twitch.tv/videos/94956965
[debug] System config: []
[debug] User config: []
[debug] Command-line args: [u'-v', u'https://www.twitch.tv/videos/94956965']
[debug] Encodings: locale UTF-8, fs UTF-8, out UTF-8, pref UTF-8
[debug] youtube-dl version 2016.02.22
[debug] Python version 2.7.12 - Linux-4.4.0-53-generic-x86_64-with-LinuxMint-18.1-serena
[debug] exe versions: none
[debug] Proxy map: {}
[generic] 94956965: Requesting header
WARNING: Falling back on generic information extractor.
[generic] 94956965: Downloading webpage
[generic] 94956965: Extracting information
ERROR: Unsupported URL: https://www.twitch.tv/videos/94956965
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/youtube_dl/extractor/generic.py", line 1308, in _real_extract
    doc = compat_etree_fromstring(webpage.encode('utf-8'))
  File "/usr/lib/python2.7/dist-packages/youtube_dl/compat.py", line 248, in compat_etree_fromstring
    doc = _XML(text, parser=etree.XMLParser(target=etree.TreeBuilder(element_factory=_element_factory)))
  File "/usr/lib/python2.7/dist-packages/youtube_dl/compat.py", line 237, in _XML
    parser.feed(text)
  File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 1653, in feed
    self._raiseerror(v)
  File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 1517, in _raiseerror
    raise err
ParseError: mismatched tag: line 176, column 2
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/youtube_dl/YoutubeDL.py", line 666, in extract_info
    ie_result = ie.extract(url)
  File "/usr/lib/python2.7/dist-packages/youtube_dl/extractor/common.py", line 316, in extract
    return self._real_extract(url)
  File "/usr/lib/python2.7/dist-packages/youtube_dl/extractor/generic.py", line 1950, in _real_extract
    raise UnsupportedError(url)
UnsupportedError: Unsupported URL: https://www.twitch.tv/videos/94956965

berr@Toshiba-terminal ~ $ 

--------------------------------------------------------------------------------------------------------------------------------


Chainik wrote:

there is an example of missing dependency


Here's the list for SVPManager:

berr@Toshiba-terminal ~ $ ldd ~/"SVP 4"/SVPManager
    linux-vdso.so.1 =>  (0x00007fff6d716000)
    libmediainfo.so.0 => /usr/lib/x86_64-linux-gnu/libmediainfo.so.0 (0x00007f77d9264000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f77d8f2a000)
    libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f77d889c000)
    libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f77d8354000)
    libQt5Qml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5 (0x00007f77d7f28000)
    libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007f77d7dcd000)
    libQt5Concurrent.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Concurrent.so.5 (0x00007f77d7dc6000)
    libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f77d78f0000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f77d76d2000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f77d7350000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f77d7047000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f77d6e30000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f77d6a67000)
    libzen.so.0 => /usr/lib/x86_64-linux-gnu/libzen.so.0 (0x00007f77d6824000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f77d6609000)
    libcurl-gnutls.so.4 => /usr/lib/x86_64-linux-gnu/libcurl-gnutls.so.4 (0x00007f77d639c000)
    libmms.so.0 => /usr/lib/x86_64-linux-gnu/libmms.so.0 (0x00007f77d618c000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f77d5f69000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f77d5d65000)
    libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f77d5b12000)
    libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f77d5800000)
    libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f77d55db000)
    libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f77d537d000)
    libGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 (0x00007f77d510b000)
    libdouble-conversion.so.1 => /usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1 (0x00007f77d4efa000)
    libproxy.so.1 => /usr/lib/x86_64-linux-gnu/libproxy.so.1 (0x00007f77d4cd8000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f77d4ad0000)
    libicui18n.so.55 => /usr/lib/x86_64-linux-gnu/libicui18n.so.55 (0x00007f77d466e000)
    libicuuc.so.55 => /usr/lib/x86_64-linux-gnu/libicuuc.so.55 (0x00007f77d42da000)
    libpcre16.so.3 => /usr/lib/x86_64-linux-gnu/libpcre16.so.3 (0x00007f77d4073000)
    /lib64/ld-linux-x86-64.so.2 (0x000055d945ef1000)
    libidn.so.11 => /usr/lib/x86_64-linux-gnu/libidn.so.11 (0x00007f77d3e40000)
    librtmp.so.1 => /usr/lib/x86_64-linux-gnu/librtmp.so.1 (0x00007f77d3c23000)
    libnettle.so.6 => /usr/lib/x86_64-linux-gnu/libnettle.so.6 (0x00007f77d39ed000)
    libgnutls.so.30 => /usr/lib/x86_64-linux-gnu/libgnutls.so.30 (0x00007f77d36bd000)
    libgssapi_krb5.so.2 => /usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2 (0x00007f77d3472000)
    liblber-2.4.so.2 => /usr/lib/x86_64-linux-gnu/liblber-2.4.so.2 (0x00007f77d3263000)
    libldap_r-2.4.so.2 => /usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2 (0x00007f77d3012000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f77d2e0d000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f77d2c07000)
    libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f77d29ff000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f77d278e000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f77d24e4000)
    libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f77d22bf000)
    libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f77d2095000)
    libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007f77d1e92000)
    libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007f77d1c8f000)
    libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007f77d1a87000)
    libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007f77d1884000)
    libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007f77d1656000)
    libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f77d1443000)
    libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f77d1240000)
    libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f77d103a000)
    libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007f77d0e37000)
    libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007f77d0c1e000)
    libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007f77d0a19000)
    libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007f77d0812000)
    libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007f77d0603000)
    libicudata.so.55 => /usr/lib/x86_64-linux-gnu/libicudata.so.55 (0x00007f77ceb4b000)
    libhogweed.so.4 => /usr/lib/x86_64-linux-gnu/libhogweed.so.4 (0x00007f77ce918000)
    libgmp.so.10 => /usr/lib/x86_64-linux-gnu/libgmp.so.10 (0x00007f77ce698000)
    libp11-kit.so.0 => /usr/lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007f77ce433000)
    libtasn1.so.6 => /usr/lib/x86_64-linux-gnu/libtasn1.so.6 (0x00007f77ce220000)
    libkrb5.so.3 => /usr/lib/x86_64-linux-gnu/libkrb5.so.3 (0x00007f77cdf4d000)
    libk5crypto.so.3 => /usr/lib/x86_64-linux-gnu/libk5crypto.so.3 (0x00007f77cdd1e000)
    libcom_err.so.2 => /lib/x86_64-linux-gnu/libcom_err.so.2 (0x00007f77cdb1a000)
    libkrb5support.so.0 => /usr/lib/x86_64-linux-gnu/libkrb5support.so.0 (0x00007f77cd90f000)
    libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f77cd6f3000)
    libsasl2.so.2 => /usr/lib/x86_64-linux-gnu/libsasl2.so.2 (0x00007f77cd4d8000)
    libgssapi.so.3 => /usr/lib/x86_64-linux-gnu/libgssapi.so.3 (0x00007f77cd297000)
    libkeyutils.so.1 => /lib/x86_64-linux-gnu/libkeyutils.so.1 (0x00007f77cd092000)
    libheimntlm.so.0 => /usr/lib/x86_64-linux-gnu/libheimntlm.so.0 (0x00007f77cce88000)
    libkrb5.so.26 => /usr/lib/x86_64-linux-gnu/libkrb5.so.26 (0x00007f77ccbfe000)
    libasn1.so.8 => /usr/lib/x86_64-linux-gnu/libasn1.so.8 (0x00007f77cc95c000)
    libhcrypto.so.4 => /usr/lib/x86_64-linux-gnu/libhcrypto.so.4 (0x00007f77cc729000)
    libroken.so.18 => /usr/lib/x86_64-linux-gnu/libroken.so.18 (0x00007f77cc512000)
    libwind.so.0 => /usr/lib/x86_64-linux-gnu/libwind.so.0 (0x00007f77cc2e9000)
    libheimbase.so.1 => /usr/lib/x86_64-linux-gnu/libheimbase.so.1 (0x00007f77cc0da000)
    libhx509.so.5 => /usr/lib/x86_64-linux-gnu/libhx509.so.5 (0x00007f77cbe8e000)
    libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f77cbbb9000)
    libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007f77cb981000)
berr@Toshiba-terminal ~ $ 

And the list for mpv (compiled with VapourSynth):

berr@Toshiba-terminal ~ $ ldd /usr/bin/mpv
    linux-vdso.so.1 =>  (0x00007ffe85679000)
    libdvdread.so.4 => /usr/lib/x86_64-linux-gnu/libdvdread.so.4 (0x00007f465806c000)
    libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f4657e13000)
    libXv.so.1 => /usr/lib/x86_64-linux-gnu/libXv.so.1 (0x00007f4657c0d000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f46578d3000)
    libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f46576c1000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f46574bc000)
    libvdpau.so.1 => /usr/lib/x86_64-linux-gnu/libvdpau.so.1 (0x00007f46572b8000)
    libva.so.1 => /usr/lib/x86_64-linux-gnu/libva.so.1 (0x00007f465709c000)
    libva-x11.so.1 => /usr/lib/x86_64-linux-gnu/libva-x11.so.1 (0x00007f4656e95000)
    libjack.so.0 => /usr/lib/x86_64-linux-gnu/libjack.so.0 (0x00007f4656c4c000)
    libasound.so.2 => /usr/lib/x86_64-linux-gnu/libasound.so.2 (0x00007f465694c000)
    libSDL2-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 (0x00007f4656638000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f465641b000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f4656201000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4655ef7000)
    libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007f4655ca7000)
    libass.so.5 => /usr/lib/x86_64-linux-gnu/libass.so.5 (0x00007f4655a77000)
    libgnutls.so.30 => /usr/lib/x86_64-linux-gnu/libgnutls.so.30 (0x00007f4655746000)
    libxvidcore.so.4 => /usr/lib/x86_64-linux-gnu/libxvidcore.so.4 (0x00007f4655432000)
    libx264.so.148 => /usr/lib/x86_64-linux-gnu/libx264.so.148 (0x00007f465508e000)
    libwavpack.so.1 => /usr/lib/x86_64-linux-gnu/libwavpack.so.1 (0x00007f4654e64000)
    libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007f4654bbb000)
    libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007f465498f000)
    libtheoraenc.so.1 => /usr/lib/x86_64-linux-gnu/libtheoraenc.so.1 (0x00007f465474f000)
    libtheoradec.so.1 => /usr/lib/x86_64-linux-gnu/libtheoradec.so.1 (0x00007f4654535000)
    libspeex.so.1 => /usr/lib/x86_64-linux-gnu/libspeex.so.1 (0x00007f465431c000)
    libschroedinger-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libschroedinger-1.0.so.0 (0x00007f4654046000)
    libopus.so.0 => /usr/lib/x86_64-linux-gnu/libopus.so.0 (0x00007f4653dfc000)
    libopencore-amrwb.so.0 => /usr/lib/x86_64-linux-gnu/libopencore-amrwb.so.0 (0x00007f4653be8000)
    libopencore-amrnb.so.0 => /usr/lib/x86_64-linux-gnu/libopencore-amrnb.so.0 (0x00007f46539bc000)
    libmp3lame.so.0 => /usr/lib/x86_64-linux-gnu/libmp3lame.so.0 (0x00007f4653747000)
    libgsm.so.1 => /usr/lib/x86_64-linux-gnu/libgsm.so.1 (0x00007f4653539000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f4653330000)
    libwayland-client.so.0 => /usr/lib/x86_64-linux-gnu/libwayland-client.so.0 (0x00007f4653122000)
    libwayland-cursor.so.0 => /usr/lib/x86_64-linux-gnu/libwayland-cursor.so.0 (0x00007f4652f1a000)
    libxkbcommon.so.0 => /usr/lib/x86_64-linux-gnu/libxkbcommon.so.0 (0x00007f4652cda000)
    libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007f4652ad7000)
    libbluray.so.1 => /usr/lib/x86_64-linux-gnu/libbluray.so.1 (0x00007f465288e000)
    libXss.so.1 => /usr/lib/x86_64-linux-gnu/libXss.so.1 (0x00007f4652689000)
    libva-drm.so.1 => /usr/lib/x86_64-linux-gnu/libva-drm.so.1 (0x00007f4652486000)
    libnetcdf.so.11 => /usr/lib/x86_64-linux-gnu/libnetcdf.so.11 (0x00007f464f123000)
    libcdio_paranoia.so.1 => /usr/lib/x86_64-linux-gnu/libcdio_paranoia.so.1 (0x00007f464ef1a000)
    libcdio_cdda.so.1 => /usr/lib/x86_64-linux-gnu/libcdio_cdda.so.1 (0x00007f464ed12000)
    libcdio.so.13 => /usr/lib/x86_64-linux-gnu/libcdio.so.13 (0x00007f464eaed000)
    liblua5.2.so.0 => /usr/lib/x86_64-linux-gnu/liblua5.2.so.0 (0x00007f464e8ba000)
    libvapoursynth-script.so.0 => /usr/lib/x86_64-linux-gnu/libvapoursynth-script.so.0 (0x00007f464e6b6000)
    libvapoursynth.so => /usr/lib/x86_64-linux-gnu/libvapoursynth.so (0x00007f464e3c9000)
    libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007f464e1b9000)
    libGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 (0x00007f464df48000)
    liblcms2.so.2 => /usr/lib/x86_64-linux-gnu/liblcms2.so.2 (0x00007f464dcf1000)
    libsmbclient.so.0 => /usr/lib/x86_64-linux-gnu/libsmbclient.so.0 (0x00007f464dacb000)
    libwayland-egl.so.1 => /usr/lib/x86_64-linux-gnu/libwayland-egl.so.1 (0x00007f464d8c9000)
    libEGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1 (0x00007f464d697000)
    libdvdnav.so.4 => /usr/lib/x86_64-linux-gnu/libdvdnav.so.4 (0x00007f464d481000)
    libva-wayland.so.1 => /usr/lib/x86_64-linux-gnu/libva-wayland.so.1 (0x00007f464d27d000)
    librubberband.so.2 => /usr/lib/x86_64-linux-gnu/librubberband.so.2 (0x00007f464d046000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f464ce23000)
    libxcb-xfixes.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-xfixes.so.0 (0x00007f464cc1b000)
    libxcb-shape.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shape.so.0 (0x00007f464ca17000)
    libsndio.so.6.1 => /usr/lib/x86_64-linux-gnu/libsndio.so.6.1 (0x00007f464c806000)
    libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007f464c5fb000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f464c232000)
    /lib64/ld-linux-x86-64.so.2 (0x0000558485a68000)
    libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f464c02b000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f464bca9000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f464ba92000)
    libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f464b888000)
    libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007f464b678000)
    libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007f464b471000)
    libjson-c.so.2 => /lib/x86_64-linux-gnu/libjson-c.so.2 (0x00007f464b266000)
    libpulsecommon-8.0.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-8.0.so (0x00007f464afea000)
    libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f464ad9e000)
    libfribidi.so.0 => /usr/lib/x86_64-linux-gnu/libfribidi.so.0 (0x00007f464ab87000)
    libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f464a943000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f464a699000)
    libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f464a43b000)
    libp11-kit.so.0 => /usr/lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007f464a1d6000)
    libidn.so.11 => /usr/lib/x86_64-linux-gnu/libidn.so.11 (0x00007f4649fa3000)
    libtasn1.so.6 => /usr/lib/x86_64-linux-gnu/libtasn1.so.6 (0x00007f4649d90000)
    libnettle.so.6 => /usr/lib/x86_64-linux-gnu/libnettle.so.6 (0x00007f4649b59000)
    libhogweed.so.4 => /usr/lib/x86_64-linux-gnu/libhogweed.so.4 (0x00007f4649926000)
    libgmp.so.10 => /usr/lib/x86_64-linux-gnu/libgmp.so.10 (0x00007f46496a6000)
    libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007f464949c000)
    liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007f464921c000)
    libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f4649013000)
    libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f4648c59000)
    libhdf5_serial_hl.so.10 => /usr/lib/x86_64-linux-gnu/libhdf5_serial_hl.so.10 (0x00007f4648a38000)
    libhdf5_serial.so.10 => /usr/lib/x86_64-linux-gnu/libhdf5_serial.so.10 (0x00007f464859b000)
    libcurl-gnutls.so.4 => /usr/lib/x86_64-linux-gnu/libcurl-gnutls.so.4 (0x00007f464832e000)
    libpython3.5m.so.1.0 => /usr/lib/x86_64-linux-gnu/libpython3.5m.so.1.0 (0x00007f4647ca6000)
    libzimg.so.2 => /usr/lib/x86_64-linux-gnu/libzimg.so.2 (0x00007f4647a3c000)
    libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f4647812000)
    libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007f464760f000)
    libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007f464740c000)
    libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007f4647204000)
    libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007f4647001000)
    libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007f4646dd3000)
    libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f4646bcf000)
    libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007f46469cd000)
    libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007f46467b4000)
    libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007f46465ae000)
    libsamba-util.so.0 => /usr/lib/x86_64-linux-gnu/libsamba-util.so.0 (0x00007f4646346000)
    libtalloc-report.so.0 => /usr/lib/x86_64-linux-gnu/samba/libtalloc-report.so.0 (0x00007f4646142000)
    libtevent-util.so.0 => /usr/lib/x86_64-linux-gnu/libtevent-util.so.0 (0x00007f4645f3f000)
    liblibsmb.so.0 => /usr/lib/x86_64-linux-gnu/samba/liblibsmb.so.0 (0x00007f4645cda000)
    libmsrpc3.so.0 => /usr/lib/x86_64-linux-gnu/samba/libmsrpc3.so.0 (0x00007f4645ab9000)
    liblibcli-lsa3.so.0 => /usr/lib/x86_64-linux-gnu/samba/liblibcli-lsa3.so.0 (0x00007f46458b5000)
    libsamba-security.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsamba-security.so.0 (0x00007f4645698000)
    liberrors.so.0 => /usr/lib/x86_64-linux-gnu/samba/liberrors.so.0 (0x00007f4645354000)
    libsmbconf.so.0 => /usr/lib/x86_64-linux-gnu/libsmbconf.so.0 (0x00007f46450f1000)
    libsamba3-util.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsamba3-util.so.0 (0x00007f4644ee8000)
    libndr.so.0 => /usr/lib/x86_64-linux-gnu/libndr.so.0 (0x00007f4644cd2000)
    libsamba-debug.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsamba-debug.so.0 (0x00007f4644acc000)
    libcli-smb-common.so.0 => /usr/lib/x86_64-linux-gnu/samba/libcli-smb-common.so.0 (0x00007f46448a2000)
    libgse.so.0 => /usr/lib/x86_64-linux-gnu/samba/libgse.so.0 (0x00007f4644679000)
    libutil-cmdline.so.0 => /usr/lib/x86_64-linux-gnu/samba/libutil-cmdline.so.0 (0x00007f4644475000)
    libndr-standard.so.0 => /usr/lib/x86_64-linux-gnu/libndr-standard.so.0 (0x00007f4643f65000)
    libdcerpc-samba.so.0 => /usr/lib/x86_64-linux-gnu/samba/libdcerpc-samba.so.0 (0x00007f4643bdc000)
    libsmbregistry.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsmbregistry.so.0 (0x00007f46439a9000)
    libsecrets3.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsecrets3.so.0 (0x00007f464379e000)
    libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f4643588000)
    libtalloc.so.2 => /usr/lib/x86_64-linux-gnu/libtalloc.so.2 (0x00007f4643374000)
    libtevent.so.0 => /usr/lib/x86_64-linux-gnu/libtevent.so.0 (0x00007f4643165000)
    libwayland-server.so.0 => /usr/lib/x86_64-linux-gnu/libwayland-server.so.0 (0x00007f4642f53000)
    libgbm.so.1 => /usr/lib/x86_64-linux-gnu/libgbm.so.1 (0x00007f4642d45000)
    libsamplerate.so.0 => /usr/lib/x86_64-linux-gnu/libsamplerate.so.0 (0x00007f46429d8000)
    libfftw3.so.3 => /usr/lib/x86_64-linux-gnu/libfftw3.so.3 (0x00007f46425da000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f46423d6000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f46421cf000)
    libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f4641fc5000)
    libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007f4641f3f000)
    libwrap.so.0 => /lib/x86_64-linux-gnu/libwrap.so.0 (0x00007f4641d35000)
    libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007f4641acc000)
    libasyncns.so.0 => /usr/lib/x86_64-linux-gnu/libasyncns.so.0 (0x00007f46418c5000)
    libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f46416a0000)
    libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f464138e000)
    libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f4641169000)
    libicuuc.so.55 => /usr/lib/x86_64-linux-gnu/libicuuc.so.55 (0x00007f4640dd4000)
    liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f4640bb2000)
    libsz.so.2 => /usr/lib/x86_64-linux-gnu/libsz.so.2 (0x00007f46409af000)
    librtmp.so.1 => /usr/lib/x86_64-linux-gnu/librtmp.so.1 (0x00007f4640792000)
    libgssapi_krb5.so.2 => /usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2 (0x00007f4640548000)
    liblber-2.4.so.2 => /usr/lib/x86_64-linux-gnu/liblber-2.4.so.2 (0x00007f4640339000)
    libldap_r-2.4.so.2 => /usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2 (0x00007f46400e7000)
    libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007f463fee4000)
    libtime-basic.so.0 => /usr/lib/x86_64-linux-gnu/samba/libtime-basic.so.0 (0x00007f463fce0000)
    libsocket-blocking.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsocket-blocking.so.0 (0x00007f463fade000)
    libgenrand.so.0 => /usr/lib/x86_64-linux-gnu/samba/libgenrand.so.0 (0x00007f463f8d1000)
    libkrb5samba.so.0 => /usr/lib/x86_64-linux-gnu/samba/libkrb5samba.so.0 (0x00007f463f6c5000)
    libcli-cldap.so.0 => /usr/lib/x86_64-linux-gnu/samba/libcli-cldap.so.0 (0x00007f463f4bd000)
    libcliauth.so.0 => /usr/lib/x86_64-linux-gnu/samba/libcliauth.so.0 (0x00007f463f2aa000)
    libsys-rw.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsys-rw.so.0 (0x00007f463f0a6000)
    libgensec.so.0 => /usr/lib/x86_64-linux-gnu/libgensec.so.0 (0x00007f463ee7e000)
    libcom_err-samba4.so.0 => /usr/lib/x86_64-linux-gnu/samba/libcom_err-samba4.so.0 (0x00007f463ec7b000)
    libasn1util.so.0 => /usr/lib/x86_64-linux-gnu/samba/libasn1util.so.0 (0x00007f463ea74000)
    libndr-nbt.so.0 => /usr/lib/x86_64-linux-gnu/libndr-nbt.so.0 (0x00007f463e85f000)
    libsamba-hostconfig.so.0 => /usr/lib/x86_64-linux-gnu/libsamba-hostconfig.so.0 (0x00007f463e636000)
    libsmb-transport.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsmb-transport.so.0 (0x00007f463e430000)
    libsamba-credentials.so.0 => /usr/lib/x86_64-linux-gnu/libsamba-credentials.so.0 (0x00007f463e21e000)
    libCHARSET3.so.0 => /usr/lib/x86_64-linux-gnu/samba/libCHARSET3.so.0 (0x00007f463e01a000)
    libndr-samba.so.0 => /usr/lib/x86_64-linux-gnu/samba/libndr-samba.so.0 (0x00007f463dcfb000)
    libdbwrap.so.0 => /usr/lib/x86_64-linux-gnu/samba/libdbwrap.so.0 (0x00007f463daf0000)
    libdcerpc-binding.so.0 => /usr/lib/x86_64-linux-gnu/libdcerpc-binding.so.0 (0x00007f463d8d2000)
    libutil-tdb.so.0 => /usr/lib/x86_64-linux-gnu/samba/libutil-tdb.so.0 (0x00007f463d6ce000)
    libsamba-sockets.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsamba-sockets.so.0 (0x00007f463d4b7000)
    libinterfaces.so.0 => /usr/lib/x86_64-linux-gnu/samba/libinterfaces.so.0 (0x00007f463d2b3000)
    libmessages-dgm.so.0 => /usr/lib/x86_64-linux-gnu/samba/libmessages-dgm.so.0 (0x00007f463d0aa000)
    libiov-buf.so.0 => /usr/lib/x86_64-linux-gnu/samba/libiov-buf.so.0 (0x00007f463cea7000)
    libserver-id-db.so.0 => /usr/lib/x86_64-linux-gnu/samba/libserver-id-db.so.0 (0x00007f463cca3000)
    libutil-reg.so.0 => /usr/lib/x86_64-linux-gnu/samba/libutil-reg.so.0 (0x00007f463caa0000)
    libmessages-util.so.0 => /usr/lib/x86_64-linux-gnu/samba/libmessages-util.so.0 (0x00007f463c89d000)
    libsmbd-shim.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsmbd-shim.so.0 (0x00007f463c69a000)
    libtdb-wrap.so.0 => /usr/lib/x86_64-linux-gnu/samba/libtdb-wrap.so.0 (0x00007f463c497000)
    libserver-role.so.0 => /usr/lib/x86_64-linux-gnu/samba/libserver-role.so.0 (0x00007f463c294000)
    libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f463c07b000)
    libtdb.so.1 => /usr/lib/x86_64-linux-gnu/libtdb.so.1 (0x00007f463be66000)
    libcap.so.2 => /lib/x86_64-linux-gnu/libcap.so.2 (0x00007f463bc5f000)
    libutil-setid.so.0 => /usr/lib/x86_64-linux-gnu/samba/libutil-setid.so.0 (0x00007f463ba5d000)
    libkrb5-samba4.so.26 => /usr/lib/x86_64-linux-gnu/samba/libkrb5-samba4.so.26 (0x00007f463b7f0000)
    libaddns.so.0 => /usr/lib/x86_64-linux-gnu/samba/libaddns.so.0 (0x00007f463b5e5000)
    libgssapi-samba4.so.2 => /usr/lib/x86_64-linux-gnu/samba/libgssapi-samba4.so.2 (0x00007f463b3b3000)
    libauthkrb5.so.0 => /usr/lib/x86_64-linux-gnu/samba/libauthkrb5.so.0 (0x00007f463b198000)
    libcli-nbt.so.0 => /usr/lib/x86_64-linux-gnu/samba/libcli-nbt.so.0 (0x00007f463af8e000)
    libmsghdr.so.0 => /usr/lib/x86_64-linux-gnu/samba/libmsghdr.so.0 (0x00007f463ad8a000)
    libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007f463ab67000)
    libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007f463a886000)
    libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007f463a611000)
    libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f463a3f5000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f463a185000)
    libicudata.so.55 => /usr/lib/x86_64-linux-gnu/libicudata.so.55 (0x00007f46386ce000)
    libaec.so.0 => /usr/lib/x86_64-linux-gnu/libaec.so.0 (0x00007f46384c5000)
    libkrb5.so.3 => /usr/lib/x86_64-linux-gnu/libkrb5.so.3 (0x00007f46381f3000)
    libk5crypto.so.3 => /usr/lib/x86_64-linux-gnu/libk5crypto.so.3 (0x00007f4637fc4000)
    libcom_err.so.2 => /lib/x86_64-linux-gnu/libcom_err.so.2 (0x00007f4637dbf000)
    libkrb5support.so.0 => /usr/lib/x86_64-linux-gnu/libkrb5support.so.0 (0x00007f4637bb4000)
    libsasl2.so.2 => /usr/lib/x86_64-linux-gnu/libsasl2.so.2 (0x00007f4637999000)
    libgssapi.so.3 => /usr/lib/x86_64-linux-gnu/libgssapi.so.3 (0x00007f4637757000)
    libasn1-samba4.so.8 => /usr/lib/x86_64-linux-gnu/samba/libasn1-samba4.so.8 (0x00007f46374dd000)
    libcli-ldap-common.so.0 => /usr/lib/x86_64-linux-gnu/samba/libcli-ldap-common.so.0 (0x00007f46372d4000)
    libwinbind-client.so.0 => /usr/lib/x86_64-linux-gnu/samba/libwinbind-client.so.0 (0x00007f46370d0000)
    libldb.so.1 => /usr/lib/x86_64-linux-gnu/libldb.so.1 (0x00007f4636ea3000)
    libwbclient.so.0 => /usr/lib/x86_64-linux-gnu/libwbclient.so.0 (0x00007f4636c94000)
    libsamba-modules.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsamba-modules.so.0 (0x00007f4636a91000)
    libsamdb.so.0 => /usr/lib/x86_64-linux-gnu/libsamdb.so.0 (0x00007f463687a000)
    libsamdb-common.so.0 => /usr/lib/x86_64-linux-gnu/samba/libsamdb-common.so.0 (0x00007f4636652000)
    libldbsamba.so.0 => /usr/lib/x86_64-linux-gnu/samba/libldbsamba.so.0 (0x00007f4636427000)
    libheimbase-samba4.so.1 => /usr/lib/x86_64-linux-gnu/samba/libheimbase-samba4.so.1 (0x00007f4636222000)
    libhx509-samba4.so.5 => /usr/lib/x86_64-linux-gnu/samba/libhx509-samba4.so.5 (0x00007f4635fdc000)
    libhcrypto-samba4.so.5 => /usr/lib/x86_64-linux-gnu/samba/libhcrypto-samba4.so.5 (0x00007f4635da9000)
    libroken-samba4.so.19 => /usr/lib/x86_64-linux-gnu/samba/libroken-samba4.so.19 (0x00007f4635b9b000)
    libwind-samba4.so.0 => /usr/lib/x86_64-linux-gnu/samba/libwind-samba4.so.0 (0x00007f4635973000)
    libndr-krb5pac.so.0 => /usr/lib/x86_64-linux-gnu/libndr-krb5pac.so.0 (0x00007f4635768000)
    libauth-sam-reply.so.0 => /usr/lib/x86_64-linux-gnu/samba/libauth-sam-reply.so.0 (0x00007f4635564000)
    libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f463534f000)
    libkeyutils.so.1 => /lib/x86_64-linux-gnu/libkeyutils.so.1 (0x00007f463514b000)
    libheimntlm.so.0 => /usr/lib/x86_64-linux-gnu/libheimntlm.so.0 (0x00007f4634f41000)
    libkrb5.so.26 => /usr/lib/x86_64-linux-gnu/libkrb5.so.26 (0x00007f4634cb7000)
    libasn1.so.8 => /usr/lib/x86_64-linux-gnu/libasn1.so.8 (0x00007f4634a15000)
    libhcrypto.so.4 => /usr/lib/x86_64-linux-gnu/libhcrypto.so.4 (0x00007f46347e1000)
    libroken.so.18 => /usr/lib/x86_64-linux-gnu/libroken.so.18 (0x00007f46345cb000)
    libflag-mapping.so.0 => /usr/lib/x86_64-linux-gnu/samba/libflag-mapping.so.0 (0x00007f46343c8000)
    libwind.so.0 => /usr/lib/x86_64-linux-gnu/libwind.so.0 (0x00007f463419f000)
    libheimbase.so.1 => /usr/lib/x86_64-linux-gnu/libheimbase.so.1 (0x00007f4633f8f000)
    libhx509.so.5 => /usr/lib/x86_64-linux-gnu/libhx509.so.5 (0x00007f4633d44000)
    libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f4633a6f000)
    libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007f4633836000)
berr@Toshiba-terminal ~ $ 

Re: SVP 4 Linux

> Here you go, does this help?

ERROR: Unsupported URL: https://www.twitch.tv/videos/94956965

109 (edited by Nintendo Maniac 64 12-02-2017 20:38:51)

Re: SVP 4 Linux

And what of SVP / mpv?

Chainik wrote:

ERROR: Unsupported URL

Well yes it says that, but from what I can tell, Twitch links are supposed to work in youtube-dl:

https://github.com/rg3/youtube-dl/releases/tag/2017.02.04.1 wrote:

[twitch:stream] Add support for player.twitch.tv (#11971)

That wouldn't be listed in the changelog if Twitch was unsupported now would it. wink

Re: SVP 4 Linux

> it seems that the mpv pre-compiled with VapourSynth doesn't even launch on Linux Mint 18

just at the bottom of https://www.svp-team.com/wiki/SVP:Linux
> apt-get install libass5


> Well yes it says that, but from what I can tell, Twitch links are supposed to work in youtube-dl

you really shouldn't argue about this with me big_smile
that type of URL is not supported, I have no idea why
other types - e.g. https://www.twitch.tv/<channel-name> - work

111 (edited by Nintendo Maniac 64 14-02-2017 01:30:07)

Re: SVP 4 Linux

Chainik wrote:

> apt-get install libass5

Yay, that worked. big_smile

However, there's still no VLC option in SVP's menu.

Also if I open a video that is associated with SVP itself, it opens the SVP control panel in addition to mpv - having a control panel window pop up in the middle of your video isn't exactly conductive to watching said video.

I will note however that SVP's performance seems a lot worse than I had in Windows, but that could just be due to mpv requiring more CPU headroom than MPC-HC + bilinear (non-P.S. 2.0) + D3D fullscreen (which is very noticeable on a 2GHz Core 2 Duo with Intel 945GMA graphics where every bit of CPU headroom counts).

Chainik wrote:

other types - e.g. https://www.twitch.tv/<channel-name> - work

But it doesn't...see attachment:

Post's attachments

twitch.png 593.25 kb, 220 downloads since 2017-02-13 

Re: SVP 4 Linux

> But it doesn't.

works for me...
anyway, do you see those letters saying "please report this issue on https://yt-dl.org/bug"? big_smile

Re: SVP 4 Linux

> there's still no VLC option in SVP's menu.

again, works for me on a fresh Mint 18.1 install
BTW there's a separate package "VLC support" in SVP's package manager

Re: SVP 4 Linux

Anyone else facing completion errors while installing SVP4 on Ubuntu 16.04?

https://www2.pic-upload.de/thumb/33116398/Screenshotfrom2017-05-0422-42-54.png

Doesn't matter if I run setup as root or not, nor if I install it into home directory or / or /opt or else...

Re: SVP 4 Linux

I think you can just press "ignore"

Re: SVP 4 Linux

I did, but I can't use the SVPManager then...

117 (edited by Nintendo Maniac 64 05-05-2017 04:25:20)

Re: SVP 4 Linux

doemEINS wrote:

Anyone else facing completion errors while installing SVP4 on Ubuntu 16.04?

https://www2.pic-upload.de/thumb/33116398/Screenshotfrom2017-05-0422-42-54.png

Doesn't matter if I run setup as root or not, nor if I install it into home directory or / or /opt or else...


I just had the exact same issue on a relatively fresh installation of Linux Mint 18.1 Cinnamon, and running the following command solved it:

sudo apt-get install libqt5concurrent5 libqt5svg5

The thing is, I already manually installed Qt 5.50 before installing SVP, so I thought I didn't have to run that command...well I was wrong.  Run that command and everything should be good.


Unfortunately, I seem to still be having the issue where there seems to be no way to have SVP running without the SVP control panel also being open - clicking the X shuts down SVP completely, and associating a video file with SVP results in it opening both mpv and the SVP control panel.  If I have mpv automatically go to fullscreen, then yes it makes the SVP control panel not visible, but once the video ends it will only automatically close mpv and therefore leave the SVP control panel sitting there being open.



I did at least figure out why I didn't have a close button on the SVP Control Panel - for some reason, some of the themes results in there being no close button even though other non-default themes do have a close button:

Post's attachments

has X.png, 27.02 kb, 728 x 296
has X.png 27.02 kb, 613 downloads since 2017-05-04 

no X.png, 26.16 kb, 729 x 293
no X.png 26.16 kb, 594 downloads since 2017-05-04 

Re: SVP 4 Linux

> there seems to be no way to have SVP running without the SVP

run it with "-tray" arg

119 (edited by doemEINS 06-05-2017 07:20:14)

Re: SVP 4 Linux

Nintendo Maniac 64 wrote:

I just had the exact same issue on a relatively fresh installation of Linux Mint 18.1 Cinnamon, and running the following command solved it:

sudo apt-get install libqt5concurrent5 libqt5svg5

The thing is, I already manually installed Qt 5.50 before installing SVP, so I thought I didn't have to run that command...well I was wrong.  Run that command and everything should be good.

I did that already during the preparations for the SVP Linux installation, as these are prerequisites (source: SVP Linux Wiki). So it's not possible to install the Qt Libs again... sad

I removed the Qt5 libs again, tried installing SVP without them, so the error occurred:

[7141] Warning: /home/dominic/SVP 4/SVPManager: error while loading shared libraries: libQt5Concurrent.so.5: cannot open shared object file: No such file or directory

Installed them again and ran the SVP setup. All that came up in the command line was:

[49] Warning: A style sheet file is specified, but it does not exist

Edit...

./svp4-linux-64.run -v

Shows some more...

[47] Warning: A style sheet file is specified, but it does not exist.
[45307] Warning: Component core depends on other components while having child components. This will not work properly.
[45310] Control script callback "TargetDirectoryPageCallback" does not exist.
[61300] Control script callback "ComponentSelectionPageCallback" does not exist.
[65853] Control script callback "DynamicCustomOptionsWdgCallback" does not exist.
[65872] Control script callback "LicenseAgreementPageCallback" does not exist.
[69628] Control script callback "ReadyForInstallationPageCallback" does not exist.
[99914] Control script callback "PerformInstallationPageCallback" does not exist.
[100213] perform core operation: Execute
[100213]     - arguments: {0}, /home/dominic/SVP 4/SVPManager, -main, -quit
[100213] /home/dominic/SVP 4/SVPManager" started, arguments: "-main -quit
[100320] Done
[100320] Operation \"Execute\" with arguments \"{0}; /home/dominic/SVP 4/SVPManager; -main; -quit\" failed: Execution failed (Unexpected exit code: 8): \"/home/dominic/SVP 4/SVPManager -main -quit\"
[100320] Created warning message box "installationErrorWithRetry": "Installer Error", "Error during installation process (core):\nExecution failed (Unexpected exit code: 8): \"/home/dominic/SVP 4/SVPManager -main -quit\""
[316186] Control script callback "FinishedPageCallback" does not exist.

Re: SVP 4 Linux

doemEINS wrote:

I did, but I can't use the SVPManager then...

what do you mean by "can't use"?
can you run SVPManager? what do you see in console?

Re: SVP 4 Linux

No, I can't run SVPManager. From the file browser, double clicking it results in: nothing happens. From the CLI

./SVPManager -v
Floating point exception (core dumped)

Re: SVP 4 Linux

try to remove/rename "ui-scale.txt" file

Re: SVP 4 Linux

Where shall that file be? Can't locate it/ doesn't exist in my SVP installation directory...

Re: SVP 4 Linux

> doesn't exist in my SVP installation directory

ah, ok

> Floating point exception (core dumped)

gdb ./SVPManager
run

?

Re: SVP 4 Linux

(gdb) run
Starting program: /home/dominic/SVP4/SVPManager 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe6753700 (LWP 2167)]

Thread 1 "SVPManager" received signal SIGFPE, Arithmetic exception.
0x00007fffe9b6ad1a in QXcbScreen::logicalDpi() const ()
   from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
(gdb)