Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

Если надо было отдельную ветку открыть, прошу модераторов отделить.

Phenom II x6 1090T. Посмотрите график:http://img12.imageshost.ru/img/2011/06/18/image_4dfc517fc13f2.png

С помощью PhenomMsrTweaker Cool'n'Quiet отключён, процессор работает на штатной частоте 3.2 ГГц. И - не справляется. Видно, что загрузка ядер не 100%. Можно ли заставить их работать на всю катушку?

Дополнительная информация

Параметры последнего обработанного файла видео:
Имя файла: Вселенная глазами телескопа Хаббл (2008) (1080).mkv
Размер кадра и частота: 1920x1080 pixels, 23.976 fps

Определившиеся параметры монитора
Размер экрана и частота обновления: 1920x1080 pixels, 60 Hz

Данные о повышении плавности видео
Коэффициент повышения плавности: 5:2
Результирующая частота видеокадров: 59.94 fps

Текущий определившийся профиль: 1920x1080@24

Параметры преобразования видео по профилю
[ExMethod=MSmoothFps_ByPixel]    Повышение плавности: Обычное
[ExAlgo=2]            SVP-шейдер: 2. Простой двунаправленный
[ExMulti=MON]            Изменение частоты кадров: До частоты экрана
[ExMiniCount=1:1]        Размер расчетных кадров: Полный размер
[ExRad=2p]            Радиус поиска: 2 пиксела
[ExSearch=4]            Тип поиска: Шестиугольниками
[ExPel=2]            Точность прогнозирования движения: До полу-пиксела
[ExRecalc=0]            Уточнение векторов: Не уточнять
[ExBlockSize=16x16]        Размер блоков: 16x16 пикселей
[ExOverlap=4]            Перекрытие блоков: 0.25 блока
[ExSadml=20]            Подавление площадных артефактов: Выше среднего
[ExSadgamma=1]            Маска площадных артефактов: Обычная
[ExBlend=false]            Построение на смене сцен: Повторять кадры
[ExDwnResize=0]            Уменьшение размера кадра: Не уменьшать
[ExConvertFps=false]        Смешивание кадров до частоты экрана:false

Параметры по меню
[svp_libflowgpu=0]        GPU-ускорение (OpenCL): false
[ExTreads=6]            Количество потоков: 6
[Borderlight=0]            Подсветка черных полей: false
[ExStretch=0]            Растяжение кадра: Не растягивать
[ExCrop=-1]            Подрезка краев: Не подрезать
[VDelay=0]            Задержка видео: 0 мсек
[ExDemo=0]            Демонстрационный режим: false
[ExTearingTest=0]        Тест дрожания: false
[StopSmoothDelayOnRewind=0]    Плавность на перемотке: Отключить и сразу включить


Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

vkams
Все в тему.

GPU-ускорение выключено. Это я одобряю. Правильно сделано, с встроенной видеокартой будет еще хуже.
Ступеньки на графике размером по 5 сек - это отъедание мощности процессора при отображении OSD-сообщения о нехватке производительности или низком SVP-индексе. Первое, что можно сделать в Вашем случае - это отключить OSD: ctrl-shift-O. Это помогает в случае, если производительности чуть-чуть недостает (пики SVP-индекса близки к 1).
Ступенчатые провалы на графике SVP-индекса пропадут.

Второе. Точность до полупиксела и перекрытие 0.25 - это весьма напряжные настройки для процессора. На видеокарте можно было бы использовать и их, но видеокарта тут встроенная, с ней будет только хуже. Так что совет: поставить либо точность до пиксела, либо перекрытие отключить, либо и то и другое. Если бы я выбирал одно из двух, то снизил бы точность, т.к. отжирает процессора она много, а повышение качества от нее меньше, чем от перекрытия.

Далее. Процессор "кушается" еще декодером и отрисовщиками. При желании можно подобрать декодер пооптимизированней, либо использующий ускорение видеокарты, а отрисовщик выбрать самый легкий - Overlay.

28 (edited by vkams 18-06-2011 19:16:11)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

MAG79, спасибо за Ваше подробное объяснение, и вообще за долговременную помощь (я ещё на другом форуме Вас расспрашивал полгода назад).

MAG79 wrote:

При желании можно подобрать декодер пооптимизированней, либо использующий ускорение видеокарты, а отрисовщик выбрать самый легкий - Overlay.

Этот у меня и стоит, декодер - ffdshow ver 3651 от 8 декабря 2010.

1. С этим фильмом всё стало в порядке, а в другом ("Властелин колец" 1080р) заметил отставание видео от звука примерно на 500 мс, хотя процессор загружен меньше чем на 60%. Почему это?

2. И ещё хочу вернуться к вопросу: если ядра нагружены неравномерно, можно ли как-то дозагрузить? Может быть, именно 15-20% простоя 1-2 ядер при 99%-й загрузке последнего оказываются вызывают дёргание и сводят на нет всю плавность.

3. Есть ли какие-то версии SVP и его компонентов, специально оптимизированные под процессоры AMD - Athlon II и Phenom II? Всё таки их производительность похуже, чем у Intel.

Успехов Вам и всего светлого!
Владимир

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

Владимир
1. Если отставание видео от звука не нарастающее, то можно в ffdShow или в плеере подогнать звук под видео и спокойно посмотреть фильм. Такие отставания изредка бывают, от SVP не зависят.
2. Были такие подозрения (и сейчас есть) у некоторых пользователей SVP, что перегруз отдельных ядер может вызывать подергивания. Я считаю, что  это не так, т.к. много экспериментировал. Подергивания больше зависят от драйвера видеокарты, отрисовщика, сплиттера и декодера. Можно было бы предложить поиграться скрытой настройкой числа потоков, но это получилась бы пустая трата времени. Число потоков тщательно подбиралось нами, в том числе и под Phenom II x6. Тут лучше привести детали, т.е. перечислить версию видео-драйвера и используемые отрисовщик, сплиттер и декодер. Декодер, как я понял ffdShow.
3. SVP оптимизирована под AMD, начиная с версии 2.0.

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

vkams wrote:

1. С этим фильмом всё стало в порядке, а в другом ("Властелин колец" 1080р) заметил отставание видео от звука примерно на 500 мс, хотя процессор загружен меньше чем на 60%. Почему это?

Попробуйте вместо оверлея использовать вмр7 (оконный) . Сможете контролировать возникающую задержку .
На больших битрейтах бывает не справляется дисковая система . Особенно если фильм на диске С или физический диск всего один .
Т.е. при близкой к 100% нагрузке процессора - видео будет играться .....Но если возникнут пробемы - появиться рассинхрон .
Всё же разгоните хотя бы встроенный контроллер  , для Ашди будет толк .

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

MAG79 wrote:

Владимир

кто это такой? или ты случайно сказал реальное имя?

32 (edited by vivan 19-06-2011 11:10:33)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

Человек подписался своим именем в посте выше (ну и имя в профиле тоже намекает) wink

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

vivan wrote:

Человек подписался своим именем в посте выше (ну и имя в профиле тоже намекает)

блин посмотрел по диагонали, пропустил

34 (edited by Werdan 22-09-2011 10:02:45)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

Напишу и я о своей борьбе с низким индексом в Full HD. Использую Daum Pot player, аппаратное декодирование. Симптомы -  неполная нагрузка процессора, видео сильно отставало от звука. Процесcор Athlon II x4, встроенное видео HD4200. Память 2*2,  1333 Mhz. Проблема решилась только разгоном памяти и контроллера (2420 Mhz, 1611Mhz), а так же отдачей для видео 512 Mb оперативы. Так что вывод - стараться использовать дискретное видео, а то встроенное просто не может поделить пропускную способность памяти с процессором. По крайней мере у меня так.
P.S. При использовании программного декодирования проблема памяти так остро не стоит, но аппаратное позволяет освободить ~13% процессора, что в моем случае позволило использовать 13 SVP-шейдер.

35

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

Всем привет. Имею систему: Asus P5QPro, E8400 3.0Ghz, Nvidia 9600GT. Всё было бы нормально, если бы видео не отставало от звука. На некоторых видео это заметно уже на 5 минуте. Непонятно почему это происходит. Звук AC3 или DTS, идёт через цифру ( использую SPDIF выход встроенной звуковой карты на материнке) на внешний рессивер . При проигрывании того же материала без SVP звук на месте.
- Запускал DPC Latency - результат отличный, всё ровно около 130.
- попробовал снизить частоту памяти в биосе с 1000 до 800 Mhz , процессор не разогнан.
- удалил вообще утилиту EPU Engine от Asus'a ( контроль энергосбережения и разгона)
- выключил  AC3filter
- выключил CoreAVC+CUDA

Короче, не знаю что ещё может помочь... ? Загрузка процессора процентов 60-70 и звук расходится.
Прилагаю фото и всякие отчёты.
http://img13.imageshost.ru/img/2012/02/25/image_4f49294de0614_small.png
http://img13.imageshost.ru/img/2012/02/25/image_4f49294f55acf_small.png

Post's attachments

Отчёты.rar 7.41 kb, 285 downloads since 2012-02-25 

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

4nd
А на Win7 не пробовали?

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

4nd
Direct Vob Sub убрать
Рендер заменить на ovarlay/VMR9R/EVR, на картинке VMR7
И не помешал бы график производительности
В следующий раз режь скриншоты, не у всех человечий нэт!

38

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

VobSub убрал
Кстати, в DPC Latency значение 2000 только при запуске фильма. Я думаю это наверное у всех так?

Загружены следующие фильтры:

Default DirectSound Device
Enchanced Video Renderer
Audio Switcher
ffdshow video decoder
Spdifer
CoreAVC Video Decoder
Haali Media Source

После того, как поменял VMR7 на EVR стало заметно лучше, но через мин 40 просмотра всё-равно стало заметно, что потоки разошлись.

Rimsky
И не помешал бы график производительности
Какой график, может SVPmark?
http://img13.imageshost.ru/img/2012/02/26/image_4f49e6ae4bec9_small.jpg

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

4nd
Я еще в состоянии сформулировать свои хотелки

график производительности - на значке SVP ПКМ - показать - графики производительности

Попробуй убрать прослойку между хаали и фдд в виде

Spdifer CoreAVC

Скорее всего кто-то из них врет ффд о частоте кадров, а SVP берет частоту кадров из ффд

40 (edited by 4nd 26-02-2012 15:38:14)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

Rimsky
Попробуй убрать прослойку между хаали и фдд в виде Spdifer CoreAVC
Сначала убрал оба, потом обратно включил CoreAVC (с ним загрузка на процессор процентов на 20  ниже).
Поставил вместо Spdifer (это продукт от AC3Filter ) ffdshow Audio Decoder ( настроен на Pass-through).

Проверял на FullHD с родным DTS.  Через 110 мин на глаз и ухо smile рассинхронизации не заметно.

Странно, но при использовании ffdshow Audio Decoder появились лаги в DPC Latency. Привожу пример и график производительности.

http://img13.imageshost.ru/img/2012/02/26/image_4f4a1a58c2133_small.jpg

Запускал ещё несколько фильмов и заметил, что такой эффект наблюдается только в FullHD видео ( в HD всё нормально) и не зависит от цифрового формата звука (AС3 или DTS).

41 (edited by igorfd 10-05-2012 16:28:26)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

Не так давно ради интереса решил попробовать поставить последнюю версию SVP - 3.1.1. До этого сидел на 3.06 и все работало на ура при настройках - 13 шейдер, удвоение при частоте монитора 50hz + reclock, радиус поиска -16х8, до пиксела и все остальное по умолчанию. Шли любые ремуксы и блюреи без тормозов. При загрузке ЦПУ - около 85% и не больше, индекс SVP был на уровне 101-105%. На версии 3.1.1 настройки не трогал вообще, все по умолчанию. Но постоянно низкий индекс- на примере фильма Время (2011) 1080p Blu-ray [HDClub]: загрузка ЦПУ - 59%, индекс SVP - 89% со всеми вытекающими последствиями.... Система Core 2 Quad 3200mhz, 4 gb DDR, GTX560 1024 mb, драйвер - 296.10. Ось - семерка 64. Не понимаю в чем дело! Любая другая версия SVP пашет нормально, а вот 3.1 ни в какую не дружит с моей системой! Похоже придется обратно на 3,06 переходить...
Допинфо:

Параметры последнего обработанного файла видео:
Имя файла: 00882.m2ts
Размер кадра и частота: 1920x1080 pixels, 23.976 fps

Определившиеся параметры монитора
Размер экрана и частота обновления: 1920x1080 pixels, 60.001 Hz

Данные о повышении плавности видео
Коэффициент повышения плавности: 5:2
Результирующая частота видеокадров: 59.94 fps
Повтор 1 кадра каждые 16 сек (без ReClock)

Текущий определившийся профиль: 1920x1080@24

Параметры преобразования видео по профилю
[ExMethod=MSmoothFps_3]        Добавление промежуточных кадров: Адаптивный режим (по-умолчанию)
[ExAlgo=13]            SVP-шейдер: 13. Стандартный (по-умолчанию)
[Bicubic=1]            Интерполяция векторов движения: Бикубическая (по-умолчанию)
[ExMulti=MON]            Изменение частоты кадров: До частоты экрана (по-умолчанию)
[ExBlockSize=32x32:1]        Шаг сетки векторов: 28 пкс. Крупный 1
[ExRecalc=0:0]            Уменьшение шага сетки: Нет (по-умолчанию)
[TypeDist=Exh:-10:SATD]        Радиус поиска: Средний (по-умолчанию)
[ExPel=1]            Точность векторов движения: До пиксела
[Badsad=1000:0]            Повторный широкий поиск: Средний (по-умолчанию)
[ExSadml=0]            Подавление площадных артефактов: Отсутствует (по-умолчанию)
[ExBlend=false]            Построение на смене сцен: Повторять кадры (по-умолчанию)
[ExDwnResize=MON]        Уменьшение размера кадра: До размера экрана
[ExConvertFps=false]        Смешивание кадров до частоты экрана:false

Параметры по меню
[svp_libflowgpu=1]        GPU-ускорение (OpenCL): true
[ExThreads=6]            Количество потоков: 6
[HandCrop=None]            Подрезка краев: Не подрезать
[Borderlight=None]        Подсветка краев: Выключена
[VDelay=0]            Задержка видео: 0 мсек
[ExDemo=0]            Демонстрационный режим: false
[ExTearingTest=0]        Тест дрожания: false
[EFrameDoubling=0]        Аварийное удвоение: false
[StopSmoothDelayOnRewind=1]    Плавность на перемотке: Отключить на 1 сек

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

igorfd
3.1 ни в какую не дружит с моей системой! Похоже придется обратно на 3,06 переходить
Во-первых, ОБРАТНО переходить не придется, 3.0 и 3.1 работают с разными папками и не мешают друг-другу. Главное запускать их по очереди и не запутаться. Кстати, это пригодится для выяснения причин тормозов в 3.1. Для этого нужно запустить 3.0.6. Если она была удалена, то установить в ОТДЕЛЬНУЮ папку, при этом проследить, чтобы галка удаления настроек была выключена. Все настройки должны быть в целости и сохранности.

Во-вторых. Нужна для сравнения такая же допинфо по этому файлу "00882.m2ts", но из SVP 3.0.6. Поглядеть, какая там при этом загрузка ЦП и SVP-индекс.

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

декодер в обоих случаях - одинаковый или как?

44 (edited by igorfd 10-05-2012 17:14:16)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

MAG79 Попробовал. На SVP 3.05 вышеуказанный фильм - закружает ЦПУ - 65-70%, индекс 104%. Полет нормальный.
Chainik В обоих случаях смотрю через MPC-HC, вывод EVR costom, Fullscreen Direct 3d, Sarpen Complaex 2 Остальное не меняю
Допинфо по SVP 3.0.5:
Параметры последнего обработанного файла видео:
Имя файла: 00882.m2ts
Размер кадра и частота: 1920x1080 pixels, 23.976 fps

Определившиеся параметры монитора
Размер экрана и частота обновления: 1920x1080 pixels, 60.002 Hz

Данные о повышении плавности видео
Коэффициент повышения плавности: 2:1
Результирующая частота видеокадров: 47.952 fps

Текущий определившийся профиль: 1920x1080@24


Параметры преобразования видео по профилю
[ExMethod=MSmoothFps_ByPixel]    Повышение плавности: Обычное
[ExAlgo=13]            SVP-шейдер: 13. Стандартный
[ExMulti=2:1:2]            Изменение частоты кадров: Удвоение кадров (2x)
[ExMiniCount=1:1]        Размер расчетных кадров: Полный размер
[ExRad=2p]            Радиус поиска: 2 пиксела
[ExSearch=4]            Тип поиска: Шестиугольниками
[ExPel=1]            Точность прогнозирования движения: До пиксела
[ExRecalc=0]            Уточнение векторов: Не уточнять
[ExBlockSize=16x8]        Размер блоков: 16x8 пикселей
[ExOverlap=0]            Перекрытие блоков: Без перекрытия
[ExSadml=0]            Подавление площадных артефактов: Отсутствует
[ExSadgamma=0.5]        Маска площадных артефактов: Слабая
[ExBlend=true]            Построение на смене сцен: Смешивать кадры
[ExDwnResize=0]            Уменьшение размера кадра: Не уменьшать
[ExConvertFps=false]        Смешивание кадров до частоты экрана:false

Параметры по меню
[svp_libflowgpu=1]        GPU-ускорение (OpenCL): true
[ExTreads=0]            Количество потоков: Авто
[Borderlight=0]            Подсветка черных полей: false
[ExStretch=0]            Растяжение кадра: Не растягивать
[ExCrop=-1]            Подрезка краев: Не подрезать
[VDelay=0]            Задержка видео: 0 мсек
[ExDemo=0]            Демонстрационный режим: false
[ExTearingTest=0]        Тест дрожания: false
[EFrameDoubling=0]        Аварийное удвоение: false
[StopSmoothDelayOnRewind=1]    Плавность на перемотке: Отключить на 1 сек

45 (edited by gaunt 10-05-2012 18:25:30)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

igorfd
Результирующая частота видеокадров: 47.952 fps
В этом режиме нужно отрисовать 24 кадра за секунду .

В 3.1 :
Результирующая частота видеокадров: 59.94 fps
Т.е. нужно отрисовать вдвое больше кадров = 48 за секунду . Это удваивает нагрузку на процессор от построения .

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

gaunt на 3.05 на настройках по умолчанию и частоте 60гц у меня отличная производительность. А на 3.1.1 на настройках по умолчанию у меня тормоза, при том что ЦПУ задействовано на 55-59%, SVP-индекс 89%.  На моей системе настройки по умолчанию летать должны еще с некоторым запасом в виде улучшения настроек на качеству. Так что тут проблема в чем то другом. Чтобы 3.1.1 хоть как то боле-менее работало приходится выставлять минимальные убожественные настройки при которых все выглядит гораздо  хуже, чем в 3.05 на максимально тянущих настройках. Так и вот и вынужден до сих пор сидеть из-за этого на версии 3.05

47 (edited by %username% 11-05-2012 10:14:15)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

igorfd
сколько показывает SVPMark?
Результаты тестов в студию и в базу
Так же список фильтров сюда

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

igorfd
Так и вот и вынужден до сих пор сидеть из-за этого на версии 3.05
Не нужно "вынуждать" себя . Я тоже сижу на 3.0.6 , хотя необходимости нет .
В вашем случае всё ограничено встроенной видяйкой . Не парьтесь , если интересно , почитайте эту тему
http://www.svp-team.com/forum/viewtopic.php?id=476
Собственно создание этой темы преследует цель помочь настроить плавное воспроизведение для "не до" систем .
Мне же интересно , да и круглосуточно включенный комп должен быть холодным и немым . Видяйка для свп и 4 ядер не нужна . У вас 6 , такой камень у меня был , строит он не хуже ай5 .
3.1 - да , видяйка скорее обязательна . Если до 1920*800 обе версии свп ведут себя предсказуемо , то 1920*1080 ....

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

gaunt
В вашем случае всё ограничено встроенной видяйкой

GTX560

50 (edited by gaunt 11-05-2012 11:11:09)

Re: [ошибка] Низкий SVP-индекс при неполной загрузке процессора

Chainik
GTX560

Круто  smile 
Из чего следует , для начала следует отключить аппаратное декодирование - и получить проблемы с потоком вс1 .
Вернее раньше нвидиа вс1 не умела , незнаю как 560 . В общем случае это и выливается в недозагруз камня . Кодек тупо грузит практически лишь одно ядро . Декодер просто не успевает готовить кадры для уплавнения . Из софтовых декодеров вс1 лучшие результаты даст Арксофт , затем Неровидеодекодер - остальные будут предпочитать  складывать нагрузку на одно ядро .
При софтовом декодировании 264=авк проблем быть не должно . Как вариант для тс , м2тс  стоит воспользоваться встроенными фильтрами хомесинема .

Предвкушая полемику равной нагрузки ...Скажем так - у 3.0 короче конвейер , что положительно сказывается на возможностях подготовки кадра (декодировании) для последующего уплавнения .

Попутался в заборах проблем этой ветки ....У одного 6 ядер и встройка , у другого 4 ядра и встройка ,
ай3 530 и ..
Тем не менее , Werdan дал ответ :
Проблема решилась только разгоном памяти и контроллера (2420 Mhz, 1611Mhz), а так же отдачей для видео 512 Mb оперативы. Так что вывод - стараться использовать дискретное видео, а то встроенное просто не может поделить пропускную способность памяти с процессором.

И это главная проблема : 3.1 более требовательна к ПСП . Вывод про разгон шины абсолютно верный , мой ай3 только разогнанный с 133 до 200 мгц по шине способен переварить фулку . Как и амдешным камням просто глоток воздуха разгон контроллера памяти .
Правда существует альтернатива - ссылку я уже дал ....