1 (edited by Nintendo Maniac 64 10-07-2015 21:53:21)

Topic: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

Doesn't matter what format, what resolution, nor what framerate - you'll get a program crash if SVP's active video profile has the "Frames interpolation mode" set to 'Off'.

After the program hard-closes, my browser comes up with the website drdump.com and gives me the following:

https://drdump.com/DumpGroup.aspx?DumpGroupID=326054 wrote:

WARNING: Following frames may be wrong.
0x0
svpflow2+0x21ecf
svpflow2+0x21d28


Similar to my other issue, I've only tested this on a single PC currently; I'll update the status accordingly if/when I test it on a different PC.

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

hmmm.... running it on my laptop - nope, it works

need more details

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

Intel 965GMA graphics?

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

more likely I need the exact .avs script

is "outer lighting" turned on?

5 (edited by Nintendo Maniac 64 10-07-2015 22:33:24)

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

Well if it makes any difference, I actually have two laptops with Intel 965GMA graphics, so I'll definitely be testing it on said other laptop.

Chainik wrote:

more likely I need the exact .avs script

Uhhh, I'm using stock SVP 3.1.7...

Chainik wrote:

is "outer lighting" turned on?

No.

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

you DO understand that if I won't be able to repeat it - it won't be fixed, right? smile

7 (edited by Nintendo Maniac 64 10-07-2015 23:03:33)

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

Chainik wrote:

you DO understand that if I won't be able to repeat it - it won't be fixed, right? smile

I get it, but I've never touched the AVS scripts so I don't even know how to provide you with it...

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

Information -> Last used AVS script

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

Here you go:

# This script was generated by SmoothVideo Project (SVP) Manager.
# Check http://www.svp-team.com for more details.

SetMemoryMax(1024)

global threads=4
global svp_scheduler=true

LoadPlugin("C:\Program Files (x86)\SVP\plugins\svpflow1.dll")
LoadPlugin("C:\Program Files (x86)\SVP\plugins\svpflow2.dll")

SetMTMode(3,threads)
ffdShow_source()
SetMTMode(2)

global crop_params=""
global resize_string=""
global super_params="{rc:true}"
global analyse_params="{}"
global smoothfps_params="{rate:{num:1}}"

global demo_mode=0
stereo_type=0
stereo_left_selection=""
stereo_right_selection=""

########## BEGIN OF MSMoothFps.avs ##########
# This file is a part of SmoothVideo Project (SVP) 3.1
# This is NOT the full AVS script, all used variables are defined via 
# JavaScript code that generates the full script text.

function interpolate(clip src)
{
    input = crop_params=="" ? src : eval("src.crop("+crop_params+")")
    input = resize_string=="" ? input : eval("input."+resize_string)

    super=SVSuper(input, super_params)
    vectors=SVAnalyse(super, analyse_params, src=input)
    smooth=SVSmoothFps(input, super, vectors, smoothfps_params, mt=threads, url="www.svp-team.com")

    return demo_mode==0 ? smooth : demo(input,smooth)
}

input=last

    stereo_type==0 ? eval(""" interpolate(input)
""") :     stereo_type==1 || stereo_type==3 ? eval("""
        lf = interpolate(input.crop(0,0,input.width/2,0))"""+stereo_left_selection+"""
        rf = interpolate(input.crop(input.width/2,0,0,0))"""+stereo_right_selection+"""
        StackHorizontal(lf, rf)
""") :     stereo_type==2 || stereo_type==4  ? Eval("""
        lf = interpolate(input.crop(0,0,0,input.height/2))"""+stereo_left_selection+"""
        rf = interpolate(input.crop(0,input.height/2,0,0))"""+stereo_right_selection+"""
        StackVertical(lf, rf)""") : input

########### END OF MSMoothFps.avs ###########
distributor()

10 (edited by Nintendo Maniac 64 14-07-2015 22:07:47)

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

Apologies for the double-post, but using either AVS dll from the below-quoted post (which was in the same thread you linked to) fixed the issue for me, though I do still get an odd error in MPC-HC itself.

Post in question

dlr5668 @ svp-team.com/forum/viewtopic.php?pid=50963#p50963 wrote:

avs set mt https://www.dropbox.com/s/dckxoowjlzwku … 0150220.7z
avs+ http://puu.sh/iYos8/cc2b25410d.7z

close svp and player
put avs file in PLAYER folder (for example C:\Program Files (x86)\MPC-BE)
start svp and player


Errors in question

AVS MT:
http://i.imgur.com/Nj5fyAn.png

AVS +:
http://i.imgur.com/Z9wjQQW.png

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

thanks! this might be the problem - when "frames interpolation" is off, core libraries are inited with all default values
which means "gpu = on", regardless of if you actually have gpu  big_smile

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

try to replace this one

Post's attachments

svpflow2.dll 632.5 kb, 398 downloads since 2015-07-15 

13 (edited by Nintendo Maniac 64 16-07-2015 05:28:05)

Re: MPC-HC and SVP crash when "Frames interpolation mode" is set to 'Off'

Chainik wrote:

try to replace this one

Yup, that fixed it!


So that combined with the AVS MT dll and the SVPMgr.exe hotfix seems to fix all three of the issues I've been having...though I'll need more time to confirm the crash-on-seek issue since it's random.