Topic: SVP 3.1.7 Problem

Since the update, whenever I pause the video and leave it for a minute or so, it will disable the SVP on the video and if I leave for a bit longer it will crash MPC and I will have to end the task, then reopen the file. I was wondering if anyone has a fix or an option I can turn off/on to fix this, as it is very annoying and I may need to go back to the older version to be able to use it properly.

2 (edited by Nintendo Maniac 64 14-07-2015 03:53:30)

Re: SVP 3.1.7 Problem

I have a very similar problem with MPC-HC crashing while using SVP except that it can occur when I seek backwards in a video.


EDIT: For reference I am not using MadVR.

3 (edited by dlr5668 14-07-2015 00:20:35)

Re: SVP 3.1.7 Problem

try avs+ / avs mt set.
For me avs+ @win10 works amazing. I am crashing with deffault sometimes.

Re: SVP 3.1.7 Problem

I tried uninstalling all of the software to do with SVP and reinstalling, didn't seem to help. The avs+/avs mt set, I do not know what you are mentioning, could you please elaborate? I also tried to install 3.1.6 but I cannot get a hold of the older installer so I am unable to do this and cannot live with using SVP if I cannot pause without crashing/slow downs. Hopefully it is fixed in the 4.0 update whenever that comes out. I may just have to stop using SVP in the mean time.

Re: SVP 3.1.7 Problem

OK, so I found that it is the 'smoothing' option in MadVR that is causing this. I did some trial and error and found MadVR was the cause by having it off while playing a video and it worked fine after that. I then turned off some settings and when 'smoothing' in MadVR is turned off, it works as it did before I upgraded to 3.1.7. When I pause with it enabled, the frame seems to change to a different one and after a minute it seems like it disables SVP and then when I play the video it has to start again, like when you open up a video and it has to enable SVP when opened and it freezes for a moment. I am not sure whether the 'smoothing' in MadVR is of any benefit, I followed a set up guide on a forum post a while ago.

6 (edited by dlr5668 14-07-2015 03:06:21)

Re: SVP 3.1.7 Problem

Tryneal
avs set mt https://www.dropbox.com/s/dckxoowjlzwku … 0150220.7z
avs+ http://puu.sh/iYos8/cc2b25410d.7z

close svp and player
put avs file in PLAYER folder (for example C:\Program Files (x86)\MPC-BE)
start svp and player

Re: SVP 3.1.7 Problem

What is this for though?

Re: SVP 3.1.7 Problem

Tryneal
What is this for though?

just try it. you should see a difference

Re: SVP 3.1.7 Problem

I tried it and didn't see any noticeable difference. What was it supposed to do for me?

Re: SVP 3.1.7 Problem

Tryneal

When you're playing using SVP, smoothness option in madvr is unnecessary.

That option is disabled by default because that's not main purpose of madvr.

Those newest avs lib are supposed to stabilize the playback (such as fixing bug, enhance performance, reducing crash etc).
The smoothness itself is depend on your SVP setting, in turn SVP depend on those avs libs (mt version or avs+)

Especially if you have avs+ x64, you could try to play with smoothness with x64 video player because the svpflow newest version has x64 version, you need to enable it in ffdshow though.

Re: SVP 3.1.7 Problem

Tryneal
Thanks for the bug report.
Try to use this fix: SVPMgr317(72)_PlayerOnPauseCrush_fix.zip
Unpack and replace files in the SVP folder.

The problem was in one new hidden setting of SVP 3.1.7:

;Delay before disabling smoothness when player in pause state, needed for release of memory and GPU computation blocks (sec, min:10, max:300, 0 and other values - do not disable)
DisableSmoothnessOnPauseDelay=0

Delay was set to 30 if hidden setting is apsend in the hidden settings file. It is wrong. Changed to zero now. Must work.

Post's attachments

SVPMgr317(72)_PlayerOnPauseCrush_fix.zip 366.15 kb, 340 downloads since 2015-07-14 

Re: SVP 3.1.7 Problem

Thank you so much for the fix, it was already fixed before hand by me reinstalling, not sure whether you implemented the fix into the full build, but if you did it worked anyway. I applied the fix just to make sure that it was not going to come back. Thanks for the help.

Re: SVP 3.1.7 Problem

it was broken only in case of updating existing SVP 3.1.6 with 3.1.7

14 (edited by Nintendo Maniac 64 16-07-2015 05:27:10)

Re: SVP 3.1.7 Problem

dlr5668 @ svp-team.com/forum/viewtopic.php?pid=50963#p50963 wrote:

avs set mt https://www.dropbox.com/s/dckxoowjlzwku … 0150220.7z
avs+ http://puu.sh/iYos8/cc2b25410d.7z

close svp and player
put avs file in PLAYER folder (for example C:\Program Files (x86)\MPC-BE)
start svp and player

Interestingly enough, using the AVS MT dll fixed the 50->60fps stuttering issue I was having as described in my thread here:
http://www.svp-team.com/forum/viewtopic.php?id=2626

Using either DLL also fixed my MPC-HC crashing issue when SVP's interpolation mode is set to "Off" as mentioned in my other thread (though I do still get an odd error in MPC-HC itself):
http://www.svp-team.com/forum/viewtopic.php?id=2628

----------------------------------------------------------------

EDIT:

MAG79 wrote:

Tryneal
Thanks for the bug report.
Try to use this fix: SVPMgr317(72)_PlayerOnPauseCrush_fix.zip
Unpack and replace files in the SVP folder.

This did not fix my crash-on-seek issue.

EDIT 2: However, it did fix an issue on my desktop PC with Haswell graphics where the entire PC would lock up while SVP was running (the laptop with Intel 965GMA graphics did not have such an issue).

EDIT 3: I'm a derp; the "lock up entire PC" issue was because my undervolt wasn't stable and had nothing to do with SVPMgr.exe