1 (edited by xoen 03-06-2012 00:21:03)

Topic: [FIXED] "Opening video timed out" - error. and bsplayer question.

Hello, this is my first post there.
I found Your project today and i felt urge to have a try.

I enocuntered problem. tried to search forum for such issue, but no avail.

every video i am trying to use gives me SVPMgr error window with "opening video timed out".
video runs, OSD from SVP is visible(preparing smooth playing, then numbers) then fades, and trayicon turns red.
video continues to play,  normally( but i assume that svp is not affecting it).

log:

0:05:37.-344; Start: SVPMgr 3.1.1 starts...
0:05:37.-344; Start: read settings file settings.ini
0:05:37.-344; Start: load language file - English
0:05:37.-344; Start: clear Logs folder
0:05:37.-344; Start: SVPMgr folders prepare
0:05:37.-344; Start: performance graphs prepare
0:05:37.-344; Start: read settings file SVPMgr.ini
0:05:37.-344; Start: monitors settings detection
0:05:37.-344; Start: disable LNG-file write when UAC enabled
0:05:37.-344; Start: change SVP-manager priority
0:05:37.-344; Start: register hotkeys
0:05:37.-344; Start: check launched instance of SVP-manager
0:05:37.-344; Start: check Avisynth installed
0:05:37.-344; Start: get versions of modules used
ffdshow.ax/avisynth.dll: 1.1.4342.0/2.5.8.6
svpflow1/2.dll: 1.2.0.0/1.3.0.0
svpflow_cpu/gpu.dll: 1.7.1.0/1.7.2.0
0:05:37.-344; Start: refresh autostart state in registry
0:05:37.-344; Start: some more work with registry
0:05:37.-344; Start: create menu
0:05:37.-344; Start: update settings file settings.ini
0:05:37.-344; Start: update monitor settings
0:05:37.-344; Start: prepare "About the program" window
0:05:37.-344; Start: enable ffdShow waiting mode
0:05:37.-344; RefreshSVP begin
0:05:37.-344; RefreshSVP end: Waiting for ffdshow video
0:05:37.-344; Start: prepare to work is complete
0:05:37.-344; GetDimensionAndFPS_Grab start
0:05:37.-344; GetDimensionAndFPS_Grab result: 624 352 29.9699999342592
0:05:37.-344; T1T: prepare
0:05:37.-344; T1T: begin
0:05:37.-344; T1T: GetAllMediaParams
0:05:37.-344; T1T: SettingsPrepare
0:05:37.-344; T1T: Preparing smooth playback...
0:05:37.-344; T1T: WriteAllMediaParamsToIni
0:05:37.-344; application launch...
command: C:\Program Files\SVP\SVPMgr
parameters: main "C:\Users\xxx\AppData\Roaming\SVP 3.1\" 624 352 29.9699999342592 624 352 2 1
write to log: True
0:05:37.-344; RefreshSVP begin
0:05:37.-344; RefreshSVP end: Waiting for ffdshow video
0:05:37.-344; Timeout error when launch: C:\Program Files\SVP\SVPMgr main "C:\Users\xxx\AppData\Roaming\SVP 3.1\" 624 352 29.9699999342592 624 352 2 1
0:05:37.-344; T1T: SVPMgr main
0:05:37.-344; T1T: Playback
29.9699999342592 * (2.00000000753664 : 1.00000000376832) = 59.9399998685184 fps
0:05:37.-344; SetPriorityPlayer: 2
0:05:37.-344; GetDimensionAndFPS_Grab start
0:05:37.-344; GetDimensionAndFPS_Grab start
0:05:37.-344; GetDimensionAndFPS_Grab result: 624 352 29.9699999342592
0:05:37.-344; RefreshSVP begin
0:05:37.-344; RefreshSVP end: SVP is disabled

Help me, guys, i really need to see it running.
i excluded path in antivirus/firewall.

my machine:

c2d e6550@3.02ghz, 3gb of ram, gtx260, samsung syncmaster 226bw(1680x1050 native), win7.

and last question:
i am using bsplayer for YEARS i cannot live without it, can i use your set with it(i tried but program totally ignores SVP)? i am not sure how to force it to use external codecs(well, i assume it is using internal ones = waiting for video)..

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

Wait for MAG79, I can't help here but it looks like a cool new SVP Manager bug - all timestamps are equal and has negative milliseconds value  big_smile

3 (edited by xoen 02-06-2012 23:04:59)

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

ok, i'll wait,
i used  Pre-3.1.2 patch for SVP 3.1.1 , hmmm.
indeed, negative miliseconds values smile

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

xoen
negative miliseconds
I think it is a bug. Very stupid bug. I will be at home today and will try to fix it.
Thank you for the bug report.

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

Thank You for this project, sir.

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

xoen
Try this file: SVPMgr_negative_ms_fix.zip
Unpack SVPMgr.exe and replace it in SVP folder.

Post's attachments

SVPMgr_negative_ms_fix.zip 338.36 kb, 452 downloads since 2012-06-03 

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

xoen
It is not one error in the log sad

GetDimensionAndFPS_Grab result: 624 352 29.9699999342592
29.9699999342592 * (2.00000000753664 : 1.00000000376832) = 59.9399998685184 fps

I see it is round trouble. Wrong tails marked by red.

What your computer configuration (CPU, video adapter, monitors)?
And show log again from SVPMgr_negative_ms, please. I need correct durations of operations.

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

MAG79
What your computer configuration (CPU, video adapter, monitors)?

c2d e6550@3.02ghz, 3gb of ram, gtx260, samsung syncmaster 226bw(1680x1050 native), win7.

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

Chainik
Thanks. Now I see it. roll
Common configuration.
Then I remember it was only one danger place to work with CPU round flags in the manager. It is D3D detection of monitor settings.

xoen
Try to select monitor settings manually and save: SVP tray menu - Screen selection - Force... - Save. Reopen SVP Manager.
And try to reinstall/update DirectX to latest version (Jun'2010).

10 (edited by xoen 03-06-2012 16:45:50)

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

hmmm, now i wonder, if monitor driver i am using is ok, need to check this(and svn build you gave me to check).
also, it seems that i am using beta nvidia driver, maybe it's 59hz bug, hmm.

i will post results when i am on desktop machine.

btw, guys, you are awesome.

upd: holy damn, it seems to work.
no errors this time, green trayicon is shining now,
i need to configure it properly, i assume.
this is first thing that is almost too demanding for my machine.

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

What you did?

12 (edited by xoen 03-06-2012 21:29:37)

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

sorry for late answer, i was off to second machine(to test thing and watch some movies).

i just used your fix.

what is weird i am still having that error, but very rarely(re-enabling usually helps now).
but whole thing works, and results/effect is VERY nice.

impressive, i'd say.

also, it looks like SVP is good cpu bottleneck benchmark, since GPU is used in 16% in my case, so, i assume, that my CPU got old after 5 years of service, finally and is not able to stand with gtx260 hand by hand...
everything up to 720p runs great even with max quality settings, 1080p's are almost too demanding for max quality, some 1080p's cannot keep up with sound.

although, i am unable to fully understand cpu/gpu usage.
cpu usage goes up to 35%(per core, of course) and gpu usage is 16% while playing 1080's and problematic ones are not trying to use more power.
do you have any idea, why?
i assume, that if whole machine is strained, then any 1080p could bump to 60fps without any problem.
when i am not using GPU mode, cpu usage rises up to 65% per core. but never more.

anyway, i need to play with SVPMark, did not test it yet.

upd: i will post actual error log, if it occur, tomorrow.

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

gpu usage is "binary" is SVP - gpu is or is not enough for real-time processing

read this wink

14 (edited by xoen 03-06-2012 21:40:44)

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

nono, i know this, i meant - SVP  is good to check, if CPU is fast enough.
clearly, i can see that e6550 is dated...i'd clock it more, but i am limited by memory now;/
also, why cpu usage is not bumpin' to 100% when i see that more cpu power is needed?

i will gain more insight if i play with SVPMark, that's for sure.
i was out of hdd space to download it, imagine this(ridiculous, but true..).

wait a minute, can i use CUDA driven LAV filters instead of ffdshow?
what gain it could be?
stil 0/1? or cpu usage would be lower?

uoy know, weird questions, but i like to know how something's working.

Re: [FIXED] "Opening video timed out" - error. and bsplayer question.

Mmm, LAV is a default decoder in svp 3.1 (in bundled mpc-hc of cause). In your case hw decoder is a must.