Topic: Bad RIFE Performance

Helloo im kinda new into this RIFE AI stuff.

Im using SVP and MPC-HC (tried mpv aswell..)
I got an amd 5800x3d with rx 6900xt. I know that with amd i have to use ncnn/vulkan. Im trying to achieve 1080p 60 fps. But im getting like 1-3 fps with this settings.

I asked someone on youtube what i should do and he told me that i have to downscale. So I wanted to know if theres something else i could do other than downscaling, maybe i got some settings wrong?
So far, I tried trt_model 4.4 , 4.6, 4.9 but the performance is the same, really.

Would appreciate help greatly!! <3

Post's attachments

Screenshot 2024-02-11 101652.jpg, 64.65 kb, 503 x 582
Screenshot 2024-02-11 101652.jpg 64.65 kb, 40 downloads since 2024-02-11 

Screenshot 2024-02-11 101736.jpg, 64.87 kb, 732 x 729
Screenshot 2024-02-11 101736.jpg 64.87 kb, 44 downloads since 2024-02-11 

2 (edited by flowreen91 12-02-2024 08:10:10)

Re: Bad RIFE Performance

framo wrote:

Im trying to achieve 1080p 60 fps. But im getting like 1-3 fps with this settings.

From gerappa's answer from here https://www.svp-team.com/forum/viewtopi … 954#p83954
it seems that all AMD users should rollback their drivers to AMD driver (v23.11.1) so they can still use 2 GPU threads for ncnn/vulkan, until AMD fix their drivers.

From what i checked on my 4080 RTX, ncnn/vulkan starts to become watchable at 60 fps on a resize value of -14400810 with 2 GPU threads, with more stable fps in mpv than MPC-HC.
https://gyazo.com/3adb99245de086ace7893a941fb36cb4
which means ncnn/vulkan is overall massively underperforming compared to the NVIDIA TensorRT neural engine.

I suggest to get used to downscaling it a bit. You can always return to the non-RIFE SVP interpolation if looks bad.
If any AMD users found other workarounds, please tell us.


framo wrote:

And what are your profile settings (without rife ai) for fluid 60fps with minimal artifacts? (i dont watch anime)

Movies settings:
https://www.svp-team.com/forum/viewtopic.php?id=5624
Anime settings:
https://kokomins.wordpress.com/2019/10/ … -playback/

Re: Bad RIFE Performance

oh okay thats very sad but thank you for the advice!

And what are your profile settings (without rife ai) for fluid 60fps with minimal artifacts? (i dont watch anime)

thank you! smile

Re: Bad RIFE Performance

Has anyone found alternative solutions or workarounds for AMD users to address the underperformance of ncnn/vulkan compared to the NVIDIA TensorRT neural engine, as mentioned in gerappa's answer?

5 (edited by framo 04-03-2024 07:46:21)

Re: Bad RIFE Performance

bauch2 wrote:

Has anyone found alternative solutions or workarounds for AMD users to address the underperformance of ncnn/vulkan compared to the NVIDIA TensorRT neural engine, as mentioned in gerappa's answer?

noo but what graphics card are u using? im running quite stable with resize to 1600x0900 in SVP..

6 (edited by yongbin 04-03-2024 08:00:59)

Re: Bad RIFE Performance

I am also an AMD graphics card, but I do not have the Engine option. I am a professional graphics card from AMD, model w7800

Re: Bad RIFE Performance

yongbin wrote:

but I do not have the Engine option.

Probably you have to install it separately by right clicking the SVP icon in taskbar and going to "Utilities" -> "Additional programs and features..."
https://gyazo.com/e2d77e20209ce646d4008edca0ef854a
Then click next, click the checkbox of "RIFE Interpolation engine" then click next again.
https://gyazo.com/6eb9f3ce78489d34e70639b47747b252
Once it gets downloaded you should be able to select that option.
Overall it should interpolate much better than "Automatic" mode, but it's more performance hungry.

Re: Bad RIFE Performance

flowreen91 wrote:
framo wrote:

Im trying to achieve 1080p 60 fps. But im getting like 1-3 fps with this settings.

From gerappa's answer from here https://www.svp-team.com/forum/viewtopi … 954#p83954
it seems that all AMD users should rollback their drivers to AMD driver (v23.11.1) so they can still use 2 GPU threads for ncnn/vulkan, until AMD fix their drivers.

From what i checked on my 4080 RTX, ncnn/vulkan starts to become watchable at 60 fps on a resize value of -14400810 with 2 GPU threads, with more stable fps in mpv than MPC-HC.
https://gyazo.com/3adb99245de086ace7893a941fb36cb4/geometry dash world

which means ncnn/vulkan is overall massively underperforming compared to the NVIDIA TensorRT neural engine.

I suggest to get used to downscaling it a bit. You can always return to the non-RIFE SVP interpolation if looks bad.
If any AMD users found other workarounds, please tell us.


framo wrote:

And what are your profile settings (without rife ai) for fluid 60fps with minimal artifacts? (i dont watch anime)

Movies settings:
https://www.svp-team.com/forum/viewtopic.php?id=5624
Anime settings:
https://kokomins.wordpress.com/2019/10/ … -playback/

v23.11.1 is working fine at the speed I want. I don't even look forward to the next version update.

Re: Bad RIFE Performance

iliken wrote:
flowreen91 wrote:
framo wrote:

Im trying to achieve 1080p 60 fps. But im getting like 1-3 fps with this settings.

From gerappa's answer from here https://www.svp-team.com/forum/viewtopi … 954#p83954
it seems that all AMD users should rollback their drivers to AMD driver (v23.11.1) so they can still use 2 GPU threads for ncnn/vulkan, until AMD fix their drivers.

From what i checked on my 4080 RTX, ncnn/vulkan starts to become watchable at 60 fps on a resize value of -14400810 with 2 GPU threads, with more stable fps in mpv than MPC-HC.
https://gyazo.com/3adb99245de086ace7893a941fb36cb4/5207418

which means ncnn/vulkan is overall massively underperforming compared to the NVIDIA TensorRT neural engine.

I suggest to get used to downscaling it a bit. You can always return to the non-RIFE SVP interpolation if looks bad.
If any AMD users found other workarounds, please tell us.


framo wrote:

And what are your profile settings (without rife ai) for fluid 60fps with minimal artifacts? (i dont watch anime)

Movies settings:
https://www.svp-team.com/forum/viewtopic.php?id=5624
Anime settings:
https://kokomins.wordpress.com/2019/10/ … -playback/

v23.11.1 is working fine at the speed I want. I don't even look forward to the next version update.

Then it seems like you're having an AMD driver...did you roll back to the previous version? My laptop has NVIDIA tensor(RT) and it is extremely underperforming...