Topic: help please i cant play this file on svp

i'm using free svp v3 +mpc-hc +madvr

svp 3 doesnt smoothplay this file:
svp just says waiting for ffdshow
General
Format                         : AVI
Format/Info                    : Audio Video Interleave
File size                      : 327 MiB
Duration                       : 27mn 18s
Overall bit rate               : 1 673 Kbps
Writing application            : VirtualDubMod 1.5.10.1 (build 2366/release)
Writing library                : VirtualDubMod build 2366/release

Video
ID                             : 0
Format                         : VC-1
Codec ID                       : WMV3
Codec ID/Info                  : Windows Media Video 9
Codec ID/Hint                  : WMV3
Duration                       : 27mn 18s
Bit rate                       : 1 406 Kbps
Width                          : 704 pixels
Height                         : 396 pixels
Display aspect ratio           : 16:9
Frame rate                     : 119.880 fps
Bit depth                      : 8 bits
Compression mode               : Lossy
Bits/(Pixel*Frame)             : 0.042
Stream size                    : 275 MiB (84%)

Audio
ID                             : 1
Format                         : MPEG Audio
Codec ID                       : 55
Codec ID/Hint                  : MP3
Duration                       : 27mn 18s
Bit rate                       : 192 Kbps
Channel(s)                     : 2 channels
Sampling rate                  : 48.0 KHz
Compression mode               : Lossy
Stream size                    : 37.5 MiB (11%)
Alignment                      : Aligned on interleaves

so i just wanna ask what do i need to install to make svp3 smoothplay this file(or similar)

please help thank you

Re: help please i cant play this file on svp

What if you mux it into an MKV via mkvtoolnix?

Re: help please i cant play this file on svp

Looks like MPC-HC uses Microsoft DMO decoder to decode your WMV. It is not compatible to ffdShow and to SVP.
So, you need to switch to internal decoder LAV in MPC-HC.
MPC-HC - menu View - Options... - Internal Filters - enable WMV 1/2/3 - OK

Post's attachments

MPC-HC_internal_WMV_decoder.png, 30.3 kb, 646 x 488
MPC-HC_internal_WMV_decoder.png 30.3 kb, 368 downloads since 2016-08-24 

4 (edited by josephilip 24-08-2016 16:22:07)

Re: help please i cant play this file on svp

@MAG79
ty for replying
forgive english and literacy im a southeast asian troll
i did what you said to tick WMV1/2/3 and apply
http://oi64.tinypic.com/291dd29.jpg

but i still couldnt get svp3 to recognize the video file
http://oi63.tinypic.com/20914cy.jpg

i tried messing with ffdshow configuration(sorry im desperate to play it despite having absolutely no knowledge at all with the stuff inside the ffdshow settings or with any of these codecs or LAV or any techie stuff)
ticking libavcodec on WMV format (they were disabled "wmv"looks familiar too so i..)
http://oi68.tinypic.com/n4jmnn.jpg

ty for helping but
please help what else do i have to do to play it?

Re: help please i cant play this file on svp

@n64
thank you muxing helps! but i had to uninstall the community codecpack(after messing with the internal filter setting on the mpc fromcccp i couldnt smoothplay any video file anymore)
so i just stick with the old mpcand old addons that comes with the svp3 installer(i reinstalled everything ffdshow, sticked with old LAV



although i still want to smoothplay the original format with the latest cccp

Re: help please i cant play this file on svp

Nowadays you should only ever need LAVfilters and a compatible media player (like MPC-HC or mpv); codec packs aren't particularly useful anymore.

If for whatever reason you want a newer version of LAVfilters you can get one here:
https://github.com/Nevcairiel/LAVFilters/releases

FYI, you can just replace the files in MPC-HC's "LAVfilters" folder with a newer version and it'll "just work".

Re: help please i cant play this file on svp

josephilip
Ok. Lets try to know what filters are used in your case (AVI-file with WMV-video).
Open your file in MPC-HC - menu Play - Filters - Copy filters list to clipboard - Paste that list here.
It must be like this:

Filters currently loaded:
  - Default DirectSound Device
  - Enhanced Video Renderer (custom presenter)
  - Audio Switcher
  - ffdshow raw video filter
  - LAV Audio Decoder (internal)
  - LAV Video Decoder (internal)
  - LAV Splitter Source (internal)

8 (edited by josephilip 06-09-2016 06:46:18)

Re: help please i cant play this file on svp

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
josephilip
Ok. Lets try to know what filters are used in your case (AVI-file with WMV-video).
Open your file in MPC-HC - menu Play - Filters - Copy filters list to clipboard - Paste that list here.
It must be like this:

    Filters currently loaded:
      - Default DirectSound Device
      - Enhanced Video Renderer (custom presenter)
      - Audio Switcher
      - ffdshow raw video filter
      - LAV Audio Decoder (internal)
      - LAV Video Decoder (internal)
      - LAV Splitter Source (internal)
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
@mag
ty for reply
i did what you said, this is what i got

Filters currently loaded:
  - Default DirectSound Device
  - Enhanced Video Renderer (custom presenter)
  - Audio Switcher
  - WMVideo Decoder DMO
  - LAV Audio Decoder (internal)
  - AVI Splitter
  - File Source (Async.)

Re: help please i cant play this file on svp

WMVideo Decoder DMO

This is the cause. It prevents ffdShow to load in the filters chain.

Try to disable DMO decoders. Use Block option in MPC-HC External Filters tab.
Press 'Add Filter...' - select in the list 'WMVideo Decoder DMO' - check it - mark as 'Block' - OK

Post's attachments

Block_DMO_decoders.png, 23.09 kb, 646 x 488
Block_DMO_decoders.png 23.09 kb, 377 downloads since 2016-09-06