1 (edited by AndreaMG 04-11-2012 12:15:59)

Topic: Issues related to "Processing Threads" when set to "Auto"

Hi,

I'm running SVP with an i7-2630QM and an overlocked GTX460M.

I have two problems that are for sure related to the "number of threads" option.

1) Whenever I play a 720p video (59.940 fps) SVP kicks in and displays correctly 1:1 convertion, but by doing that unfortunately if the "number of threads" is set to "auto" there is an exact 200 ms delay in the playback! This sync issue does not occour if the number of threads is set to 4 or 8. I don't know how to solve this because I want to leave the threads to auto to mantain the full cpu power when I play 1080 videos sad

2) This one is even weirder: when I play a dvd if the threads are set to auto I have massive framedrops and the video stutters horribly, if it is manually set again to 4 or 8 threads everything is fine (except if I use Lav video decoder because I get stutters in between chapter changes).

I have no problem whatsoever when for instance I play 1080p movies and thread are set to auto; in some cases I reach the limits of my system with I think 15 active threads, and if I manually set them let's say to 8 I encounter frame drops because I'm capping the cpu, which is a thing that I obviously don't want to do.

Can you please help? It's annoyng to continuously manually switch between "8" and "auto" threads depending on what I'm watching!

Thanks. PS I would like to donate but the "donation page" is only in russian smile

Re: Issues related to "Processing Threads" when set to "Auto"

AndreaMG

I dunno what to say  hmm  sounds extremely wiered
What if set 9,10,11,... threads?

but the "donation page" is only in russian
really? smile i see only one link in russian at the top of the page

Re: Issues related to "Processing Threads" when set to "Auto"

Ok, I made some more tests for my problem (out of sync video whenever occurs a "1:1 convertion" and constany stuttering while playing every dvd):

if I manually set the threads to 2, 3, 4, 5, 6, 7, 8, 9, 10 everthing is fine;

if I set them to either Auto or 11, 12, 13, 14, 15, 19, 30, 38 the problem occours... sad  sad  sad

Do you think it could be related to the avisynth.dll?

What do you suggest to try?

If it helps I saw someone had similar problems in the past:
http://www.svp-team.com/forum/viewtopic.php?id=682
http://www.svp-team.com/forum/viewtopic.php?id=588

PS the link is in russian wink
https://www.paypal.com/ru/cgi-bin/websc … 47f193f8fd

Thanks again! smile

Re: Issues related to "Processing Threads" when set to "Auto"

AndreaMG
More threads make more memory use.
1. How much memory you have? May be it is free memory issue?
2. What size of your pagefile?
3. What CPU usage when fine and when audio delayed?
4. Do you know if your DVD is interlaced or not?

Re: Issues related to "Processing Threads" when set to "Auto"

AndreaMG
the link is in russian
and now?

6 (edited by AndreaMG 04-11-2012 16:18:37)

Re: Issues related to "Processing Threads" when set to "Auto"

Thanks Mag

1) 8GB

2) Pagefile dimension is set to default values (windows 7 64bit): virtual memory (paging): 8169. Is it ok? hmm

3) When audio delayed playing 720@59.40 (threads set to auto):
Pyshical memory
Total: 8169
Cache: 5432
At disposal: 5417
Free: 40
Kernel Memory
Paging: 507
Non paging: 117
Same file with threads manually set to 4 gives me very similar results...

4) progressive

Keep in mind that I play even very havy stuff (1080i 38mbps) with SVP motion interpolation without any problem!!

Thanks again smile

Re: Issues related to "Processing Threads" when set to "Auto"

Chainik wrote:

AndreaMG
the link is in russian
and now?

Now it works smile

Re: Issues related to "Processing Threads" when set to "Auto"

AndreaMG
With your memory size all is good. Pagefile is good too.
I want to know CPU usage in percents (not memory usage). smile How many when fine and when audio delayed?

In case with DVD it is 99% splitter and decoder issue.
Try to change it. In MPC-HC: Edit > Options... > Internal filters.

Re: Issues related to "Processing Threads" when set to "Auto"

Thanks Mag,

The CPU percentage usage when I play 720p is neglectable (around 7%) because SVP is not intepolating anything, the problem is at the beginning of the movie shortly after the OSD message "Playback 59.94*(1:1)=59.94" appears, by doing that SVP (if threads are seto to auto or above 10) screws the sync between audio and video exactly by 200ms sad during playback there are no framedrops at all, only the tedious sync issue smile

As far as the dvd blayback I already tried various things: I changed the video render from madVR to EVR, I tried hardware decoders (LavVideo CUDA and cyberlink Video/SP decoder) and software decoders (MPCHC internal filters), nothing..., the issue thread related is always there...what do you suggest to try?

Thanks again smile

Re: Issues related to "Processing Threads" when set to "Auto"

avisynth.dll version?

Re: Issues related to "Processing Threads" when set to "Auto"

It is 2.5.8.0

Re: Issues related to "Processing Threads" when set to "Auto"

while I've no idea about the issue, please attach all the logs / scripts here (from "Information" sub-menu) after playing 60fps 720p video with "auto" threads

Re: Issues related to "Processing Threads" when set to "Auto"

Chainik wrote:

while I've no idea about the issue, please attach all the logs / scripts here (from "Information" sub-menu) after playing 60fps 720p video with "auto" threads

Thanks smile

Post's attachments

debuginfo.txt 1.68 kb, 778 downloads since 2012-11-04 

Last used script.txt 717 b, 688 downloads since 2012-11-04 

Log.txt 2.25 kb, 685 downloads since 2012-11-04 

14 (edited by AndreaMG 04-11-2012 20:54:59)

Re: Issues related to "Processing Threads" when set to "Auto"

Chainik wrote:

while I've no idea about the issue, please attach all the logs / scripts here (from "Information" sub-menu) after playing 60fps 720p video with "auto" threads

Here is the log that showed up after the various tests I made today when I rebooted the pc. Is it bad as it looks judging by its size? big_smile
Thanks smile

Post's attachments

LastErrorLog.zip 99.31 kb, 846 downloads since 2012-11-04 

Re: Issues related to "Processing Threads" when set to "Auto"

AndreaMG
from debug.info:

Filename: 720 Avril Lavigne - Girlfriend_+_Interview_28The_View_20070528_29__new_.ts
Frame size and frame rate: 1280x720 pixels, 59.94 fps

Why you using SVP? You not need it for such video. Video is already have 59.94 fps (after deinterlacing).

Detected screen parameters
Screen size and refresh rate: 1920x1080 pixels, 59 Hz

This is bad. SVP coldn't determine precize refresh rate using D3D. Have you DirectX (jun'2010) installed?

from LastErrorLog.txt:

12:04:21.990; Frame size 720x576 instead of 1440x1152
(C:\Users\Cloud\AppData\Roaming\SVP 3.1\AVS\ffdshow.avs, line 10)
(ffdshow_filter_avisynth_script, line 4)

It is an old error which is fixed many many versions ago. How did you get that? hmm

18:17:04.114; ===== Playback
25 * (5 : 2) = 62.5 fps

Frame rate is higher than monitor refresh rate.
It may cause desync video from audio or video drops or little audio stops to save synchro with video.

16 (edited by AndreaMG 06-11-2012 08:40:26)

Re: Issues related to "Processing Threads" when set to "Auto"

Thanks @MAG smile

1)"Why you using SVP? You not need it for such video. Video is already have 59.94 fps (after deinterlacing)"

I do not understand. SVP icon is always active (waiting for ffdhow video), whenever I play a video it starts and in case of files such 720p59 should not interpolate. In my case in fact it does not interpolate but it kicks in anyway and while doing that it screws the audio sync. I obviously know that I don't need SvP for such videos but you understand that i cannot continuously turn on and off SVP depending on the fps of the videos I'm watching smile Did you succeed to reproduce the issue on your system or is it only my thing??

2) "This is bad. SVP coldn't determine precize refresh rate using D3D. Have you DirectX (jun'2010) installed?"

Thanks, as soon as I go back home I'll check and reinstall the whole directx versions:)

3) "It is an old error which is fixed many many versions ago. How did you get that? hmm"

How should I know? You are the programmer wink

4) "Frame rate is higher than monitor refresh rate.
It may cause desync video from audio or video drops or little audio stops to save synchro with video."

Thanks. Can you please tell me the video title that caused this issue?

Re: Issues related to "Processing Threads" when set to "Auto"

AndreaMG
i cannot continuously turn on and off SVP depending on the fps of the videos I'm watching
You can do it manually. Crtl-Win-Alt-P (Red SVP icon is indicator).

Did you succeed to reproduce the issue on your system or is it only my thing??
Give me please one problem description, one file and one settings set (debuginfo.txt). When I will try. smile

How should I know?
Other words: what you did before "Frame size" error appears?

Can you please tell me the video title that caused this issue?
Unfortunately no. It is "spy free" log: no personal info, no file titles, only time. You can find (remember wink ) it yourself by time, size and framerate: 18:17:04, 720 x 576 @ 25 fps

Re: Issues related to "Processing Threads" when set to "Auto"

obviously we've a little misunderstanding here  big_smile

AndreaMG
I'll try to reproduce your issue very soon.

BTW:
I changed the video render from madVR to EVR, I tried hardware decoders (LavVideo CUDA and cyberlink Video/SP decoder) and software decoders (MPCHC internal filters), nothing

did you tried another video player? hmm Daum PotPlayer for example

Re: Issues related to "Processing Threads" when set to "Auto"

Yeah, I think I can see it.
Sometimes with large number of threads CPU usage raises (from 20% to 80% in my case). And this's is totally unnormal.

Re: Issues related to "Processing Threads" when set to "Auto"

big_smile
I have an explanation.
Look at "Performance graphs" window's status bar while playing 60 fps video. There's source fps value there.
Is it standing at some number (59.94) or changing every second somewhere between 59.0 and 61.0?

21 (edited by AndreaMG 06-11-2012 20:08:29)

Re: Issues related to "Processing Threads" when set to "Auto"

Hi guys, thanks for the support,

I did some more tests (with the limited time I had today). First of all I reinstalled the DirectX (jun'2010) as MAG suggested and now 720p video playback with threads set to auto seems fine smile  smile  I have to do some more testing but it should be ok now (at least I hope so smile ).

The only thing that remains is the brief freeze at the beginning of the video when SVP tries to connect and detects 1:1. One question: if I create a profile ad hoc for this format and tell SVP not to intervene I get the osd message (and consequently the freeze) all the same, is it right? It should be awsome to be able to eliminate this freeze.

The dvd playback with lav video is still broken (it stutters horribly with SVP and threads set to auto) but with cyberlink decoder seems fine, even during chapters changes (I have some more tests to do though this night...)

For now thank you and keep up the good work

PS @Chainik, I have to run some tests on CPU usage, but I can tell for sure that while playing blu-rays with very demanding SVP settings (MadVR render) if I set threads to 8 my cpu is about 50%, but I get framedrops and OSD message low performance, if I set threads to auto, my cpu hovers to even 90% (semi-costant turboboost) but I do not have frame drops, even if the system is stressed

22 (edited by AndreaMG 06-11-2012 20:16:04)

Re: Issues related to "Processing Threads" when set to "Auto"

Chainik wrote:

big_smile
I have an explanation.
Look at "Performance graphs" window's status bar while playing 60 fps video. There's source fps value there.
Is it standing at some number (59.94) or changing every second somewhere between 59.0 and 61.0?

When not in fullscreen (720 windowed mode) I get always the 59.94 message, while in fullsceen I don't know how to call the performance graphs big_smile

Re: Issues related to "Processing Threads" when set to "Auto"

AndreaMG
if I create a profile ad hoc for this format and tell SVP not to intervene I get the osd message (and consequently the freeze) all the same, is it right?

yeah, cause even with "frames interpolation mode" = "off" svp still can do some magik like black borders lighting and/or cropping/resizing, which means the video is still processed through Avisynth

I get always the 59.94 nessage

well then it's another bug I've just found  big_smile

24 (edited by AndreaMG 06-11-2012 20:38:22)

Re: Issues related to "Processing Threads" when set to "Auto"

Sorry, I just realized that the "-200ms video delay option" was set on SVP, that's why the videos seemed fine mad Now i'm going to bed, tomorrow I will run some more tests... smile

Re: Issues related to "Processing Threads" when set to "Auto"

Hi,
I tried various things and the issue is still there ... I noticed though that while playing 720p59 videos when threads are set to auto avisynth box indicates buffer back/ahead "15/18" and I get the audio delay, but if I press the "use current" button buffer back/ahead drops to "0/something" and the audio delay is gone even with threads set to auto! How do you explain it? Keep in mind that buffer back/ahead "15/18" does not create any issue when SVP is actually interpolating.

Can you please explain me how the thread number and buffer back/ahead are related?

Is there a way to tell SVP not to set those buffer back/ahead values while playing material that does not need to be interpolated?

Is there a way to automatically block SVP for such files?

Thanks smile