myfakeacc wrote:

I guess interpolation of 1920*1080*2 is not gonna happen on a Iris 5100. Tried lower res videos?

Where did you see that? Because the monitor is 60Hz, so there shouldn't be any interpolation happening at all, just a straight pass-through.

Chainik wrote:

> Trying to play a native 60FPS YouTube video with mpv. Whenever I have SVP enabled, I get a stuttery mess. Just disabling/kill SVP and it's buttery smooth.

too few information

I know, but I don't know what to provide though. I'm not familiar with Mac debugging tongue

All right, let's try this again:

Specific video in question:
Macbook Pro 13-inch Retina Mid-2014, macOS Sierra 10.12.3

MPV 0.23.0 config:


mpv --version output:

mpv 0.23.0 (C) 2000-2016 mpv/MPlayer/mplayer2 projects
 built on Wed Jan 25 10:34:21 ICT 2017
ffmpeg library versions:
   libavutil       55.34.100
   libavcodec      57.64.101
   libavformat     57.56.100
   libswscale      4.2.100
   libavfilter     6.65.100
   libswresample   2.3.100
ffmpeg version: 3.2.2

SVP console log:

11:24:59.783 [i]: VideoPlayer: mpv connected, waiting for the video info...
11:25:00.314 [i]: VideoPlayer: mpv 0.23.0
11:25:03.506 [i]: Media: video looks like some kind of stream
11:25:03.506 [i]: Media: video 1920x1080 [PAR 1.000] at 60.000 fps [constant] (via video player)
11:25:03.506 [i]: Media: codec type is h264 (H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10), nv12
11:25:03.522 [i]: Playback: starting up...
11:25:03.526 [i]: Playback [4347fa4d]: resulting video frame 1920x1080
11:25:03.527 [i]: Playback [4347fa4d]: 1 acceptible profiles, best is 'Automatic' [0]
11:25:03.527 [i]: Playback [4347fa4d]: enabled while video is playing
11:25:03.528 [i]: Profile: using auto values [13]
11:25:03.541 [i]: Playback [4347fa4d]: playing at 60 [60 *1/1]
11:25:10.725 [i]: Playback [4347fa4d]: full screen mode activated
11:25:19.622 [i]: Playback [4347fa4d]: disabled while video is playing
11:25:19.622 [i]: Playback [4347fa4d]: deleted

mpv log without SVP (smooth):

mpv\?v\=iErlDGSZc7w --no-resume-playback
 (+) Video --vid=1 (*) (h264)
 (+) Audio --aid=1 --alang=eng (*) 'DASH audio' (opus) (external)
AO: [coreaudio] 48000Hz stereo 2ch floatp
Using hardware decoding (videotoolbox-copy).
VO: [opengl] 1920x1080 nv12
(Buffering) AV: 00:00:16 / 00:13:17 (2%) A-V:  0.000 Dropped: 6 Cache:  0s+7KB

mpv log with SVP (stuttery mess):

mpv\?v\=iErlDGSZc7w --no-resume-playback
 (+) Video --vid=1 (*) (h264)
 (+) Audio --aid=1 --alang=eng (*) 'DASH audio' (opus) (external)
AO: [coreaudio] 48000Hz stereo 2ch floatp
Using hardware decoding (videotoolbox-copy).
VO: [opengl] 1920x1080 nv12
AV: 00:00:00 / 00:13:17 (0%) A-V:  0.000 Cache:  0s+0KB
Opening video filter: [vapoursynth file=/Users/trandoanhung/Library/Application Support/SVP4/scripts/ buffered-frames=4 concurrent-frames=7]
Using conversion filter.
AV: 00:00:00 / 00:13:17 (0%) A-V:  0.282 Cache:  0s+0KB
VO: [opengl] 1920x1080 yuv420p
AV: 00:00:00 / 00:13:17 (0%) A-V:  0.476 Dropped: 10 Cache:  0s+0KB

Audio/Video desynchronisation detected! Possible reasons include too slow
hardware, temporary CPU spikes, broken drivers, and broken files. Audio
position will not match to the video (see A-V status field).

AV: 00:00:12 / 00:13:17 (1%) A-V: 12.234 Dropped: 546 Cache: 10s+513KB
[ffmpeg] tls: IO Error: -9806
AV: 00:00:19 / 00:13:17 (2%) A-V: 20.006 Dropped: 840 Cache: 10s+10MB

Trying to play a native 60FPS YouTube video with mpv. Whenever I have SVP enabled, I get a stuttery mess. Just disabling/kill SVP and it's buttery smooth.


(10 replies, posted in Using SVP)

The issue occurs as long as ffdshow raw is enabled. Without it DXVA2 works fine.


(10 replies, posted in Using SVP)

MAG79 wrote:

What if you select output 8bit YV12 only in LAV?

Same problem still happens.


(10 replies, posted in Using SVP)

The video in question is 60FPS, so I'm not sure why you're talking about 120FPS.

What I'm trying to do is to interpolate from 60FPS to 144FPS.

One thing to note is that even if I have SVP disabled or turn off frame rate conversion, the symptoms still happen. The only way I can get it to play nice is to remove ffdshow raw filter.


(10 replies, posted in Using SVP)

All Pascal GPUs have that capability built in. … 493.0.html


(10 replies, posted in Using SVP)

Trying to get this file to play nice. Using LAV Filters CPU decoding, SVP works perfectly. But when using LAV Filters DXVA2-CP, all hell break loose.

The render queue will stay nice and full, but the decoder queue drops like a rock, causes a stall, fill up and repeat. SVP Index shows 0.57 while not even 20% of the CPU is used. Changing automatic quality slider doesn't make a difference. When CPU decoding is used and SVP works, CPU is fully used and performance changes with the quality slider.

Behavior happens whether SVP has GPU acceleration on or off.

Using GTX 1070 and drivers 375.70, with a 4.4GHz i7 5820k. Player is MDPN 64 bit.


(70 replies, posted in Using SVP)

I think NVIDIA fixed this because on Windows 10 64 bit, I can finally use CUDA decoding AND GPU accelerated SVP now.

Currently running 64 bit version of SVP.


(4 replies, posted in Using SVP)

Yep. Seems like setting thread count at 13 I get perfect playback. 23 I get stutters.

If it works, there's no point in increasing the thread count, is there?


(4 replies, posted in Using SVP)

My system specs:
i7 5820k @ 4.375GHz
16GB DDR4 2666MHz RAM
GTX 970 @ 1490MHz/7800MHz

Without GPU acceleration enabled, running using CUVID decoding or DXVA CP or native and hardware/YADIF deinterlacing results in very smooth playback.

However, when I try GPU acceleration enabled, with DXVA copyback/native and YADIF deinterlacing, result is very stuttery even though media player reports 60FPS in both cases.

CPU usage is not even close to 30%, GPU usage maxed out at around 70%.

CPU only:
GPU accelerated:


(70 replies, posted in Using SVP)

SVP4 works fine with Windows 10. Just don't enable GPU acceleration.


(2 replies, posted in Using SVP)


It seems to be something between SVP and MPDN's reclock script. I'll ask the MPDN guys  big_smile


(2 replies, posted in Using SVP)

I'm having a problem with SVP on W10. Even though the settings I use nowhere near tax my system, after a few seconds of perfect playback SVP causes a lot of dropped/delayed frames, even though everything seems to be ok.

I see that when this happens, the video frame rate drops from 59-60Hz, sometimes all the way down to 30Hz.


(25 replies, posted in Using SVP)

Anyone using SVP 3.1.7 + AVS+ + MPDN? I'm getting freezes when pausing when using this combo, weird  hmm


(25 replies, posted in Using SVP)

How are you supposed to use 3.1.7 with Avisynth+? It seems all checks are still for Avisynth hmm

Do I still need Avisynth installed? Cause otherwise I can't even install SVP core.


(8 replies, posted in Using SVP)

I'd say switch from madVR to MPDN. I've been using NEDI + SuperRes and while I can't see obvious quality changes, the performance cost is much lower.

As for madVR before SVP, that'll just be pointless. Why? Because you'll be stuck with identical frames for huge periods, which destroys smoothness. 8ms refresh time and 41ms render time means 5 identical frames before the next frame show up. Why would you even need SVP, then? The point of frame interpolation is to have as many frames out with minute changes as possible to create the illusion of smoothness, right? You'll just get a stuttery mess is what I think will happen.

It's like gaming, what you're describing. Either you lower settings to a point where 120Hz is possible, or you live with lower frame rates. You can't really have both.


(2 replies, posted in Using SVP)

Can we have a setting where we choose the default resolution + container to be autoplayed? I found out that with MP4, the duration is messed up, but VP9 works 100% of the time. However, autoplay always open MP4.


EDIT: Oops, I did not notice that VP9 is preferred when showing only MP4 and VP9. How about for all formats, then?