Re: SVP 4 Linux

lukesamuel
> but shows an error which would seem to confirm it is using beignet

this is not an error but a warning

> Is it a bug in the system performance testing process?

probably yes...

277 (edited by starks 16-02-2020 05:13:38)

Re: SVP 4 Linux

Chainik wrote:

https://github.com/RadeonOpenCompute/RO … /issues/59

Image support is supplied by a closed-source component of the ROCr runtime (libhsa-ext-image64.so) that is part of the hsa-ext-rocr-dev package

I have image support on my 7730M OpenCL driver, but that doesn't seem to be enough. And I don't expect ROCr to work on anything older than the 200 series.

278

Re: SVP 4 Linux

Chainik wrote:

lukesamuel
> but shows an error which would seem to confirm it is using beignet

Performance test did crash for me too on Haswell with Beignet. In theory it
works (according to mpv/SVP), however I didn’t see much of a
performance boost, if any. Beignet is an old unmaintained OpenCL
implementation, which was removed from Gentoo repositories lately for
that reason. Intel-neo however, which supports Broadwell onwards,
gives quite much of a performance boost on my Skylake laptop. For that
reason I doubt, that Beignet really works. I have a dedicated card now
(Navi14).

I can’t seem to get that to run either however.  I have image support
and the performance test runs through just fine with GPU OpenCL.  Also
SVP gives no errors/warnings whatsoever.  If I turn GPU based OpenCL
on, mpv gets broken command line arguments, which does not happen on
CPU based interpolation.

mpv breaks with:

mesa: CommandLine Error: Option 'help-list' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options

My setup:
mpv 0.32.0
Vapoursynth 49
Kernel 5.6.3 (proper Navi14 support)
Mesa 20.0.6
Rocm 3.3.0
hsa-ext-rocr 1.1.30300.0 (image support)
LLVM 9.0.1

The LoadLib failures in clinfo.log are warnings. The aqlprofile library is an
optional package. [1] I could not find anything except [2] on
libhsa-ext-finalize64, which states, that it is an old library dropped
in Rocm 1.9. Besides that, these warnings were not present in 3.0.0,
which also failed with the above CLI arg error and again: the
performance test runs through without errors and GPU based OpenCL
enabled.

Any ideas? Maybe Rocm needs a quirk? I’ll attach the usual logs (mpv,
SVP, clinfo).

[1]: https://www.phoronix.com/forums/forum/l … 4-17/page2
[2]: https://github.com/RadeonOpenCompute/RO … -421691921

Post's attachments

clinfo.log 10.33 kb, 9 downloads since 2020-05-08 

mpv.log 2.41 kb, 12 downloads since 2020-05-08 

svp.log 4.17 kb, 14 downloads since 2020-05-08 

Re: SVP 4 Linux

> LLVM ERROR: inconsistency in registered CommandLine options

Something about LLVM, or linking with LLVM. Google this error, there're bunch of references.
Dunno how we could help here.

280 (edited by AutumQueen92 18-05-2020 10:08:09)

Re: SVP 4 Linux

Got these errors on Kubuntu 20.04

MPV and VLC force closes.
I can see VLC in my icon tray but it is not responding

Post's attachments

active.log 3.45 kb, 15 downloads since 2020-05-18 

Re: SVP 4 Linux

> VLC: unsupported color format, switch to software video decoder

do what it tells big_smile

> Video: error launching C:\Program Files (x86)\SVP 4\mpv64\mpv.exe

no idea how you managed to put this path into main.setup.player, but just clear it

Re: SVP 4 Linux

Hello there,

I'm using elementary OS, and at the end of the mpv with vapoursynth installation i got this error.

 "The project was not configured: run "waf configure" first!"

When i try to enable the SVP with VLC it does not work, it says that i need to install the vlc support or check the vapoursynth install.
SMPlayer does not work also.

Re: SVP 4 Linux

then you must fix the build error(s) first
either you're doing something wrong or missing some dependency

284 (edited by pezgui 19-05-2020 06:51:52)

Re: SVP 4 Linux

Installed ubuntu this time, and no error on the install stage.

now when playing a video on SMplayer i got this:

 Playback [21645d50]: enabled while video is playing
 Profile: using automatic profile #1 /film
 Playback [21645d50]: playing at 143.856 [29.97 *24/5] 
 Profile: using automatic profile #1 /film
 Playback [21645d50]: playing at 143.856 [29.97 *24/5] 
 Profile: using automatic profile #1 /film
 Playback [21645d50]: playing at 143.856 [29.97 *24/5] 
 Profile: using automatic profile #1 /film
 Playback [21645d50]: playing at 143.856 [29.97 *24/5] 
 Playback [21645d50]: VS - Script evaluation failed:
 Playback [21645d50]: VS - File reading exception:
 Playback [21645d50]: VS - [Errno 13] Permission denied: '/root/.local/share/SVP4/scripts/21645d50.py'
21:02:30.936 [E]: Playback [21645d50]: VS - could not init VS

My root folder there is a big X on it, could this be the problem, SVP needs permission, and if yes, how can i do it? THanks.

Re: SVP 4 Linux

No idea why you're running SVP as root... You probably should stick with Windows instead wink

286 (edited by subluminal 20-06-2020 09:09:52)

Re: SVP 4 Linux

I am getting a vapoursynth script evaluation error in normal playback using mpv in Kubuntu 20.04. I compiled zimg, vapoursynth, ffmpeg and mpv yesterday (Using your guide in SVP:Linux section) and compilation went without a hitch. However SVP doesn't work. It was working fine the last time I compiled, about a month ago. Something has changed in vapoursynth or mpv that has broken SVP.

@Chainik, Any suggestions?

SVP works perfectly in MX Linux, my 2nd distro. And I'm current in MX so I can't paste the log. Will do so when I'm in Kubuntu.

P.S. The website guide should perhaps also mention enabling openssl and nonfree as ffmpeg options for online stream playback??

Re: SVP 4 Linux

logs, errors...?

288 (edited by LinuxBaby 20-06-2020 13:08:42)

Re: SVP 4 Linux

Hi. I'm trying to move away from Windows and after the entire night installing dependencies, I managed to build mpv with VapourSynth enable.
Now I am getting this error and no amount of googling has given me any advice:

09:38:29.811 [i]: VideoPlayer: mpv [mpv] connected, waiting for the video info...
09:38:30.342 [i]: VideoPlayer: mpv 0.32.0-563-gdc24a437fb /via '/tmp/smplayer-mpv-3ba82'
09:38:30.875 [i]: Media: video looks like some kind of stream
09:38:30.875 [i]: Media: video 1280x720 [PAR 1.000] at 30.000 fps [constant] (via video player)
09:38:30.875 [i]: Media: codec type is h264 (H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10), YUV420P, BT.709 BT.1886
09:38:30.912 [i]: Playback: starting up...
09:38:30.919 [i]: Playback [f140068c]: resulting video frame 1280x720
09:38:30.919 [i]: Playback [f140068c]: 1 acceptible profiles, best is 'Automático' [0]
09:38:30.920 [i]: Playback [f140068c]: enabled while video is playing
09:38:30.921 [i]: Profile: using automatic profile #1 /film
09:38:30.933 [i]: Playback [f140068c]: playing at 60 [30 *2/1] 
09:38:31.180 [E]: Playback [f140068c]: VS - Script evaluation failed:
09:38:31.180 [E]: Playback [f140068c]: VS - Python exception: Cache: nodes foreign to this core passed as input, improper api usage detected
09:38:31.180 [i]: Playback [f140068c]: disabled while video is playing
09:38:31.185 [i]: Playback [f140068c]: deleted
09:38:31.180 [E]: Playback [f140068c]: VS - Script evaluation failed:
09:38:31.180 [E]: Playback [f140068c]: VS - Python exception: Cache: nodes foreign to this core passed as input, improper api usage detected

Is something wrong with SVP's generated script? I have no idea how VapourSynth's scripts work... Please, help me!

Further info:

Ubuntu 20.04

mpv

$ mpv
mpv 0.32.0-563-gdc24a437fb Copyright © 2000-2020 mpv/MPlayer/mplayer2 projects
 built on Sat Jun 20 09:18:08 -03 2020
FFmpeg library versions:
   libavutil       56.31.100
   libavcodec      58.54.100
   libavformat     58.29.100
   libswscale      5.5.100
   libavfilter     7.57.100
   libswresample   3.5.100
FFmpeg version: 4.2.2-1ubuntu1

VapourSynth

$ vspipe --version
VapourSynth Video Processing Library
Copyright (c) 2012-2020 Fredrik Mellbin
Core R50
API R3.6
Options: -

python3 vapoursynth installed

$ python3 -m pip install vapoursynth
Requirement already satisfied: vapoursynth in ./.local/lib/python3.8/site-packages (50)

Re: SVP 4 Linux

I am getting the same error message as LinuxBaby.

VS - Script evaluation failed:

VS - Python exception: Cache: nodes foreign to this core passed as input, improper api usage detected

Re: SVP 4 Linux

The relevant portions of the mpv verbose log.

[user_filter_wrapper] Setting option 'buffered-frames' = '4' (flags = 0)                 
[user_filter_wrapper] Setting option 'concurrent-frames' = '5' (flags = 0)               
[vapoursynth] using 5 concurrent requests.                                               
[vf] User filter list:                                                                   
[vf]   vapoursynth (vapoursynth.00)                                                      
[vf] [vapoursynth] 640x480 yuv420p bt.601/bt.601-525/bt.1886/limited/display SP=1.000000 CL=mpeg2/4/h264                                                                          
[vapoursynth] initializing...
[vapoursynth] Script evaluation failed:
[vapoursynth] Python exception: Cache: nodes foreign to this core passed as input, improper api usage detected
[vapoursynth] 
[vapoursynth] Traceback (most recent call last):
[vapoursynth]   File "src/cython/vapoursynth.pyx", line 2241, in vapoursynth.vpy_evaluateScript
[vapoursynth]   File "src/cython/vapoursynth.pyx", line 2242, in vapoursynth.vpy_evaluateScript
[vapoursynth]   File "/home/sayan/.local/share/SVP4/scripts/d0001550.py", line 56, in <module>
[vapoursynth]     smooth =  interpolate(clip)
[vapoursynth]   File "/home/sayan/.local/share/SVP4/scripts/d0001550.py", line 30, in interpolate
[vapoursynth]     input_um = clip.resize.Point(format=vs.YUV420P8,dither_type="random")
[vapoursynth]   File "src/cython/vapoursynth.pyx", line 2071, in vapoursynth.Function.__call__
[vapoursynth]   File "src/cython/vapoursynth.pyx", line 763, in vapoursynth.mapToDict
[vapoursynth]   File "src/cython/vapoursynth.pyx", line 2069, in vapoursynth.Function.__call__
[vapoursynth] vapoursynth.Error: Cache: nodes foreign to this core passed as input, improper api usage detected
[vapoursynth] 
[vapoursynth] destroying VS filters
[vapoursynth] all requests terminated
mpv: ../video/filter/vf_vapoursynth.c:598: destroy_vs: Assertion `!p->in_node_active' failed.
Aborted (core dumped)

Re: SVP 4 Linux

try to build R50 tag instead of master
i.e.

git clone --branch R50 https://github.com/vapoursynth/vapoursynth.git

Re: SVP 4 Linux

subluminal wrote:

I am getting the same error message as LinuxBaby.

VS - Script evaluation failed:

VS - Python exception: Cache: nodes foreign to this core passed as input, improper api usage detected

I downloaded https://github.com/vapoursynth/vapoursy … R50.tar.gz from the repo's releases page instead of

git clone https://github.com/vapoursynth/vapoursynth.git

so...:

wget https://github.com/vapoursynth/vapoursynth/archive/R50.tar.gz
tar -xvzf R50.tar.gz
cd vapoursynth-R50/
./autogen.sh
./configure
make
sudo make install
cd ..

...and it worked!

Re: SVP 4 Linux

https://github.com/vapoursynth/vapoursynth/issues/594

Re: SVP 4 Linux

Built against R50 vapoursynth branch and SVP is working flawlessly again, thanks a million @Chainik and @LinuxBaby.