Installed the latest update and I noticed the Duplicate Frame Removal drop-down switched to Remove Every Other Frame. Shouldn't this stay on Don't Remove, even with Image Comparison + SCT 100% + Blend Adjacent Frames?

flowreen91 wrote:
Xenocyde wrote:

Unfortunately I can still see microstuttering

I noticed that if i exit specific background apps like TeamViewer, i suddenly get 20-30 extra fps with SVP.
I believe TeamViewer reads the memory and causes a bottleneck even when it's minimized in taskbar.

Xenocyde try to close your 200 Chrome tabs and other background apps and see if u find the specific app that causes that microstuttering. It's good to know.

I uninstalled TeamViewer and I don't use Chrome cuz it's a RAM hog crappy browser. Firefox isn't perfect, but it's far less taxing, and I don't have 200 tabs opened lol. Oh, MPC-BE is only using 32% GPU power at most in 1080p @ 60 fps, so it's at least 10% better than MPV.

Don't think background apps and processes can influence microstuttering in my case. I'll monitor background stuff too but I tend to believe that the problems are linked to encoding at unpopular fps like 25 fps or something wrong with the source.

I've done some more testing with MPC-BE. Unfortunately I can still see microstuttering, but it looks like this is linked to improperly encoded videos or weird sources. I watched the first three episodes from The Boys S4 and haven't really noticed any micostuttering. On the other hand, all the episodes from Doctor Who S9 are encoded at 25 fps and leaving x2.5 multiplier results into frame skips every few seconds. If I switch to fixed 60 fps, the skips turn into occasional microstutter (at least 3-4 per 46-minute episode).

Drakko01 wrote:
Xenocyde wrote:
Drakko01 wrote:

Why dont you try MPC HC+Madvr+Rife for the content and framerate you want , your gpu has room to spare.

Isn't VapourSynth better for RIFE? I'm just looking to get rid of the microstuttering.

I don't understand your question I use Vapoursynth  with mpchc and Rife without the problem.

Question is which renderer is better with RIFE for mitigating microstutters: VapourSynth or MadVR?

Drakko01 wrote:

Why dont you try MPC HC+Madvr+Rife for the content and framerate you want , your gpu has room to spare.

Isn't VapourSynth better for RIFE? I'm just looking to get rid of the microstuttering.

pensioner600 wrote:
Xenocyde wrote:

Will test MPC-BE for microstuttering.

If you plan to melt above 160 fps, then I recommend version 0.7.1.2172 of mpcVR. Here (and in the following messages) it’s clear why.  The developer does not fix this error and wants a high-frequency monitor))
https://mpc-be.org/forum/index.php?topi … 18#msg8818

Lol, I wish my TV could push that many fps. I'm stuck at 60 fps for the moment roll Might not even get an OLED this year either.

Drakko01 wrote:

Do you unselect avisynth , the other thing its under utilities, set environmet variables for VapourSynth

I removed avisynth altogether, only vapoursynth is enabled. But I think I screwed something up now. After reading your instructions I thought it would be a good idea to uninstall and reinstall vapoursynth via SVP. Then I did SVP menu -> Utilities -> Set environment variables for Vapoursynth and now MPC-BE triggers SPV RIFE but I only have generic 4.4 as model and the TRT drop-down is gone. Halp!

L.E.: Looks like it accidentally uninstalled MPV and TRT when uninstalling Vapoursynth. I installed TRT and MPV again but now MPV would not trigger SVP and MPC-BE displays a warning in attached image over the video image. Think I need to install new TRT.

L.L.E.: OK think I fixed it. Overwritten the vsmlrt-cuda folder and vstrt.dll with the 9.2 version and both MPC-BE and MPV trigger RIFE now. Will test MPC-BE for microstuttering.

flowreen91 wrote:
Xenocyde wrote:

how do I force MPC-BE to always start with RIFE?

Go to Options -> External Filters -> move VapourSynth Filter to top and set it as Prefer

I followed the installation steps from here, which shows Avisynth. If I select VaporSynth, the filter does not show up in the play-filter list and it does not trigger SVP at all. I remember something about registering it... I haven't used MPC in almost a year.

Drakko01 wrote:

I think the lack of G-sync/freesync support causing this.
try the options video -> frame synch -> "Sync video to display" in MPC, it may fix the problem

OK I enabled sync to display but do we leave the default 0.0012 for frequency adjustment? Also, how do I force MPC-BE to always start with RIFE? Right now it defaults to SPV Automatic every time I load a video. I've seen this before mentioned here, can't find it now.

Can't find any downloadable Fast Sync plugin for MPC. Any link for this?

dawkinscm wrote:
Xenocyde wrote:
dawkinscm wrote:

Really? What made you decide today was a good day to call me a liar?

I just want to get to the bottom of this. Was not my intent to call you a liar, I was asking for the exact options you have there because I think having Power management Mode on Normal might cause more microstutters, I'm currently testing with Prefer Maximum Power.

I made it explicitly clear that I used to make changes the NV3D but now everything is back on default. I always double check before I answer questions about my system. If I'm not sure then I usually say that I'm not sure.

OK, so Prefer maximum Power is not helping. Maybe this is not NVCP-related.

pensioner600 wrote:

Mpc-be+mpcVR. If there is a global FPS lock in nvcp, then this lock must be turned off separately on the player. I also install the ancient and forgotten fast sync on the player; it is in this scenario that it works best. Never any stuttering or skipped frames.

I had fps limit set to 60 but removed that and it does not help. I use MPV though. I'll try with MPC-BE + mpcVR and fast sync.

dawkinscm wrote:
Xenocyde wrote:

I don't really think it's possible you left everything on default, but whatever, maybe I'm asking too much.

Really? What made you decide today was a good day to call me a liar?

I just want to get to the bottom of this. Was not my intent to call you a liar, I was asking for the exact options you have there because I think having Power management Mode on Normal might cause more microstutters, I'm currently testing with Prefer Maximum Power.

flowreen91 wrote:

gpu-api=d3d11
video-sync=audio
d3d11-sync-interval=0

Ya, I tested with these enabled and I was still seeing microstutters sad

Drakko01 wrote:

Okay now I see, let's take another approach then,, remember me if you use MPC HC or MPV. Do you use in combination with Madvr. Later when I back home I share screenshot of my settings. For most useful information if you use Madvr post you control J stats. and you rendering General settings.


I use MPV so no MadVR from what I know.

dawkinscm wrote:

There's a tool that someone in this thread mentioned a few months back called NvCleanInstall  which can help. The link is here: https://www.techpowerup.com/nvcleanstall/ smile

OK, I made those two modifications with NVCleanstall, but I can still see 2-3 stutters per 40+ minute TV series episode. I don't have 3D options on default as some games require certain tweaks. Also, I don't really think it's possible you left everything on default, but whatever, maybe I'm asking too much.

flowreen91 wrote:

Xenocyde, could vsync syncing cause microstuttering then? Cause every time i try to test with video-sync=display-resample it breaks the soap opera effect on panning scenes.
Try to test with it temporarily disabled by adding these in mpv config too:

# D3D11 renderer (default) is required for the HDR playback
gpu-api=d3d11
# disable VSync
video-sync=audio
d3d11-sync-interval=0

Removing vsync wait times from the equation should allow the RIFE generated frames to be displayed realtime. Even if u set it to 120 fps on a 60 fps capped monitor. xD

Not sure if you wanted me to test with vsync disabled from Nvidia Control Panel. I turned it off there, but I was getting screen tears so had to turn it back on. I removed the # before "disable VSync" from the config file and I can still see microstutters. Let me know if that is what you wanted me to test.

dawkinscm wrote:
Xenocyde wrote:

So the headset would introduce more lag theoretically? Not sure why that matters. Anyway, what options do you have enabled/disabled in the NV 3D control panel?

No changes made to NV3D panel. I've made some (very) low level driver tweaks by disabling Multiplane Overlay and enabling Message Signalled Interrupts but I doubt they would make a huge difference.

Can you please show a pic with all the options in the 3D panel and maybe explain how to do the other two things you mentioned?

Drakko01 wrote:

I work better when I see it, can you give me an example video/scene that gives you microstutters?

Also, what display do you use?

Drivers ?

The issue is not related to a specific scene. The microstuttering happens and when I rewind to check if maybe that was an encoding frame skip, it's not there anymore. I use a 14-year old 37-inch 1080p Samsung TV (yes I know, need to get a new one, been waiting for a good OLED, but just can't pull the trigger). Drivers are the latest 555.99 from Nvidia.

dawkinscm wrote:

My CPU and RAM have minor OC tweaks but I stopped OC'in my GPU a long time ago. Yes those readings are from the Task Manager.  BTW my GPU is also transmitting the SVP+MPV processed video back to my headset.

So the headset would introduce more lag theoretically? Not sure why that matters. Anyway, what options do you have enabled/disabled in the NV 3D control panel?

dawkinscm wrote:

Nope I stop using v2 a while back.

Then not sure how you're getting that performance difference. Different components? OC-ed GPU? Some config tweaks? You're getting same readings in task manager too?

dawkinscm wrote:

HAGS should be off so that is OK. But my previous GPU readings was FHD3D downscaled. With 4K downscaled and playing full ATMOS (which also uses the GPU) my GPU hits 55%.

Are you on V2 then? I took readings from 4.15 non-V2. With 4.15 V2 or 4.17 V2 @1080p, utilization varies wildly between 40 and 60%, seems like non-V2 is more intensive but at least it stays at 60 something all the time.

flowreen91 wrote:

Try to set rife_sc to 100 in SVP so it will not cause microstuttering from repeating frames when a scene change is detected.

SC is already set to 100. I'll try with V2 and disabling vsync + adding the lines in config.

dawkinscm wrote:

The occasional micro-stutter isn't a major issue of course, but it's surprising that your GPU is hitting 67% with downscaling. For me it's around 30% with the same GPU. I use mpv player.

Haven't actually checked the 4K downscale performance since I don't have a 4K HDR TV and I only get a 4K movie when I can't find the 1080p version. 67% is for native 1080p. I don't have HAGS enabled btw.

Drakko01 wrote:

Maybe it's a stupid question, but in the nvidia control panel you have the vertical sync option enabled, if not, do it.

I will try 4.17, thanks for the suggestion. Yes, vsync is always on.

L.E.: Tried 4.17, I can still see microstuttering. Will try V2 as well.

flowreen91 wrote:

Did u try to enable Statistics in Nvidia App and check if you are giving extra breathing room for your GPU?

I have an RTX 4080 and I only play 1080p TV series or 4K downscaled to 1080p @2.5X fps with RIFE 4.15. Maximum GPU utilization I see is around 67%. Microstutters are not too often, maybe once every 15 minutes at most.

flowreen91 wrote:

Ooh by the way if u accidentally use the vsmlrt.py from 9.2 archive it will fail to find the rife_v2 folder models.Attaching below the out of the box SVP vsmlrt.py file cause it still works with 9.2 and can also find the rife_v2 folder models.

I only copied the dll and the CUDA folder.

There was a time when microstutters did not occur at all, but who even knows what version of RIFE or what drivers I was using back then.

I had TRT 9.1.2 and decided to give 9.2 a try because I was noticing some microstuttering at times. From what I can see, fast movement might be somewhat improved with 9.2, but microstuttering gets worse. Should I update to latest TRT version or is there really nothing I can do to get rid of microstuttering?

oriento wrote:
Xenocyde wrote:

RIFE 4.17 is out with no lite version. Testing now.

L.E.: Not sure what this new version is supposed to improve... I'm getting quite a bit more more fast movement artifacts compared to 4.15 and 4.16.

4.17 - 2024.05.24 | Google Drive | 百度网盘 : Add gram loss from FILM, need to fully assess the impact.

No idea what this means hmm

RIFE 4.17 is out with no lite version. Testing now.

L.E.: Not sure what this new version is supposed to improve... I'm getting quite a bit more fast movement artifacts compared to 4.15 and 4.16.

Magly wrote:

I downscale everything to 1080p so performance shouldn't be an issue, just this clip and the other movies I mentioned doesn't look like they get any interpolation visually, while everything else in 4k hdr works just fine

Maybe it's a source encoder problem. Have you tried those movies from different sources?

Magly wrote:

It only happens with the TensorRT engine of Rife, the ncnn/Vulcan version works fine but my gpu can't handle it (RTX 3080)

It happens with full movie UHD Bluray mkv rips of several of the Fast & Furious and Transformers movies and some others.

I have an RTX 4080 and full 4K movies cannot run at 48fps+ smoothly, not even on RTX 4090 afaik. If they have HDR data, even worse. I only have a 1080p screen, but I've seen people here recommending to downscale the resolution to 1440p or something similar. Tried your clip and it seems to be running at less than 24 fps (maybe 12 fps) on my RTX 4080 when enabling RIFE (TRT or Vulkan, doesn't matetr). The video gets stretched to twice the normal duration for some reason, and the sound stops in the middle of the video. Not sure what's going on with your optimization window though. Mine ran fine, saved the profile in ~40 seconds.

aloola wrote:

yes, it's the only reason we use v2
from my benchmark, v2 gives a huge fps boost

Why HAGS ON? Shouldn't turning it off provide an even bigger fps boost?